@entropy

Maybe you forgot that i have written lots of scripts to test various variants of xbmc branches, also the ones that support xvba:

http://kanotix.com/files/fix/xbmc-latest-xvba-local.txt

Needs this in case you dont have got Kanotix:

https://launchpad.net/~wsnipex/+arch...4001-5_all.deb

You can install depends as root and as user it will dl and compile it. If you update wipe out ~/dist before.

I tested xvba since the very beginning, but today i could playback my l5.1 testfile. Well i dont use fglrx all the day, i did so with an ati 9700/9800 pro but not later.