Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: looking for old ati proprietary drivers, are they gone for good?

  1. #1
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    538

    Question looking for old ati proprietary drivers, are they gone for good?

    hey, so it turns out that the extreme lag I have on some of my old HP laptops under linux is all due to a open source driver issue and since ati has dropped all support for old cards I have spent a hour or so looking for their flgx proprietary driver from circa 2007... namely the linux catalyst 7.12 (or the last one that supports RS200)

    I understand I would be stuck with a old kernel but it would still beat using XP on the HP laptops... trouble is all the links to www2.ati all the links to the files I can find are dead...

    are these drivers gone for good?

  2. #2
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,072

    Default

    You'd be stuck using old X and old libs too, basically several years old distro. Good luck getting any recent apps on that.

    Also, the r200 fglrx was extremely buggy. Like, the current fglrx ^ 15. You do not want to experience that.

  3. #3
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    538

    Default

    yes, that's what I could gather from what I red online. But right now the desktop and even the powerpc are running linx so, frankly, I would really like to get the HP laptops running linux aswel... they load the oss radeon driver just fine but it's unusable because of the lag/fallback mode etc etc


    even if it's something like ubuntu 8 as long as it's responsive I'm fine with running old versions

  4. #4
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,072

    Default

    You really should find out why it's slow rather than go for an old distro with ancient fglrx. You'd likely get even worse performance, since even current fglrx loses in 2d, back then the difference was greater.

    Ie, instead of fallback mode, install another de. Xfce, lxde, whatever.

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,441

    Default

    Is your chipset an Xpress 200 (aka rs480) for AMD processors or an rs200 for Intel processors ?

    If it's an Xpress 200 the 9.3 driver seems to be new enough (makes sense, since the GPU was a cut-down r300 core) but if it's an rs200 (which seems to be rv50 based) I didn't think we ever supported that in fglrx.

    If it's an Xpress 200 try going to http://www.amd.com, then click on Support & Drivers, then pick Motherboard & Chipsets for the first entry.

    I would argue for the open drivers as well though -- what do you mean by "lag/fallback mode" ? If it is an rn50 then you might want to try ums as a first step.

  6. #6
    Join Date
    Sep 2011
    Posts
    6

    Default

    Hi Pallidus,

    According to this page (scroll down to the bottom), the last driver supporting should be the one before V8.28.8 which is V8.27.10.

    You can find the 32bit driver here, 64bit here and, to be complete, release notes.

    Good luck
    Sceptic

  7. #7
    Join Date
    Jul 2012
    Location
    SuperUserLand
    Posts
    538

    Default

    thanks for the replies.

    Southbridge intel, this particular card is actually a IGP 345m rs200 agp from circa 2004, it was used in HP, dell and sony vaio laptops I believe. .

    In windows you have to force install drivers for IGP340 but the perfomance you get is good enough for what I want (browse the web, watch vlc videos (non hd) etc...)

    Under linux it lags painfully, cpu load is close to 100% and it crashes if you open 3 or 4 youtube tabs... video playback is choppy... I have tried them all and even lxde lags... only ones that you can manage are enlightment (so far the fastest) and openbox

    But this has got to be a driver issue and not a hw one since I have less powerful integrated graphics from nvidia on an older laptop and it doesn't lag only using the kernel drivers.

    glxgears is "194 frames in 5.0 seconds = 38.789 FPS"

    "01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon IGP 330M/340M/350M [1002:4337] "

    CONFIG_AGP=y
    CONFIG_AGP_ALI=y
    CONFIG_AGP_ATI=y
    CONFIG_AGP_AMD=y
    CONFIG_AGP_AMD64=y
    CONFIG_AGP_INTEL=y
    CONFIG_AGP_NVIDIA=y
    CONFIG_AGP_SIS=y
    CONFIG_AGP_SWORKS=y
    CONFIG_AGP_VIA=y
    CONFIG_AGP_EFFICEON=y


    display: :0 screen: 0
    direct rendering: Yes
    server glx vendor string: SGI
    server glx version string: 1.4
    client glx vendor string: Mesa Project and SGI
    client glx version string: 1.4
    GLX version: 1.4
    OpenGL vendor string: Tungsten Graphics, Inc.
    OpenGL renderer string: Mesa DRI R100 (RS200 4337) NO-TCL DRI2
    OpenGL version string: 1.3 Mesa 8.0.2

    [ 1.000992] [drm] Initialized drm 1.1.0 20060810
    [ 1.071003] [drm] radeon defaulting to kernel modesetting.
    [ 1.071044] [drm] radeon kernel modesetting enabled.
    [ 1.081338] [drm] initializing kernel modesetting (RS200 0x1002:0x4337 0x103C:0x0850).
    [ 1.081393] [drm] register mmio base: 0xD4300000
    [ 1.081396] [drm] register mmio size: 65536
    [ 1.081748] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [ 1.081750] [drm] Driver supports precise vblank timestamp query.
    [ 1.081767] [drm] radeon: irq initialized.
    [ 1.082725] [drm] Detected VRAM RAM=32M, BAR=64M
    [ 1.082732] [drm] RAM width 64bits DDR
    [ 1.086156] [drm] radeon: 32M of VRAM memory ready
    [ 1.086160] [drm] radeon: 64M of GTT memory ready.
    [ 1.086219] [drm] radeon: ib pool ready.
    [ 1.110580] [drm] fence driver on ring 0 use gpu addr 0xd8000000 and cpu addr 0xf7c2e000
    [ 1.111845] [drm] Loading R100 Microcode
    [ 1.114129] [drm] radeon: ring at 0x00000000D8001000
    [ 1.114156] [drm] ring test succeeded in 1 usecs
    [ 1.114645] [drm] ib test succeeded in 0 usecs
    [ 1.115365] [drm] Panel ID String: LGP
    [ 1.115369] [drm] Panel Size 1024x768
    [ 1.126663] [drm] radeon legacy LVDS backlight initialized
    [ 1.126782] [drm] Radeon Display Connectors
    [ 1.126786] [drm] Connector 0:
    [ 1.126788] [drm] VGA
    [ 1.126792] [drm] DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
    [ 1.126794] [drm] Encoders:
    [ 1.126796] [drm] CRT1: INTERNAL_DAC1
    [ 1.126798] [drm] Connector 1:
    [ 1.126800] [drm] LVDS
    [ 1.126802] [drm] DDC: 0x198 0x198 0x19c 0x19c 0x1a0 0x1a0 0x1a4 0x1a4
    [ 1.126804] [drm] Encoders:
    [ 1.126806] [drm] LCD1: INTERNAL_LVDS
    [ 1.126808] [drm] Connector 2:
    [ 1.126810] [drm] S-video
    [ 1.126811] [drm] Encoders:
    [ 1.126813] [drm] TV1: INTERNAL_DAC2
    [ 1.247614] [drm] fb mappable at 0xDC040000
    [ 1.247619] [drm] vram apper at 0xDC000000
    [ 1.247622] [drm] size 786432
    [ 1.247623] [drm] fb depth is 8
    [ 1.247625] [drm] pitch is 1024
    [ 1.247888] fbcon: radeondrmfb (fb0) is primary device
    [ 1.318851] fb0: radeondrmfb frame buffer device
    [ 1.318854] drm: registered panic notifier
    [ 1.318870] [drm] Initialized radeon 2.13.0 20080528 for 0000:01:05.0 on minor 0


    from what I red online the last version of linux catalyst to support rs2000 was 7.12 from 2007, I actually don't know if it was even supported at all but I'm willing to try before I trash these laptops and since this OSS driver seems to be from 2008 (radeon 2.13.0 20080528) it's not like they have it improved much anyway

  8. #8
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    Try

    vblank_mode=0 glxgears

    but below 60 fps it is really low...

  9. #9
    Join Date
    Sep 2011
    Posts
    6

    Default

    Quote Originally Posted by Pallidus View Post
    from what I red online the last version of linux catalyst to support rs2000 was 7.12 from 2007, I actually don't know if it was even supported at all but I'm willing to try before I trash these laptops and since this OSS driver seems to be from 2008 (radeon 2.13.0 20080528) it's not like they have it improved much anyway
    If you want to try 7.12 go to this page.
    At the bottom you will find a link to the installer, but instead of clicking it, copy the link address and paste it into the address bar of your browser.
    You then have to edit the link from

    https://a248.e.akamai.net/f/674/9206...x86.x86_64.run

    to

    https:/www2.ati.com/drivers/linux/ati-driver-installer-8.443.1-x86.x86_64.run

    (or copy the above )

    Sceptic

  10. #10
    Join Date
    Aug 2007
    Posts
    6,615

    Default

    Wasted time, to use 8.28.8 you need a very old kernel and xorg 7.1. Best get rid of that crap if you want to use current kernel+xorg. xorg 7.1 was released 22 May 2006, so if you really want to try it you would need to use a distro from that stone age, like u 6.06 maybe.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •