Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 46

Thread: Diagnosing & fixing unacceptably slow I/O performance

  1. #11
    Join Date
    Dec 2007
    Posts
    677

    Default

    The http://openbenchmarking.org/opc/1207...4#system_table page lists some of the things, and the model is Aspire 5740. Note that it's a dualcode CPU with hyperthreading, not a quadcore.

    Here's what the hdparm said:

    Code:
    /dev/sda:
     Timing cached reads:   5282 MB in  2.00 seconds = 2643.53 MB/sec
     Timing buffered disk reads: 242 MB in  3.00 seconds =  80.59 MB/sec
    Incidentally, after running the first set of PTS benchmarks and then running the SMART extended test, the biggest offender in slowness - the sound menu coming up - has gotten to be a bit quicker about it... so I ran benchmarks again last night, however the new results are inconclusive: http://openbenchmarking.org/result/1...AR-1207015AR38

  2. #12
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,988

    Default

    80 mb/s reads are average for a laptop HD. It may just be that it's that slow.

  3. #13
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    If you want ssd speed just buy one. It's just that simple.

  4. #14
    Join Date
    Jan 2011
    Location
    Are we real?
    Posts
    26

    Default

    Quote Originally Posted by Kano View Post
    If you want ssd speed just buy one. It's just that simple.
    Vadi is not talking about slow disk, he said there is a big lag... latency!

    Quote Originally Posted by Vadi View Post
    Opening Nautilus on the home folder takes a fair bit of disk grinding before it shows anything; open the gnome settings for sound takes eons of disk grinding and generally - anything that involves the HDD is unacceptably slow.

  5. #15
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    Well time to read dmesg. Look at

    http://openbenchmarking.org/system/1...e-defrag/dmesg

    That shows lots of ext4 errors, maybe the hd is already bad. Also i would never install a 32 bit os on a new system. Certainly i would use 64 bit and boot it preferred via UEFI. Also you can try a new kernel.
    Code:
    wget -qO- http://kanotix.com/files/fix/mainline/install-3.5.sh|sudo sh
    Last edited by Kano; 07-11-2012 at 06:54 AM.

  6. #16
    Join Date
    Dec 2007
    Posts
    677

    Default

    Hm... would installing this kernel certainly fix the ext4 errors and not break the normal kernel updates Ubuntu does?

    I went with 32bit a while ago because of Flash issues - this is a system for a common user, and they didn't need 64bit of practically speaking, 32bit offered the better experience. It's changed since, but the system was just upgraded instead of being reinstalled.

  7. #17
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    That kernel is much newer than the ubuntu default. So standard ubuntu kernels will never be default.

  8. #18
    Join Date
    Dec 2007
    Posts
    677

    Default

    Alright - how would that address the problem however?

    (I'd just like to understand what is happening and if this is necessary)

  9. #19
    Join Date
    Jan 2011
    Location
    Are we real?
    Posts
    26

    Default

    Quote Originally Posted by Vadi View Post
    Alright - how would that address the problem however?

    (I'd just like to understand what is happening and if this is necessary)
    There are ext4 fs errors. Just update the kernel to 3.5 with Kano's script, and see if it helps. The Ubuntu default kernel won't be uninstalled.

  10. #20
    Join Date
    Dec 2007
    Posts
    677

    Default

    Ah, right. You get to choose which one to load at start. I'll try that then.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •