Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Catalyst 7.12 slows down

  1. #1
    Join Date
    Jan 2008
    Posts
    46

    Default Catalyst 7.12 slows down

    The installation of Catalyst 7.2 has slowed my RV505 [Radeon X1550 64-bit] down significantly. glxgears gives me just 75.350 FPS (334 frames in 5.0 secs), and some programs, especially Firefox (extremely slow scrolling) and Gimp show bad response times. Catalyst 7.1 worked perfectly well, the xorg.conf is stillö the same.

    My xorg.conf:
    Code:
    ## /.../
    # SaX generated X11 config file
    # Created on: 2007-12-31T16:41:35+0000.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/opt/kde3/share/fonts"
      FontPath     "/usr/local/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AIGLX" "enable"
      Option       "AllowMouseOpenFail" "on"
      Option       "IgnoreABI" "on"
    EndSection
    
    Section "Module"
      Load         "glx"
      Load         "type1"
      Load         "extmod"
      Load         "dbe"
      Load         "freetype"
      Load         "dri"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "de"
      Option       "XkbModel" "logiaccess"
      Option       "XkbRules" "xfree86"
      Option       "XkbVariant" "deadgraveacute"
    EndSection
    
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Microsoft Wheel Mouse Optical"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  304 228
      HorizSync    31-60
      Identifier   "Monitor[0]"
      ModelName    "NEC CI FT500"
      Option       "DPMS"
      VendorName   "NCI"
      VertRefresh  50-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      15
        Modes      "1024x768" "800x600" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "1024x768" "800x600" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1024x768" "800x600" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "1024x768" "800x600" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "Radeon X1550 64-bit (RV505 7147)"
      BusID        "2:0:0"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "EXANoOffscreenPixmaps"
      Option       "FSAADisableGamma" "no"
      Option       "CapabilitiesEx" "0x00000000"
      Option       "ScreenOverlap" "0"
      Option       "FSAAMSPosY0" "0.000000"
      Option       "CenterMode" "off"
      Option       "FSAAMSPosX3" "0.000000"
      Option       "mtrr" "off"
      Option       "FSAAMSPosX4" "0.000000"
      Option       "FSAAMSPosY1" "0.000000"
      Option       "FSAAMSPosY2" "0.000000"
      Option       "FSAAScale" "1"
      Option       "ForceGenericCPU" "no"
      Option       "XAANoOffscreenPixmaps" "true"
      Option       "FSAAMSPosX5" "0.000000"
      Option       "FSAAMSPosY3" "0.000000"
      Option       "GammaCorrectionI" "0x04511445"
      Option       "no_accel" "no"
      Option       "FSAAMSPosY4" "0.000000"
      Option       "FSAAMSPosY5" "0.000000"
      Option       "UseFastTLS" "0"
      Option       "FSAACustomizeMSPos" "no"
      Option       "FSAAEnable" "no"
      Option       "BlockSignalsOnLock" "on"
      Option       "Capabilities" "0x00000000"
      Option       "GammaCorrectionII" "0x00000000"
      Option       "no_dri" "no"
      Option       "VideoOverlay" "on"
      Option       "UseInternalAGPGART" "no"
      Option       "StereoSyncEnable" "1"
      Option       "PseudoColorVisuals" "off"
      Option       "FSAAMSPosX0" "0.000000"
      Option       "FSAAMSPosX1" "0.000000"
      Option       "OpenGLOverlay" "off"
      Option       "AccelMethod" "EXA"
      Option       "FSAAMSPosX2" "0.000000"
      Option       "Stereo" "off"
      Screen       0
      VendorName   "ATI"
    EndSection
    
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
      Option       "Composite" "Enable"
      Option       "DAMAGE" "true"
    EndSection

  2. #2
    Join Date
    Jan 2008
    Posts
    46

    Default

    and here the xorg.log. Sorry about the length, I didn't know which section you would actually need to look at.



    (II) fglrx(0): pEnt->device->identifier=0x8206720

    (II) Setting vga for screen 0.
    (II) fglrx(0): === [atiddxPreInit] === begin, [x]
    (II) Loading sub module "vgahw"
    (II) LoadModule: "vgahw"
    (II) Loading /usr/lib/xorg/modules//libvgahw.so
    (II) Module vgahw: vendor="X.Org Foundation"
    compiled for 7.2.0, module version = 0.1.0
    ABI class: X.Org Video Driver, version 1.2
    (II) fglrx(0): PCI bus 2 card 0 func 0
    (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
    (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
    (==) fglrx(0): Default visual is TrueColor

    (II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:2:0:0"
    (II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
    (II) fglrx(0): [drm] mapped SAREA 0x2000 to 0xb7fa3000
    (II) fglrx(0): [drm] framebuffer handle = 0x3000
    (II) fglrx(0): [drm] added 1 reserved context for kernel
    (II) fglrx(0): DRIScreenInit done
    (II) fglrx(0): Kernel Module Version Information:
    (II) fglrx(0): Name: fglrx
    (II) fglrx(0): Version: 8.44.3
    (II) fglrx(0): Date: Dec 19 2007
    (II) fglrx(0): Desc: ATI FireGL DRM kernel module
    (II) fglrx(0): Kernel Module version matches driver.
    (II) fglrx(0): Kernel Module Build Time Information:
    (II) fglrx(0): Build-Kernel UTS_RELEASE: 2.6.22.13-0.3-default
    (II) fglrx(0): Build-Kernel MODVERSIONS: no
    (II) fglrx(0): Build-Kernel __SMP__: no
    (II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
    (II) fglrx(0): [drm] register handle = 0x00004000
    (II) fglrx(0): Interrupt handler installed at IRQ 19.
    (II) fglrx(0): Exposed events to the /proc interface
    (II) fglrx(0): DRI initialization successfull!
    (II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x01000000
    (II) fglrx(0): FBMM initialized for area (0,0)-(1024,4096)
    (II) fglrx(0): FBMM auto alloc for area (0,0)-(1024,768) (front color buffer - assumption)
    (II) fglrx(0): Largest offscreen area available: 1024 x 3328
    (==) fglrx(0): Backing store disabled
    (II) Loading extension FGLRXEXTENSION
    (II) Loading extension ATITVOUT
    (**) fglrx(0): DPMS enabled
    (**) fglrx(0): Textured Video is enabled.
    (II) LoadModule: "glesx"
    (II) Loading /usr/lib/xorg/modules//glesx.so
    (II) Module glesx: vendor="X.Org Foundation"
    compiled for 7.1.0, module version = 1.0.0
    ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension GLESX
    (II) fglrx(0): GLESX enableFlags = 16
    (II) fglrx(0): GLESX is enabled
    (**) fglrx(0): Option "XaaNoOffscreenPixmaps" "true"
    (II) fglrx(0): Using XFree86 Acceleration Architecture (XAA)
    Screen to screen bit blits
    Solid filled rectangles
    8x8 mono pattern filled rectangles
    Solid Lines
    Dashed Lines
    Setting up tile and stipple cache:
    32 128x128 slots
    20 256x256 slots
    6 512x512 slots
    (II) fglrx(0): Acceleration enabled
    (WW) fglrx(0): Option "EXANoOffscreenPixmaps" is not used
    (WW) fglrx(0): Option "FSAADisableGamma" is not used
    (WW) fglrx(0): Option "FSAAMSPosY0" is not used
    (WW) fglrx(0): Option "FSAAMSPosX3" is not used
    (WW) fglrx(0): Option "FSAAMSPosX4" is not used
    (WW) fglrx(0): Option "FSAAMSPosY1" is not used
    (WW) fglrx(0): Option "FSAAMSPosY2" is not used
    (WW) fglrx(0): Option "FSAAScale" is not used
    (WW) fglrx(0): Option "FSAAMSPosX5" is not used
    (WW) fglrx(0): Option "FSAAMSPosY3" is not used
    (WW) fglrx(0): Option "FSAAMSPosY4" is not used
    (WW) fglrx(0): Option "FSAAMSPosY5" is not used
    (WW) fglrx(0): Option "FSAACustomizeMSPos" is not used
    (WW) fglrx(0): Option "FSAAEnable" is not used
    (WW) fglrx(0): Option "FSAAMSPosX0" is not used
    (WW) fglrx(0): Option "FSAAMSPosX1" is not used
    (WW) fglrx(0): Option "AccelMethod" is not used
    (WW) fglrx(0): Option "FSAAMSPosX2" is not used
    (WW) fglrx(0): Option "CalcAlgorithm" is not used
    (II) fglrx(0): X context handle = 0x1
    (II) fglrx(0): [DRI] installation complete
    (II) fglrx(0): Direct rendering enabled
    [atiddx] ASYNCIO init succeed!
    (==) fglrx(0): Silken mouse enabled
    (==) fglrx(0): Using hardware cursor
    (==) RandR enabled
    (II) Initializing built-in extension MIT-SHM
    (II) Initializing built-in extension XInputExtension
    (II) Initializing built-in extension XTEST
    (II) Initializing built-in extension XKEYBOARD
    (II) Initializing built-in extension XC-APPGROUP
    (II) Initializing built-in extension XAccessControlExtension
    (II) Initializing built-in extension SECURITY
    (II) Initializing built-in extension XINERAMA
    (II) Initializing built-in extension XFIXES
    (II) Initializing built-in extension XFree86-Bigfont
    (II) Initializing built-in extension RENDER
    (II) Initializing built-in extension RANDR
    (II) Initializing built-in extension COMPOSITE
    (II) Initializing built-in extension DAMAGE
    (II) Initializing built-in extension XEVIE
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: Searching for BusID PCI:2:0:0
    drmOpenDevice: node name is /dev/dri/card0
    drmOpenDevice: open result is 7, (OK)
    drmOpenByBusid: drmOpenMinor returns 7
    drmOpenByBusid: drmGetBusid reports PCI:2:0:0
    (WW) AIGLX: 3D driver claims to not support visual 0x23
    (WW) AIGLX: 3D driver claims to not support visual 0x24
    (WW) AIGLX: 3D driver claims to not support visual 0x25
    (WW) AIGLX: 3D driver claims to not support visual 0x26
    (WW) AIGLX: 3D driver claims to not support visual 0x27
    (WW) AIGLX: 3D driver claims to not support visual 0x28
    (WW) AIGLX: 3D driver claims to not support visual 0x29
    (WW) AIGLX: 3D driver claims to not support visual 0x2a
    (WW) AIGLX: 3D driver claims to not support visual 0x2b
    (WW) AIGLX: 3D driver claims to not support visual 0x2c
    (WW) AIGLX: 3D driver claims to not support visual 0x2d
    (WW) AIGLX: 3D driver claims to not support visual 0x2e
    (WW) AIGLX: 3D driver claims to not support visual 0x2f
    (WW) AIGLX: 3D driver claims to not support visual 0x30
    (WW) AIGLX: 3D driver claims to not support visual 0x31
    (WW) AIGLX: 3D driver claims to not support visual 0x32
    (WW) AIGLX: 3D driver claims to not support visual 0x33
    (WW) AIGLX: 3D driver claims to not support visual 0x34
    (WW) AIGLX: 3D driver claims to not support visual 0x35
    (WW) AIGLX: 3D driver claims to not support visual 0x36
    (WW) AIGLX: 3D driver claims to not support visual 0x37
    (WW) AIGLX: 3D driver claims to not support visual 0x38
    (WW) AIGLX: 3D driver claims to not support visual 0x39
    (WW) AIGLX: 3D driver claims to not support visual 0x3a
    (WW) AIGLX: 3D driver claims to not support visual 0x3b
    (WW) AIGLX: 3D driver claims to not support visual 0x3c
    (WW) AIGLX: 3D driver claims to not support visual 0x3d
    (WW) AIGLX: 3D driver claims to not support visual 0x3e
    (WW) AIGLX: 3D driver claims to not support visual 0x3f
    (WW) AIGLX: 3D driver claims to not support visual 0x40
    (WW) AIGLX: 3D driver claims to not support visual 0x41
    (WW) AIGLX: 3D driver claims to not support visual 0x42
    (WW) AIGLX: 3D driver claims to not support visual 0x43
    (WW) AIGLX: 3D driver claims to not support visual 0x44
    (WW) AIGLX: 3D driver claims to not support visual 0x45
    (WW) AIGLX: 3D driver claims to not support visual 0x46
    (WW) AIGLX: 3D driver claims to not support visual 0x47
    (WW) AIGLX: 3D driver claims to not support visual 0x48
    (WW) AIGLX: 3D driver claims to not support visual 0x49
    (WW) AIGLX: 3D driver claims to not support visual 0x4a
    (WW) AIGLX: 3D driver claims to not support visual 0x4b
    (WW) AIGLX: 3D driver claims to not support visual 0x4c
    (WW) AIGLX: 3D driver claims to not support visual 0x4d
    (WW) AIGLX: 3D driver claims to not support visual 0x4e
    (WW) AIGLX: 3D driver claims to not support visual 0x4f
    (WW) AIGLX: 3D driver claims to not support visual 0x50
    (WW) AIGLX: 3D driver claims to not support visual 0x51
    (WW) AIGLX: 3D driver claims to not support visual 0x52
    (WW) AIGLX: 3D driver claims to not support visual 0x53
    (WW) AIGLX: 3D driver claims to not support visual 0x54
    (WW) AIGLX: 3D driver claims to not support visual 0x55
    (WW) AIGLX: 3D driver claims to not support visual 0x56
    (WW) AIGLX: 3D driver claims to not support visual 0x57
    (WW) AIGLX: 3D driver claims to not support visual 0x58
    (WW) AIGLX: 3D driver claims to not support visual 0x59
    (WW) AIGLX: 3D driver claims to not support visual 0x5a
    (WW) AIGLX: 3D driver claims to not support visual 0x5b
    (WW) AIGLX: 3D driver claims to not support visual 0x5c
    (WW) AIGLX: 3D driver claims to not support visual 0x5d
    (WW) AIGLX: 3D driver claims to not support visual 0x5e
    (WW) AIGLX: 3D driver claims to not support visual 0x5f
    (WW) AIGLX: 3D driver claims to not support visual 0x60
    (WW) AIGLX: 3D driver claims to not support visual 0x61
    (WW) AIGLX: 3D driver claims to not support visual 0x62
    (WW) AIGLX: 3D driver claims to not support visual 0x63
    (WW) AIGLX: 3D driver claims to not support visual 0x64
    (WW) AIGLX: 3D driver claims to not support visual 0x65
    (WW) AIGLX: 3D driver claims to not support visual 0x66
    (WW) AIGLX: 3D driver claims to not support visual 0x67
    (WW) AIGLX: 3D driver claims to not support visual 0x68
    (WW) AIGLX: 3D driver claims to not support visual 0x69
    (WW) AIGLX: 3D driver claims to not support visual 0x6a
    (WW) AIGLX: 3D driver claims to not support visual 0x6b
    (WW) AIGLX: 3D driver claims to not support visual 0x6c
    (WW) AIGLX: 3D driver claims to not support visual 0x6d
    (WW) AIGLX: 3D driver claims to not support visual 0x6e
    (WW) AIGLX: 3D driver claims to not support visual 0x6f
    (WW) AIGLX: 3D driver claims to not support visual 0x70
    (WW) AIGLX: 3D driver claims to not support visual 0x71
    (WW) AIGLX: 3D driver claims to not support visual 0x72
    (II) AIGLX: Loaded and initialized /usr/lib/dri/fglrx_dri.so
    (II) GLX: Initialized DRI GL provider for screen 0

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,565

    Default

    Quick questions :

    1. You mention Catalyst 7.1 and 7.2 in your initial post -- do you mean 7.11 (November) and 7.12 (December) ?

    2. I noticed your config file had :

    Option "AccelMethod" "EXA"

    ... while the log indicates that XAA is being initialized; wonder if the combination is somehow resulting in software rendering and the slowdown you are seeing ?

    Maybe try changing acceleration method to XAA ?

  4. #4
    Join Date
    Jan 2008
    Posts
    46

    Default

    Quote Originally Posted by bridgman View Post
    Quick questions :

    1. You mention Catalyst 7.1 and 7.2 in your initial post -- do you mean 7.11 (November) and 7.12 (December) ?

    2. I noticed your config file had :

    Option "AccelMethod" "EXA"

    ... while the log indicates that XAA is being initialized; wonder if the combination is somehow resulting in software rendering and the slowdown you are seeing ?

    Maybe try changing acceleration method to XAA ?
    I mean Catalyst 7.12 (December). Sorry for the confusion.

    I will remove EXA from the xorg.conf and see if there're any changes in the behaviour.

  5. #5
    Join Date
    Jan 2008
    Posts
    46

    Default

    nope. that didn't change anything. Still as slow as before

  6. #6
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by bridgman View Post
    Quick questions :

    1. You mention Catalyst 7.1 and 7.2 in your initial post -- do you mean 7.11 (November) and 7.12 (December) ?

    2. I noticed your config file had :

    Option "AccelMethod" "EXA"

    ... while the log indicates that XAA is being initialized; wonder if the combination is somehow resulting in software rendering and the slowdown you are seeing ?

    Maybe try changing acceleration method to XAA ?
    accelmethod is not used as inidicated in the log (we can only see a part of the log which tells us about thw vgahw module load and about the textured video enabling). it seems that somehow fglrx enables the rendering which slows down your board. i haven't seen nothing wrong in your xorg.conf but i wasn't able to see all the log. i know that there are sites around that let you load files on them. try loading the log there and post a link or copy the entire file in a post here.
    to try speeding up the rendering (should be activated by the extensions) add this to the device section:
    Code:
      Option        "TexturedXrender" "true"
    the following could break xorg and make it not start so if it doesn't start with the following option remove it.
    Code:
      Option        "Texture2d" "true"
    (it should speed up rendering) and
    Code:
      Option        "RENDER" "true"
    to the extensions sections.
    now this makes me wonder if this could be motive why my board has stepped down to about 300fps after enabling the rendering. i thought that this was due to my chip being slow, but it may be that the driver does the rendering by software means and its speed would be limited to just 300fps. i'll try out some modifications in the xorg conf and let you know if the enabling of rendering was the cause of this slowdown.

  7. #7
    Join Date
    Jan 2008
    Posts
    46

    Default

    I have uploaded the xorg.log to

    this address

    I'll try the suggested changes in the xorg.conf and will report back soon. Thanks for the help!

  8. #8
    Join Date
    Jan 2008
    Posts
    46

    Default

    Quote Originally Posted by mancunian View Post
    I have uploaded the xorg.log to

    this address

    I'll try the suggested changes in the xorg.conf and will report back soon. Thanks for the help!
    ps: dmesg comes up with the following error:

    [
    Code:
    fglrx:firegl_lock] *ERROR* Process 4146 is using illegal context 0x00000006

    I don't know what that means, though.

  9. #9
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by mancunian View Post
    ps: dmesg comes up with the following error:

    [
    Code:
    fglrx:firegl_lock] *ERROR* Process 4146 is using illegal context 0x00000006

    I don't know what that means, though.
    i didn't know it is an igp board until now, but this doesn't matter much. i don't see nothing wrong in the log except for the driver not being able to read the monitor, but if it works then that's not a real problem. from what i've seen i seem to understand that you're using opensuse 10.2 with xorg 7.2 (server 1.3) and personal compiled kernel. is that correct?
    well, it doesn't really matter much to tell the truth.
    anyway, try setting to false the extensions and turn to off aiglx and then comment out all the options in the device sections and restart xorg. see then if the driver reloads the rendering and if the gears have gone down again.

  10. #10
    Join Date
    Jan 2008
    Posts
    46

    Default

    Quote Originally Posted by givemesugarr View Post
    i didn't know it is an igp board until now, but this doesn't matter much. i don't see nothing wrong in the log except for the driver not being able to read the monitor, but if it works then that's not a real problem. from what i've seen i seem to understand that you're using opensuse 10.2 with xorg 7.2 (server 1.3) and personal compiled kernel. is that correct?
    well, it doesn't really matter much to tell the truth.
    anyway, try setting to false the extensions and turn to off aiglx and then comment out all the options in the device sections and restart xorg. see then if the driver reloads the rendering and if the gears have gone down again.
    Almost correct: the OS is OpenSuse 10.3.

    I have set all the extensions to false and have then commented out all the options in the device section. the gears are still down. re-activating the extensions and the different options one by one doesn't really change anything either. I am really lost here. Funny thing is, that Catalyst 7.11 worked almost flawlessly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •