It seems that Linux simply refuses to let my hard disks sleep. If I do:

hdparm -Y /dev/sdb

After a few minutes (5 or so), the disk wakes up again and dmesg says:

Code:
ata5.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6
ata5.00: waking up from sleep
ata5: hard resetting link
No partition of that disk is mounted anywhere. If I do "hdparm -Y" again, the same happens again after a few minutes.

I suspected the polling from udisks is doing that, so I created "/etc/udev/rules.d/99-disable-hd-polling.rules" with:

Code:
KERNEL=="sd*[!0-9]", ATTR{removable}=="0", ENV{ID_BUS}=="ata", ENV{DEVTYPE}=="disk", ENV{UDISKS_DISABLE_POLLING}="1"
KERNEL=="sd*[!0-9]", ATTR{removable}=="0", ENV{ID_BUS}=="scsi", ENV{DEVTYPE}=="disk", ENV{ID_VENDOR}=="ATA", ENV{UDISKS_DISABLE_POLLING}="1"
But no go. It doesn't help.

So the question is very simple: How do I do HD power management on Linux? (Using Gentoo with KDE 4.8.4, kernel 3.4.4.)