Results 1 to 3 of 3

Thread: Black screen after installing fglrx

Hybrid View

  1. #1
    Join Date
    Dec 2007
    Posts
    32

    Default Black screen after installing fglrx

    Hi all,

    got my new PC now. My Graphic card is a Sapphire ATi HD2600XT DDR4. But when I install fglrx and try to start my Xserver the Computer freezes with a black screen. Following error from kdm.log:

    X Window System Version 1.3.0
    Release Date: 19 April 2007
    X Protocol Version 11, Revision 0, Release 1.3
    Build Operating System: Linux Ubuntu (xorg-server 2:1.3.0.0.dfsg-12ubuntu8)
    Current Operating System: Linux home 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686
    Build Date: 29 September 2007
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 4 21:06:29 2008
    (==) Using config file: "/etc/X11/xorg.conf"
    (II) Module already built-in
    (II) Module already built-in
    (EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1014)
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): Failed to set up write-combining range (0xd0000000,0x10000000)
    (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    [glesx] __glESXExtensionInit: No GL ES2.0 capable screen found!
    The XKEYBOARD keymap compiler (xkbcomp) reports:
    > Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
    > Ignoring extra symbols
    Errors from xkbcomp are not fatal to the X server
    I used the NVIDIA driver before, so I assume somethings trying to use those old NVIDIA drivers. But what? And how can I remove/disable it?

    Thanks for your help!

    Cheers,
    Daniel

  2. #2
    Join Date
    Dec 2007
    Posts
    32

    Default

    Never mind, I'm going to install Kubuntu 8.04 anyway and think that will solve the issue...

  3. #3
    Join Date
    Aug 2007
    Posts
    6,679

    Default

    If you used the NVIDIA Installer:

    nvidia-installer --uninstaller

    would be best to do that before installing ATI drivers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •