Page 1 of 9 123 ... LastLast
Results 1 to 10 of 86

Thread: E-450 graphics performance issues

  1. #1
    Join Date
    Jan 2010
    Posts
    358

    Default E-450 graphics performance issues

    I have serious graphics performance issues with a new Lenovo X121e notebook that uses the E-450 APU.

    - GNOME shell runs very sluggish. Often the framerate seems to dip down to ~10fps, for instance when switching between workspaces. That's no better than my old POS Intel Atom GMA950 netbook!
    - I get only ~500fps in glxgears (not a benchmark, I know, but it still seems to be very slow).
    - The game TORCS is not very demanding AFAIK, but still runs pretty badly at < 30fps.
    - 2D performance is also noticeably worse than on the old Atom netbook (e.g. scrolling in a browser)

    OpenGL is definitely accelerated, according to glxinfo, and I'm seeing the same on Ubuntu 12.04 (stock or with updated kernel/mesa/ddx, doesn't matter) and Fedora 17 (Live USB).

    What the heck is going on?! The radeon drivers might not be as optimized as Intel's drivers, but this sort of performance is unacceptable. The GPU should be at least an order of magnitude faster than the old GMA950, but I see performance that is not actually better than this very old non-GPU.

  2. #2
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,116

    Default

    I use the same laptop, but I don't use Gnome Shell. From what I remember, Gnome Shell's/Clutter's Sync-to-Vblank option is slowing stuff down with Catalyst (it was an issue on Ubuntu (Compiz), too, which got fixed with Ubuntu 12.04. So try turning that off first.

    Also, Catalyst's 2D performance is overall not *that* impressive *yet*, you can try the experimental ShadowPrimary acceleration.

    #edit: Just saw that you were talking about the open source radeon driver. Well, that should not happen. 2D is kickass with it for me.

  3. #3
    Join Date
    Jan 2010
    Posts
    358

    Default

    Well, I see pathologically bad graphics performance in many places. For instance, Ubuntu's login manager is so slow you can watch it redraw, no kidding, and Unity is quite slow overall, too. Scrolling in the dash application list is unusuably slow, it just crawls.

    I wonder if that is a hardware issue, or something specific to the E-450. Which model variant do you have, the old one with the E-350 or the new one with E-450?

  4. #4

    Default

    AFAIK E-450 default is low power profile. Did you try changing the power profile?

    http://www.x.org/wiki/RadeonFeature#...gement_Options

  5. #5
    Join Date
    Jan 2010
    Posts
    358

    Default

    I messed around with power_method and power_profile in various ways, but that does not seem to affect performance or power usage. According to /sys/kernel/debug/dri/0/radeon_pm_info the GPU is always hovering around with a very low engine clock (5000-15000 KHz), and the clock never exceeds 200 MHz (the "default clock"). The Radeon 6320 should go up to 508 MHz by default. Is power management and clock control completely broken or what is going on?

    Please, can someone else report what radeon_pm_info says for an E350/450?

  6. #6
    Join Date
    Jan 2010
    Posts
    358

    Default

    By the way, is the drm driver supposed to dump info about available power states in the kernel log (dmesg)? According to some older posts it did that, but I do not see anything like that, only a "power management enabled" message.

  7. #7
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,987

    Default

    That dumping was only via manually added printfs, IIRC, never in a released kernel.

  8. #8
    Join Date
    Oct 2009
    Posts
    2,062

    Default

    Quote Originally Posted by brent View Post
    I have serious graphics performance issues with a new Lenovo X121e notebook that uses the E-450 APU.

    - GNOME shell runs very sluggish. Often the framerate seems to dip down to ~10fps, for instance when switching between workspaces. That's no better than my old POS Intel Atom GMA950 netbook!
    - I get only ~500fps in glxgears (not a benchmark, I know, but it still seems to be very slow).
    - The game TORCS is not very demanding AFAIK, but still runs pretty badly at < 30fps.
    - 2D performance is also noticeably worse than on the old Atom netbook (e.g. scrolling in a browser)

    OpenGL is definitely accelerated, according to glxinfo, and I'm seeing the same on Ubuntu 12.04 (stock or with updated kernel/mesa/ddx, doesn't matter) and Fedora 17 (Live USB).

    What the heck is going on?! The radeon drivers might not be as optimized as Intel's drivers, but this sort of performance is unacceptable. The GPU should be at least an order of magnitude faster than the old GMA950, but I see performance that is not actually better than this very old non-GPU.
    Please post the output of 'glxinfo | grep OpenGL'

  9. #9
    Join Date
    Jan 2010
    Posts
    358

    Default

    droidhacker, OpenGL is accelerated, if that is what you're getting at. I'm currently experimenting with an updated Mesa driver, but if anything that improved performance a little bit. Anyway, here's the output:

    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD PALM
    OpenGL version string: 2.1 Mesa 8.1-devel (git-6404095 precise-oibaf-ppa)
    OpenGL shading language version string: 1.30
    Apparently (verified by someone else with a desktop E350 mainboard), the kind of performance I'm experiencing is "normal" with current drivers. This is very disappointing. I carefully researched how well Brazos APUs work nowadays, and everyone assured me there are no major issues anymore.

  10. #10
    Join Date
    Dec 2007
    Posts
    2,321

    Default

    Enable 2D tiling in your xorg.conf.
    Option "ColorTiling2D" "True"
    in the device section.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •