Results 1 to 3 of 3

Thread: Ubuntu 12.04 and ATI driver 100% CPU usage bug makes it useless on laptop

Hybrid View

  1. #1

    Unhappy Ubuntu 12.04 and ATI driver 100% CPU usage bug makes it useless on laptop

    Hi all

    I am unfortunate enough to be suffering from this bug:

    https://bugs.launchpad.net/ubuntu/+s...iz/+bug/980195
    http://ubuntuforums.org/showthread.php?t=1957470
    http://ubuntuforums.org/showthread.php?t=2034232

    As soon as the screen goes into standby mode the compiz maxes one of the cores of the CPU. This of course drains the battery in no time flat

    When I use the opensource driver this issue doesn't exist but I want to play games with a proper frame rate in Linux and especialy seeing as steam is coming to Linux this will be a big issue for all using laptops and ATI display cards...

    I am not sure if the problem is compiz or ATI related. The same thing happens when using cinnamin on Mint 13 so it definetly is some incompatibility in compiz and the ATI driver.

    I installed the driver via the software centre and by following these steps:

    http://wiki.cchtml.com/index.php/Ubu...TI.27s_site.29

    All of them gives the same results...

  2. #2

    Default

    Found this workaround, just be sure to disable tearfree or else it wont work:

    WORKAROUND:
    1. Open Catalyst Control Center.
    2. Go to 3D > More Settings.
    3. Set "Wait for vertical refresh" to "On, unless application specifies".
    And if that doesn't work, then also do:
    4. Run "ccsm"
    5. In Workarounds, enable "Force full screen redraw (buffer swap) on repaint".

  3. #3
    Join Date
    Dec 2012
    Posts
    1

    Default

    Quote Originally Posted by georgelappies View Post
    Found this workaround, just be sure to disable tearfree or else it wont work:

    WORKAROUND:
    1. Open Catalyst Control Center.
    2. Go to 3D > More Settings.
    3. Set "Wait for vertical refresh" to "On, unless application specifies".
    And if that doesn't work, then also do:
    4. Run "ccsm"
    5. In Workarounds, enable "Force full screen redraw (buffer swap) on repaint".
    Thank you you saved my life!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •