Results 1 to 1 of 1

Thread: Mesa master: Problem loading newly compiled mesa

Hybrid View

  1. #1
    Join Date
    Feb 2012
    Posts
    9

    Default Mesa master: Problem loading newly compiled mesa

    Hello,

    I have a Radeon HD 4890 and I've built mesa from git like this:
    Code:
    ./autogen.sh --prefix=/usr
                 --with-dri-driverdir=/usr/lib/xorg/modules/dri
                 --with-dri-drivers=
                 --with-gallium-drivers=r600
                 --with-egl-platforms=x11,drm
                 --enable-gallium-llvm
                 --enable-gallium-egl
                 --disable-gallium-gbm
                 --enable-gallium-g3dvl
                 --enable-egl
                 --enable-gbm
                 --disable-debug
                 --enable-gles1
                 --enable-gles2
                 --enable-openvg
                 --enable-glx-tls
                 --enable-texture-float
                 --enable-shared-glapi
                 --disable-d3d1x
    and then make, but not make install.
    The problem is that it won't load the new driver.

    Code:
    $ export LIBGL_DRIVERS_PATH=lib
    $ LIBGL_DEBUG=verbose glxinfo 2>&1 >/dev/null | grep so$
    libGL: OpenDriver: trying lib/tls/r600_dri.so
    libGL: OpenDriver: trying lib/r600_dri.so
    libGL error: unable to load driver: r600_dri.so
    libGL: OpenDriver: trying lib/tls/swrast_dri.so
    libGL: OpenDriver: trying lib/swrast_dri.so
    libGL error: unable to load driver: swrast_dri.so
    
    $ export LD_LIBRARY_PATH=lib
    $ ldd lib/libGLESv2.so | grep glapi
            libglapi.so.0 => lib/libglapi.so.0 (0x00007f8a0f5e2000)
    
    $ export EGL_DRIVERS_PATH=lib/egl
    $ EGL_LOG_LEVEL=debug test_application 2>&1 >/dev/null | grep '\.so'
    $
    When running Nexuiz, it reports that it is using Mesa 8.0.4-1 which is the version that comes with the system (Debian unstable, linux 3.5-0 amd64).
    edit: When running Nexuiz like this, things are broken: no textures and player models are no tvisible.

    Any ideas how to do this right?

    Thanks
    Last edited by enio; 08-12-2012 at 09:12 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •