Results 1 to 2 of 2

Thread: Resolution problem with 7950gt and samsung syncmaster 226bw

  1. #1
    Join Date
    Oct 2007
    Location
    Canada
    Posts
    25

    Default Resolution problem with 7950gt and samsung syncmaster 226bw

    Hi, I just built a new computer with a 7950gt and samsung syncmaster 226bw. It's running ubuntu 7.10 and I used the envy script to install the 169.07 driver. The problem is the screen is at 1400x1050 and it is supposed to be at 1680x1050. I changed the resolution in xorg.conf but it seems to have ignored it.
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "Files"
    EndSection
    
    Section "Module"
    	Load		"glx"
    	Load		"v4l"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "Device"
    	Identifier	"Failsafe Device"
    	Boardname	"vesa"
    	Busid		"PCI:1:0:0"
    	Driver		"nvidia"
    	Screen	0
    EndSection
    
    Section "Monitor"
    	Identifier	"Failsafe Monitor"
    	Vendorname	"Generic LCD Display"
    	Modelname	"LCD Panel 1680x1050"
    	Horizsync	31.5-65.5
    	Vertrefresh	56.0	-	65.0
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1680x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"Failsafe Device"
    	Monitor		"Failsafe Monitor"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1400	1050
    		Modes		"800x600@60"	"1024x768@60"	"800x600@56"	"1280x960@60"	"640x480@60"	"1280x1024@60"	"1680x1050@60"
    	EndSubSection
    	Option		"AddARGBGLXVisuals"	"True"
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    EndSection
    Section "device" #               
    	Identifier	"device1"
    	Boardname	"vesa"
    	Busid		"PCI:1:0:0"
    	Driver		"nvidia"
    	Screen	1
    EndSection
    Section "screen" #               
    	Identifier	"screen1"
    	Device		"device1"
    	Defaultdepth	24
    	Monitor		"monitor1"
    	Option		"AddARGBGLXVisuals"	"True"
    EndSection
    Section "monitor" #               
    	Identifier	"monitor1"
    	Gamma	1.0
    EndSection
    Section "ServerFlags"
    EndSection
    Section "Extensions"
    	Option		"Composite"	"Enable"
    EndSection
    Also in the DFP part of my Nvidia x server settings the native resolution, best fit resolution and backend resolution show up as 1680x1050 but the frontend resolution shows up as 1400x1050.

    Any help is greatly appreciated!

  2. #2
    Join Date
    Oct 2007
    Location
    Canada
    Posts
    25

    Default

    I got it, sorry for the bother, I started nvidia-settings as root and manually entered the resolution in advanced and it worked. Sorry to bug you though this is my first nvidia card and I messed with in for hours before I posted this. Thanks any ways.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •