Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Radeon Gallium3D Gains Greater MSAA Support

  1. #11
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,040

    Default

    Is the common code still missing, ie, can this be used for any app (forced on, even if the app doesn't support it)?

  2. #12
    Join Date
    Jan 2009
    Posts
    619

    Default

    No, it can only be used with OpenGL framebuffer objects at the moment and only when the app asks for it.

  3. #13
    Join Date
    Mar 2011
    Posts
    375

    Default

    Quote Originally Posted by marek View Post
    Some pieces from the Radeon HD 6000 series are Evergreen GPUs too and those are supported already.
    Sorry for bugging you, but what about this:
    - r600g: implement MSAA rendering and texturing for evergreen and cayman
    (source http://www.phoronix.com/scan.php?pag...tem&px=MTE2MDc)

    Cayman is Northern Island, not Evergreen, right? So what about the other Northern Island chips?

  4. #14
    Join Date
    Jan 2009
    Posts
    619

    Default

    Quote Originally Posted by TAXI View Post
    Sorry for bugging you, but what about this:
    - r600g: implement MSAA rendering and texturing for evergreen and cayman
    (source http://www.phoronix.com/scan.php?pag...tem&px=MTE2MDc)

    Cayman is Northern Island, not Evergreen, right? So what about the other Northern Island chips?
    The other chips are being worked on, but I can't promise anything yet.

  5. #15
    Join Date
    Dec 2011
    Posts
    76

    Default

    Like all the others, thank you so much Marek for all your help!

  6. #16
    Join Date
    Mar 2011
    Posts
    375

    Default

    Quote Originally Posted by marek View Post
    The other chips are being worked on, but I can't promise anything yet.
    Thanks.

    Just one last question: Is Cayman actually supported (Kernel 3.6-rc3, newest libdrm/mesa from git) or does it need a newer kernel (hopefully rc4), too? I'm just wondering cause it seems like Evergreen works but Cayman not (well, can't tell for sure, it just doesn't advertise OpenGL 3.0 but I have no idea for which GL extensions to look).

  7. #17
    Join Date
    Jan 2009
    Posts
    619

    Default

    Cayman is not supported yet.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •