Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: Unreal Engine 3 works on Linux via Stage3D

  1. #21
    Join Date
    Aug 2010
    Posts
    58

    Default

    I had some issues with the demo.

    We could join some problems and send them to Google, so they could properly fix them as fast as possible.

    Here is what happens here:


    My hardware is (info from chrome://gpu/):
    GPU0 VENDOR = 0x10de [NVIDIA Corporation], DEVICE= 0x0401 [GeForce 8600GT]
    Driver vendor NVIDIA
    Driver version 295.40
    Pixel shader version 3.30
    Vertex shader version 3.30
    GL version 3.3
    GL_VENDOR NVIDIA Corporation
    GL_RENDERER GeForce 8600 GT/PCIe/SSE2
    GL_VERSION 3.3.0 NVIDIA 295.40

  2. #22
    Join Date
    Feb 2012
    Posts
    69

    Default

    I've recently seen a video on YouTube entitled Web Browsers in Linux Suck. The guy was comparing the performance of web browsers in Windows to Ubuntu with tests from Internet Explorer 10 Test Drive.

    The FishBowl test on Chrome Beta works much better if the "--ignore-gpu-blacklist" flag is set but I still get only about 60fps (with 10 and 25 fishes) and it's not smooth at all.

    fernandoc1 you have to start the browser from terminal with this command:

    Code:
    google-chrome --ignore-gpu-blacklist
    When comparing Stage3D and WebGL in the cube demo I get half more frames per second with WebGL.

    Rendering 1000 cubes

    Stage3D 15fps (openGL rendering)
    WebGL 30fps

  3. #23
    Join Date
    Jul 2012
    Posts
    152

    Default

    Quote Originally Posted by Bestia View Post
    I've recently seen a video on YouTube entitled Web Browsers in Linux Suck. The guy was comparing the performance of web browsers in Windows to Ubuntu with tests from Internet Explorer 10 Test Drive.

    The FishBowl test on Chrome Beta works much better if the "--ignore-gpu-blacklist" flag is set but I still get only about 60fps (with 10 and 25 fishes) and it's not smooth at all.
    Web Browsers in Linux Suck? No, Microsoft benchmark sucks. Check http://people.mozilla.org/~jmuizelaa...fishie-gl.html

  4. #24
    Join Date
    Feb 2012
    Posts
    69

    Default Yeah Microsoft benchmarks sucks!

    That's what I thought when viewing the video. Why would anybody look at Microsoft benchmarks desinged for IE.

    With Mozilla demo running on Chrome Beta I get 35fps with 1000 fishes and still it's much smoother than the Microsoft benchmark with 10 or 25 fishes.

    I've found some good demos of Stage3D. They are created with Minko a 3D framework for the web. Aerys company behind that technology already works on Minko 2 which supposedly will bring big performance improvements. The game they developed with it runs much better than Epic Citadel but it's also even less impressive graphically The Mirage.

  5. #25
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,052

    Default

    Quote Originally Posted by Bestia View Post
    I've recently seen a video on YouTube entitled Web Browsers in Linux Suck. The guy was comparing the performance of web browsers in Windows to Ubuntu with tests from Internet Explorer 10 Test Drive.
    Should I even attempt to watch it?

    Well, I did. Here are the important parts for people who don't want to spend that time:

    1. Maybe I didn't hear it but I think he didn't say anything at all about his test setup. in one comments he says he has intel HD 3000.
    2. Firefox has no acceleration whatsoever in linux? I don't think so.
    3. Does the particle acceleration test even work correctly? In google chrome 23 I get steady 60 FPS with vblank_mode=0 and gpu vsync deactivated in chrome flags. DrawTime massively depends on the browser windows size. 4 ms for ~1024x768, 2-3 times as much when the browser is maximized on 1920x1080.
    On firefox nightly I get 3-4 FPS no matter what. That seems to be a particularily bad example.
    4. With chrome 23 I have 60 FPS with 250 fish in the fishbowl and 50 FPS with 500. Water looks fine.
    Firefox nightly: as in the video

    My chrome on linux acceleration with the (still not very efficient) open source radeon driver is much better than his windows acceleration? Therefore: "Web Browsers in Linux Suck."

    *loading a website from cache* "it's not my web connection!"
    *... disabled = true* "As you can see I did turn it on"
    "I've never actually got the fishbowl test to load under linux anyway so it's inferior" WAT

    *It comes up so fast it's probably still from cache* "There you have it, linux is inerior when it comes to web browsers"

    *obnoxious condescending laughing. Repeatedly*
    *more obnoxious laughing while calling the browsers on linux "garbage" and repeating that they fall short*

    comment from video author: "YouTube videos if i go full screen the video is choppy in Linux and smooth in windows on the same hardware and browser."

    If anything was "pathetic" than it was his presentation.

  6. #26
    Join Date
    Jul 2012
    Posts
    819

    Default

    Quote Originally Posted by fernandoc1 View Post
    I had some issues with the demo.

    We could join some problems and send them to Google, so they could properly fix them as fast as possible.

    Here is what happens here:


    My hardware is (info from chrome://gpu/):
    GPU0 VENDOR = 0x10de [NVIDIA Corporation], DEVICE= 0x0401 [GeForce 8600GT]
    Driver vendor NVIDIA
    Driver version 295.40
    Pixel shader version 3.30
    Vertex shader version 3.30
    GL version 3.3
    GL_VENDOR NVIDIA Corporation
    GL_RENDERER GeForce 8600 GT/PCIe/SSE2
    GL_VERSION 3.3.0 NVIDIA 295.40
    This because you didn't set "--ignore-gpu-blacklist" like the OP said. Otherwise it looks the same
    on my hardware. Not a bug.

  7. #27
    Join Date
    Jul 2012
    Posts
    152

    Default

    Ok, last experiment. I installed FGLRX and... Epic Citadel is still slow. ~25 fps @ ~1280x720.

  8. #28
    Join Date
    Feb 2013
    Posts
    15

    Default

    Quote Originally Posted by blackout23 View Post
    This because you didn't set "--ignore-gpu-blacklist" like the OP said. Otherwise it looks the same
    on my hardware. Not a bug.
    Mmm, no luck even launching chromium with: chromium-browser --ignore-gpu-blacklist

    Graphics Feature Status
    Canvas: Hardware accelerated
    Compositing: Hardware accelerated
    3D CSS: Hardware accelerated
    CSS Animation: Accelerated
    WebGL: Hardware accelerated
    WebGL multisampling: Hardware accelerated
    Flash 3D: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Texture Sharing: Hardware accelerated
    Video Decode: Hardware accelerated
    Video: Hardware accelerated
    Panel Fitting: Unavailable. Hardware acceleration disabled.
    Force Compositing Mode: Unavailable. Hardware acceleration disabled.
    Problems Detected
    Panel fitting is unavailable, either disabled at the command line or not supported by the current system.
    Force compositing mode is off, either disabled at the command line or not supported by the current system.
    Version Information
    Data exported 27/2/2013 20:55:09
    Chrome version 24.0.1312.56 (Build para desarrolladores 24.0.1312.56-0ubuntu0.12.04.1) Ubuntu 12.04
    Operating system Linux 3.5.0-18-generic
    Software rendering list version 0
    ANGLE revision 1560
    2D graphics backend Skia
    Driver Information
    Initialization time 91
    Sandboxed false
    GPU0 VENDOR = 0x10de [NVIDIA Corporation], DEVICE= 0x11c6 [Device 11c6]
    Optimus false
    AMD switchable false
    Driver vendor NVIDIA
    Driver version 310.14
    Driver date
    Pixel shader version 4.30
    Vertex shader version 4.30
    Machine model
    GL version 4.3
    GL_VENDOR NVIDIA Corporation
    GL_RENDERER GeForce GTX 650 Ti/PCIe/SSE2
    GL_VERSION 4.3.0 NVIDIA 310.14

  9. #29
    Join Date
    Aug 2007
    Posts
    6,646

    Default

    It does not work that way with newer chrome versions, but you can use a much simpler way via:

    chrome://flags

  10. #30
    Join Date
    Feb 2013
    Posts
    15

    Default

    Quote Originally Posted by Kano View Post
    It does not work that way with newer chrome versions, but you can use a much simpler way via:

    chrome://flags
    Ok, and wich flags I should change?

    Thanks in advance!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •