Results 1 to 4 of 4

Thread: Performance regression under Linux3.6 with Radeon Mobility X1600

  1. #1
    Join Date
    Dec 2009
    Posts
    110

    Default Performance regression under Linux3.6 with Radeon Mobility X1600

    I tried out Fedora 18 on my old laptop the other day and noticed that it was SLOOOW.
    Looking into it I realized that Xorg ate loads of CPU-cycles. A fast check with sysprof told me that it was in the drm-chain Xorg placed all its resurces. I also was able to confirm this was not the case with a 3.5.0 fetched from koji for fc18.

    Now I ask myself, is there anyone else experience this kind of problem with the 3.6-kernel so far? Any other dists?

    lspci:
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI M56P [Radeon Mobility X1600] [1002:71c5] (prog-if 00 [VGA controller])
    Subsystem: Acer Incorporated [ALI] Device [1025:010a]

  2. #2
    Join Date
    May 2009
    Location
    Owatonna, Minnesota, USA
    Posts
    98

    Default

    Fedora's development branch (Rawhide) has debugging-enabled kernels that will lower performance significantly. If you want to use a fc18 kernel, go to koji.fedoraproject.org and do a search for the kernel package. When you find it, check the changleog of the latest one and watch for which version has disabled debugging (they disable it for the first build of each RC.) The 3.6-RC3 one can be found here.
    You can download and install the RPM manually (with the rpm or yum commands). I recommend getting installing the versionlock plugin for yum and locking the debugging-disabled kernel version. That will keep it from upgrading when you do an update.

  3. #3
    Join Date
    Nov 2009
    Posts
    379

    Default

    I wonder if the dual head problem is solved in Fedora 18? Fedora 16 worked fine, with Fedora 17 the gdm won't start if an external monitor is attached...

  4. #4
    Join Date
    Dec 2009
    Posts
    110

    Default

    Quote Originally Posted by BlueJayofEvil View Post
    Fedora's development branch (Rawhide) has debugging-enabled kernels that will lower performance significantly. If you want to use a fc18 kernel, go to koji.fedoraproject.org and do a search for the kernel package. When you find it, check the changleog of the latest one and watch for which version has disabled debugging (they disable it for the first build of each RC.) The 3.6-RC3 one can be found here.
    You can download and install the RPM manually (with the rpm or yum commands). I recommend getting installing the versionlock plugin for yum and locking the debugging-disabled kernel version. That will keep it from upgrading when you do an update.
    Thanks for reminding me, that was it.
    Strange, I was sure I had tested that version...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •