Results 1 to 5 of 5

Thread: How to use two monitors at the same time?

  1. #1
    Join Date
    Jun 2008
    Posts
    62

    Default How to use two monitors at the same time?

    Hi,

    I just got a HP EliteBook 8560p with a Mobility Radeon 6470. Installed Ubuntu 12.04 and the binary AMD drivers. In AMD CCC I selected "Single display (Multi-Desktop)" and rebooted. The second display is now completely white and I cant move any windows there. But I can make mouse clicks there and create a new folder...

    Then I switched to "Multi-display desktop with display 1": Now the second display is still black and not activated in CCC. I can repeat this forever and nothing changes.

    Third thing tried is to generate a dual head config with amd config. Changes nothing to both methods above.

    Monitor 1 is a HP LP2475w connected via DVI, the second one is a HP ZR2240w connected via Displayport.


    So, how can I use two monitors with AMD cards?
    Last edited by Asariati; 09-13-2012 at 05:50 PM.

  2. #2
    Join Date
    Oct 2007
    Posts
    321

    Default

    Functionality wise, there's nothing preventing the multiple displays... however the default configuration is the main issue. To fix this, Follow the following steps, and you will be able to make use of multiple displays at the same time ( With monitor hot-plugging support ).
    1. Open up the xorg.conf file with your favorite text editor. This file is usually located at /etc/X11/xorg.conf
    2. scroll down to the "Screen" Section. This should look something like:
      Code:
      Section "Screen"
      	Identifier "aticonfig-Screen[0]-0"
      	Device     "aticonfig-Device[0]-0"
      	Monitor    "aticonfig-Monitor[0]-0"
      	DefaultDepth     24
      	SubSection "Display"
      		Viewport   0 0
      		Depth     24
      	EndSubSection
      EndSection
    3. Modify the subsections which define viewport and depth to also include the "Virtual" parameter. For this, I recommend 4096 square for two displays and if your looking at three or more displays try 8192. either way, the new screen section will look something like this:
      Code:
      Section "Screen"
      	Identifier "aticonfig-Screen[0]-0"
      	Device     "aticonfig-Device[0]-0"
      	Monitor    "aticonfig-Monitor[0]-0"
      	DefaultDepth     24
      	SubSection "Display"
      		Viewport   0 0
      		Depth     24
      		Virtual 4096 4096
      	EndSubSection
      EndSection
    4. Save the file, and restart the computer.
    5. Once the reboot is finished, You should have full xrandr working without any hassles, and with this working, the desktop environmental configuration tool for monitors will handle the rest.

  3. #3
    Join Date
    Jun 2008
    Posts
    62

    Default

    Thank you!
    It is working now. Dont understand why the CCC isnt doing this modification correctly or has a larger standard setting.

  4. #4
    Join Date
    Feb 2012
    Posts
    43

    Thumbs up

    Or with the open stack, plug in the 2nd monitor, and it works (mirror mode) edit the monitor options in your DE to enable spanned mode.

  5. #5
    Join Date
    Jun 2008
    Posts
    62

    Default

    Yeah, with the OSS drivers it just works. On the other hand they burn too much power in the laptop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •