Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: Valve's Full Linux Push Talked About For February

  1. #21
    Join Date
    Jul 2008
    Posts
    565

    Default Fuck Ubuntu

    Canonical and Valve meeting has me pissed. Exclusive Linux distro releases is utterly absurd. Valve better release a cross-distro Linux installer/package that will inclue all dependencies and their games better do the same. The dependencies can only end where actual real unchanging standard APIs/ABIs begin. I'm not supporting efforts to push proprietary Linux. Anyone who cares about freedom should be pushing for cross-distro standards.
    Last edited by Yfrwlf; 09-02-2012 at 12:26 PM.

  2. #22
    Join Date
    Jul 2012
    Posts
    707

    Default

    Do you know any programs with distro lock? I don't. Most of the stuff I install from Arch User Repositorys comes in *.debs. Still no problem.

  3. #23
    Join Date
    May 2011
    Posts
    1,442

    Default

    It seems like it would be pretty trivial to convert a .deb to another distro format.

  4. #24
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    904

    Default

    Quote Originally Posted by kwahoo View Post
    http://www.blackmesasource.com/
    I really need a Source port for Linux.

    BTW Free (or Pay What You Want) sountrack is available to download http://www.blackmesasource.com/soundtrack.html
    Oh my god....

    I'm visiting the homepage and the forums from time to time for more than six years now.
    Unbelievable they eventually made it.

    BTW, I remember a developer to answer the question for a Mac OS port not too long ago (maybe a year or so).
    IIRC, he said it's very unlikely to happen. The port can not be easily compiled for another platform target.
    There is lots of platform specific stuff included (not sure why) and they most likely won't take the effort to port it.

  5. #25
    Join Date
    Aug 2012
    Posts
    440

    Default

    Quote Originally Posted by Yfrwlf View Post
    Canonical and Valve meeting has me pissed. Exclusive Linux distro releases is utterly absurd. Valve better release a cross-distro Linux installer/package that will inclue all dependencies and their games better do the same. The dependencies can only end where actual real unchanging standard APIs/ABIs begin. I'm not supporting efforts to push proprietary Linux. Anyone who cares about freedom should be pushing for cross-distro standards.
    You have ignored everything that directly contradicts your claim, and still spout your erogenous opinion as fact and act offended and outraged.

    Congrats, your the best American I've ever seen.

  6. #26
    Join Date
    Jul 2012
    Posts
    146

    Default

    Quote Originally Posted by entropy View Post

    BTW, I remember a developer to answer the question for a Mac OS port not too long ago (maybe a year or so).
    IIRC, he said it's very unlikely to happen. The port can not be easily compiled for another platform target.
    There is lots of platform specific stuff included (not sure why) and they most likely won't take the effort to port it.

    http://wiki.blackmesasource.com/Gene...er_platform.3F
    Will Black Mesa be ported to Xbox360, Mac or another platform?

    At the moment Black Mesa supports only PCs powered by Microsoft Windows operational system [5]. In the near future it will be also available for Mac, and possibly, Linux [6]. No port for Xbox360.
    I'm curious if there is a platform-agnostic way for Source modding, something like a Quake ]I[ Arena QVM...

  7. #27
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    904

    Default

    Quote Originally Posted by kwahoo View Post
    http://wiki.blackmesasource.com/Gene...er_platform.3F


    I'm curious if there is a platform-agnostic way for Source modding, something like a Quake ]I[ Arena QVM...
    Great. Thanks for the link!

  8. #28
    Join Date
    Nov 2007
    Posts
    297

    Default

    Quote Originally Posted by blackout23 View Post
    Do you know any programs with distro lock? I don't. Most of the stuff I install from Arch User Repositorys comes in *.debs. Still no problem.
    There is none

    This is the problem at the moment and it comes from quite a few years of FUD, FUD like "too many distro's you can't get it working for all" or "linux is not stable [from a lib point of view]""

    WRONG

    #1 Too many distro
    Not really, the VAST majority are derivatives, there really is only like 6 odd core distro's (debian, redhat, gentoo, arch...) sure you can argue around which one you can call core or not but that's just semantics and doesn't change the fact there isn't that many (ubuntu, Xubuntu... SAME THING!!!) even then it comes downto libraries...

    Now sure 10years ago when I was really getting the hang on linux distro's could end up differing a fair amount due to specific distro-patches to the likes of libc, kernel... (slow updates from upstream and such) but with git and a faster moving update from some of the core libs, pretty much every distro is reasonably similar

    So why not just target one and ubuntu makes sense - its the most popular AND they target themselves as newbie friendly. Have all official support ubuntu based BUT (as every linux application is) make the program Distro Agnostic REALLY FUCKING SIMPLE!!!! don't link against an ubuntu-specific library (unity.so for instance... even then easy for others to install), don't link against a specific library version (libXft.so instead of libXft.ubuntu.2.3.1.so) LINUX does multiple version of shared libs REALLY WELL, this isn't windows and dll hell... IF you have to link against a specific library concider shipping it... many a linux app does this AND quite a few windows as well ... matlab does...)


    #2 Linux is not stable (from a library point of view)
    Again bullshit!!! its alot more binary ABI stable that windows is. The kernel has a very simple rule "YOU NEVER BREAK EXTERNAL INTERFACES" so for the entire 2.6.x as well as the 3.x its the same from a userland point of view.
    Likewise Libc has just been extended and since upstream was updating faster all distro's have access to the latest patches that each other submits.
    The 3.6rc kernel will still run a Rogue binary built in 1992. X is back compatible to apps far older than Linux.

    Windows is completely unable to make such a claim...



    I have a couple of programs I run on a Fedora box at work. Matlab and EFFE. Matlab ONLY support Redhat so when I contacted them for support their official line was "we only support redhat", my reply for the couple of times I have had to contact them was "that is fine, but for redhat systems have you seen such an error, what have you recommended". They tell me what their solution or where to look for redhat AND I tailor it to Fedora. Not that hard.
    Likewise EFFE is developed on Gentoo and is tested on Ubuntu so when I hit a problem with that they informed me what they did for gentoo/ubuntu and I tailored for Fedora...

    Simply put if Valve want to target Ubuntu so what, as long as they don't go full retard (and cause other distro's to pull in specific Ubuntu libs [BAD!!! but then it could be a simple build error]) then all that is needed is the other distro's can provide ad-hoc techsupport for their users.

  9. #29
    Join Date
    Mar 2011
    Posts
    326

    Default

    Quote Originally Posted by Naib View Post
    There is none


    Simply put if Valve want to target Ubuntu so what, as long as they don't go full retard (and cause other distro's to pull in specific Ubuntu libs [BAD!!! but then it could be a simple build error]) then all that is needed is the other distro's can provide ad-hoc techsupport for their users.
    Lol is that a Tropic Thunder reference? I agree with everything you say in that most people are just misinformed.

  10. #30
    Join Date
    Jul 2012
    Posts
    707

    Default

    If it wasn't for Ubuntu being backed by a real company and aiming at providing a user-friendly linux experience there would not be
    any news about Steam coming to linux at all. And I don't even use Ubuntu anymore.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •