Results 1 to 7 of 7

Thread: xorg ati.

  1. #1
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default xorg ati.

    Hi
    i have compiled xf86-video-ati. i use kubuntu 12.04
    /autogen.sh --prefix=/opt/xorg
    after
    sudo make install


    but
    how do i load the driver?

    with kms, the xorg.conf file is disabled?

    thanks for help, sorry my english is bad.

  2. #2
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,052

    Default

    Well, my xf86-video-ati package has these two files:
    Code:
    /usr/lib/xorg/modules/drivers/ati_drv.so
    /usr/lib/xorg/modules/drivers/radeon_drv.so
    So you could just move them there and overwrite the old ones (and simply reinstall from the package manager to revert to the old one).

    I think you can use this to see where your X.org server looks for modules:
    Code:
    X -showDefaultModulePath
    X.org also has this in the Xorg manpage:
    Code:
           -modulepath searchpath
                   Set the module search path to searchpath.  searchpath is a comma separated list of directories to search for Xorg server modules.  This option is only available when the server is run as root (i.e, with real-uid 0).
    So you could probably use
    Code:
    sudo X -modulepath /opt/xorg/<wherever your modules are there>

  3. #3
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    ok thanks
    but

    i have kubuntu 12.10, and /etc/init.d/kdm stop dont work
    i have forced the copy and crush kde hahahahahah
    restart all ok
    thanks

  4. #4
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Hello.

    xorg.conf does indeed work, even with KMS.
    You can create it from scratch, or even better, use xorg.conf.d/xx-xxxx.conf approach. Archlinux has pretty a lot of documentation on topic.

    When using KMS, you can also use "driconf" utility to tune your card.

    As for display manager, its either MDM or lightdm, so "lightdm restart" or "/etc/init.d/lightdm restart" depending on subsystem (I think kubuntu is with upstart, so 1st variant).

  5. #5
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    5,113

    Default

    driconf doesn't require kms.

  6. #6
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Quote Originally Posted by curaga View Post
    driconf doesn't require kms.
    Yes, of course, correct. Driconf is for any driver using DRI, any opensource driver. Works worser with nouveau however, from my experience.

  7. #7
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    Thanks

    sudo /etc/init.d/lightdm rstop (works good).


    1000 Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •