Results 1 to 9 of 9

Thread: Flickering video on Asus motherboard with ATI video

  1. #1
    Join Date
    Jun 2007
    Location
    Haifa
    Posts
    55

    Default Flickering video on Asus motherboard with ATI video

    I have Kubuntu 8.10 installed on a machine with an ASUS motherboard, onboard ATI graphics:
    http://www.asus.com/products.aspx?l1...64&modelmenu=1

    The system graphics seem very sluggish (switching photos in digikam is slow) and video flickers. Running "aticonfig --initial" helped somewhat, but not completely. I am using the proprietary fglrx driver. Opening the Proprietary Drivers windows informs me that the machine is using "a different version" of the driver, for what that's worth. Looking in Adept, I have the only version available, installed.

    What can I do to start troubleshooting this issue? Thanks.

  2. #2
    Join Date
    Jul 2007
    Posts
    405

    Default

    Please dump your Xorg.0.log file on pastebin and link it here so we can see what driver is being loaded and if it is configured correctly.

  3. #3
    Join Date
    Jun 2007
    Location
    Haifa
    Posts
    55

    Default

    Thanks, here it is:
    http://pastebin.com/md30d2c9

  4. #4
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,571

    Default

    That looks like your config file - could you also paste your log file ?

    Probably in /var/log/

  5. #5
    Join Date
    Jul 2008
    Location
    Greece
    Posts
    3,801

    Default

    /var/log/Xorg.0.log

  6. #6
    Join Date
    Jun 2007
    Location
    Haifa
    Posts
    55

    Default

    Sorry, I should have read slower:
    http://pastebin.com/m370af045

  7. #7
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,571

    Default

    OK, looks like you are running the version of fglrx that came with *ubuntu 8.10, and it seems to have come up OK on your HD3200/780 GPU.

    That driver version will flicker when playing videos under Compiz (ie with full Desktop Effects); the latest version (9.1) fixes the flicker but may still have some other issues when playing video under Compiz.

    Here are some options :

    1. Turning Desktop Effects off should get rid of the video flicker and may help performance with other apps. That's the first and easiest thing to try. It's System=>Preferences=>Appearance then rightmost tab on Ubuntu, not sure if Kubuntu is the same there.

    2. If you want to keep Desktop Effects enabled and keep the current driver and be able to play videos without flicker, try changing the "Unredirect Full Screen Windows" checkbox in the General Options of the CompizConfig Settings Manager (you might have to download this package). With the right setting (I don't remember if that's checked or unchecked) games and videos will not flicker in full screen mode.

    3. You can download and install the latest driver which will address the flickering video but you will still have flickering with 3D apps.

  8. #8
    Join Date
    Jun 2007
    Location
    Haifa
    Posts
    55

    Default

    Thanks. I disabled the desktop effects (System Settings -> Desktop) and the video flicker is gone. Digikam still seems to be very slow in thumbnail placement, but there is a recently resolved bug in bugzilla on the issue, and I'm not using the 0.9.x version:
    http://bugs.kde.org/show_bug.cgi?id=166564

  9. #9
    Join Date
    Dec 2007
    Posts
    32

    Default

    Quote Originally Posted by bridgman View Post
    [SNIP]
    2. If you want to keep Desktop Effects enabled and keep the current driver and be able to play videos without flicker, try changing the "Unredirect Full Screen Windows" checkbox in the General Options of the CompizConfig Settings Manager (you might have to download this package). With the right setting (I don't remember if that's checked or unchecked) games and videos will not flicker in full screen mode.

    3. You can download and install the latest driver which will address the flickering video but you will still have flickering with 3D apps.
    Does "flickering" include the "video-allways-on-top" issue? So what about newest drivers and the "Unredirect Full Screen Windows" checkbox? I'm not at home, can't try myself.

    EDIT: Video works with 9.1 and Desktop Effects enabled. fgl_glxgears is flickering minimal.
    Last edited by Spitfire; 02-04-2009 at 07:08 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •