Results 1 to 10 of 19

Thread: Nouveau Releases New Driver With PRIME Support

Hybrid View

  1. #1
    Join Date
    Jan 2007
    Posts
    14,378

    Default Nouveau Releases New Driver With PRIME Support

    Phoronix: Nouveau Releases New Driver With PRIME Support

    The xf86-video-nouveau 1.0.2 driver was released today to take advantage of the new capabilities of X.Org Server 1.13...

    http://www.phoronix.com/vr.php?view=MTE4MzA

  2. #2
    Join Date
    Aug 2012
    Posts
    70

    Default

    Besides the RADEON drivers still not have this support.
    the last drivers release today in ppa's for ubuntu with xorg1.13 and up.
    Now, when using the xorg.conf and being specific with the radeon driver and pci device. The system boot well, didn't crash, didn't give error about link/atom bios crash. and i know the system can boot perfect. BUT i cant see the screen YET. If i type the password ( doing this in a blind way) everything load ( i can rear) But i cant See it. no error in xorg.log or dmesg.

    A BIG STEP AHEAD

  3. #3
    Join Date
    Jun 2010
    Location
    ฿ 16LDJ6Hrd1oN3nCoFL7BypHSEYL84ca1JR
    Posts
    1,026

    Default

    Quote Originally Posted by fritzls View Post
    Besides the RADEON drivers still not have this support.
    If you manage to be a bit specific about the exact versions of involved software you use you might want to file a bug report. I can't test it because my notebook only has one card but my xrandr from git says this:
    Code:
     ./xrandr --listproviders
    Providers: number : 1
    Provider 0: id: 88 cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 6 outputs: 3 associated providers: 0 name:radeon

  4. #4
    Join Date
    Dec 2011
    Posts
    2,008

    Default

    http://nouveau.freedesktop.org/wiki/FeatureMatrix
    http://cgit.freedesktop.org/nouveau/xf86-video-nouveau/

    Seems it is only Dave Airlie, Adam Jackson, and Ben Skeggs working on nouveau.

    Wayland does still not work with nouveau on Ubuntu.

  5. #5
    Join Date
    Aug 2012
    Posts
    70

    Default

    Quote Originally Posted by ChrisXY View Post
    If you manage to be a bit specific about the exact versions of involved software you use you might want to file a bug report. I can't test it because my notebook only has one card but my xrandr from git says this:
    Code:
     ./xrandr --listproviders
    Providers: number : 1
    Provider 0: id: 88 cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 6 outputs: 3 associated providers: 0 name:radeon
    It's not a bug at all. And i'm talking about AMD RADEON not NVIDI+bumblebe
    from what i Understand it's a behaviour.
    Radeon driver loads now perfect. but still not the output from intel card.
    Before, when the radeon driver loaded and didn't find the output monitor, he break giving a error and crashing the xorg. now the xorg load. didnt crash anymore. Just doesn't show nothing because there is not physical output from radeon ( output still being owned by the intel hardware).
    They are aware of this. Not rush with more one bug filled. Just wait they do the work they are being done.

    ho. About hardware. xrandr --listproviders didnt swork with this command --listproviders .
    but the hardware.
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Broadway [ATI Mobility Radeon HD 6800 Series] (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 159b
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 53
    Region 0: Memory at a0000000 (64-bit, prefetchable) [size=256M]
    Region 2: Memory at c0700000 (64-bit, non-prefetchable) [size=128K]
    Region 4: I/O ports at 3000 [size=256]
    Expansion ROM at c0740000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon

    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 159b
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 54
    Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 4000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

  6. #6
    Join Date
    Aug 2012
    Location
    Pennsylvania, United States
    Posts
    1,862

    Default

    Quote Originally Posted by fritzls View Post
    It's not a bug at all. And i'm talking about AMD RADEON not NVIDI+bumblebe
    from what i Understand it's a behaviour.
    Radeon driver loads now perfect. but still not the output from intel card.
    Before, when the radeon driver loaded and didn't find the output monitor, he break giving a error and crashing the xorg. now the xorg load. didnt crash anymore. Just doesn't show nothing because there is not physical output from radeon ( output still being owned by the intel hardware).
    They are aware of this. Not rush with more one bug filled. Just wait they do the work they are being done.

    So the drivers are PRIME-aware, in that multiple GPU's no longer causes an exception / crashes Xorg, but not PRIME-usable, in that output is still broken?

  7. #7
    Join Date
    Aug 2012
    Posts
    70

    Default

    Quote Originally Posted by Ericg View Post
    So the drivers are PRIME-aware, in that multiple GPU's no longer causes an exception / crashes Xorg, but not PRIME-usable, in that output is still broken?
    Yeap. Exact "So the drivers are PRIME-aware, in that multiple GPU's no longer causes an exception / crashes Xorg, but not PRIME-usable"

    A big step ahead from last years. Lets wait until RADEON driver get the prime ( or better ) support to. And AMD cards have a more mature way to play like NVIDIA.

    Funny is that linux is the oposite from Microsoft.
    At the release. Microsoft get the drive working, but late, when they stop to release drivers. Everything become fucked and you cant use your hardware anymore ( just look ahead IF manufacturer like hp will release some driver for WIN8. If same for the new one they are not ).

    Linux sometimes is slow to get some hardware support. but when this come. STAY THERE, STRONG.

  8. #8
    Join Date
    Jan 2009
    Posts
    1,309

    Default

    Quote Originally Posted by phoronix View Post
    Phoronix: Nouveau Releases New Driver With PRIME Support

    The xf86-video-nouveau 1.0.2 driver was released today to take advantage of the new capabilities of X.Org Server 1.13...

    http://www.phoronix.com/vr.php?view=MTE4MzA
    Can someone explain if PRIME can be leveraged for heterogeneous gpu work?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •