Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 44

Thread: AMD Catalyst 12.9 For Linux Brings Few Good Changes

  1. #31
    Join Date
    Aug 2011
    Posts
    10

    Default

    Quote Originally Posted by djdoo View Post
    Following Kano's workaround I finally installed it. Works nice, I see amdcccle reports 2D driver version 9.0.2, openGL 4.2.11903. No new options at amdcccle.
    OpenSUSE 12.2 here with stock Kernel 3.4.6, stock Xserver 1.12.3 and stock(updated) KDE 4.8.5.
    I think openGL ES 2.0 is disabled by blacklisting fglrx at kwin for KDE version prior 4.9... Does anyone know how to force the procedure??

    XVBA works via VAAPI mod through VLC output:
    Code:
    libva: VA-API version 0.33.0
    libva: User requested driver 'fglrx'
    libva: Trying to open /usr/lib64/dri/fglrx_drv_video.so
    libva: Found init function __vaDriverInit_0_32
    libva: va_openDriver() returns 0
    xvba_video: XVBA_GetSurface(): status 2
    [0x7f8d38c6dba8] avcodec decoder: Using VA API version 0.33 for hardware decoding.
    [h264 @ 0x7f8d38002a60] Cannot parallelize deblocking type 1, decoding such frames in sequential order
    Let's see if it works under Xserver 1.13...


    For reference I have Shadow Primary enabled with no problems. KDE runs smooth for now.
    Create a file in ~/.kde4/env with a name ending in '.sh'.

    The file should contain:
    Code:
    #!/bin/sh
    export KWIN_DIRECT_GL=1
    That will get you OpenGL 2 support. It works with KDE 4.9 in openSUSE but I didn't try it with the default 4.8.5.

  2. #32
    Join Date
    Oct 2007
    Posts
    54

    Default

    I don't see any performance improvement with KWIN_DIRECT_GL=1 and radeon hd 5670 (KDE 4.9 and fglrx-updates in ubuntu 12.04... I know it's not the newest driver but it will be always the same)

  3. #33
    Join Date
    Feb 2011
    Posts
    142

    Default

    fglrx-updates != 12.9

    In precise it is still version 12.4 - so it is ofc that you don't see any speedup.

  4. #34
    Join Date
    Aug 2011
    Posts
    10

    Default

    Quote Originally Posted by kirý View Post
    I don't see any performance improvement with KWIN_DIRECT_GL=1 and radeon hd 5670 (KDE 4.9 and fglrx-updates in ubuntu 12.04... I know it's not the newest driver but it will be always the same)
    I don't know if you should expect a performance improvement but it does allow you to enable the OpenGL 2 effects such as Invert. I don't know what driver version you are using in Ubuntu but OpenGL 2 works with 12.8 or 12.9 for me.

  5. #35
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    2,158

    Default

    Catalyst 12.9 Beta (at least for Windows) is going to be released *next* week. So this is nowhere near final.

  6. #36
    Join Date
    Oct 2007
    Posts
    54

    Default

    Quote Originally Posted by foxfire View Post
    I don't know if you should expect a performance improvement but it does allow you to enable the OpenGL 2 effects such as Invert. I don't know what driver version you are using in Ubuntu but OpenGL 2 works with 12.8 or 12.9 for me.
    I'm quite sure I had the "use opengl 2 shaders" option checked since kubuntu 11.10. Isn't this OpenGL 2 working since much time?

  7. #37
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default

    Guys first of all it does NOT work with xserver 1.13. I installed the whole stack of packages with the latest code from X11:Xorg repository for openSUSE 12.2(I did all the needed stuff first, like uninstalled catalyst via amdconfig --uninstall command, rebooted, then I did the package updates, logout-login, installed catalyst 12.9, reboot) and I couldn't login at all!
    I reinstalled the old packages from the standard repo, reinstalled catalyst 12.9 with Kano's mod and all is working now again.

    @foxifire: I did what you said but I created the folder ~./kde4/env cause it didn't exist and put inside the file as you described with the code you gave me.
    Can I find out somehow if openGL ES 2.0 really works??
    Last edited by djdoo; 09-17-2012 at 06:19 PM.

  8. #38
    Join Date
    Aug 2011
    Posts
    10

    Default

    Quote Originally Posted by kirý View Post
    I'm quite sure I had the "use opengl 2 shaders" option checked since kubuntu 11.10. Isn't this OpenGL 2 working since much time?
    In openSUSE it is reported to be working but it does not. My guess is Ubuntu does the same thing. Try to enable the Invert effect and see if it throws an error. That one only works if OpenGL 2 is being used.

  9. #39
    Join Date
    Oct 2007
    Posts
    54

    Default

    I'm sorry that I can't test this effect anymore as I'have nomore kde on my system. However if you find some performance improvement with opengl 2 let us know as I'm very interested about this.

  10. #40
    Join Date
    Sep 2007
    Location
    Athens-Hellas
    Posts
    255

    Default

    Quote Originally Posted by foxfire View Post
    In openSUSE it is reported to be working but it does not. My guess is Ubuntu does the same thing. Try to enable the Invert effect and see if it throws an error. That one only works if OpenGL 2 is being used.
    Works here!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •