I was running Ubuntu with an uptime for some two weeks or so. After downloading Black Mesa Source yesterday, I attempted to boot into Windows 7 to install the recently released mod but I got an error message before Grub2 loaded. The message read, “BOOTMGR is missing.” I then booted my Ubuntu Live disc and Googled the error message. I can’t recall exactly what it was that nudged me towards the conclusion that it was my two mass storage USB sticks plugged into my PC. I have my boot priority in my BIOS set to USB-HDD, CD Drive and then hard disk. My BIOS was probably looking for an O/S on those two storage USB sticks and it couldn’t find any. I removed my USB sticks which eliminated that error message. However, I then encountered different unusual behaviour. Now it hangs after, “Verifying DMI Pool Data.....” Google tells me that the source of problems similar to mine involve hardware and not software. Since I don't even get to Grub2 boot loader, it can`t be a problem with Ubuntu or Windows. As per advice I found on Google, I tried reverting to factory default settings in the BIOS. This yielded “Update Success” after "Verifying DMI Pool Data," but it still hangs. Also, I think my hard disk isn't the problem. My Ubuntu Live environment detects all the hard drives. I can see the contents of all my partitions, so I think I can safely rule out that it`s a faulty hard disk. What else could it be?

I ran a Memtest86 check and it said there were no errors detected.