Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Computer freezes with fglrx drivers

  1. #1
    Join Date
    Jun 2006
    Posts
    94

    Question Computer freezes with fglrx drivers

    Recently I bought a laptop with ATI Radeon Mobile X300 but I'm having some big problem with drivers from ATI (not with the one that comes with Xorg). What happens is that when I exit KDE to go to login screen it frequently happens that the computer completely freezes. Does anyone else have this problem? Is there any solution?

  2. #2

    Default

    It sounds like you have the system lockup/freeze bug on log-out to KDM. I believe a workaround may exist, however, I am not a KDE user so I don't know off hand.

    This looks like the the BugZilla entry for your problem @ http://ati.cchtml.com/show_bug.cgi?id=239

  3. #3
    Join Date
    Jun 2006
    Posts
    94

    Angry

    Yeah that is exactly the same bug. And I noticed it is in the database for a very long time. Is ATI even aware of this bug (do they check the database)? If they are aware of this then it is realy sad that it is taking them so long to fix such a big bug

    Anyway thanks for pointing me to this bug report. I'll see how it goes with the workaround.

  4. #4

    Default

    Quote Originally Posted by Tsiolkovsky
    Yeah that is exactly the same bug. And I noticed it is in the database for a very long time. Is ATI even aware of this bug (do they check the database)? If they are aware of this then it is realy sad that it is taking them so long to fix such a big bug

    Anyway thanks for pointing me to this bug report. I'll see how it goes with the workaround.
    Some ATI Linux developers do monitor the unofficial BugZilla, and yes they should be aware of the bug. Hopefully it should be fixed soon.

  5. #5

    Default

    I also experience this problem. People I've consulted, especially the guys at Rage 3d were ready to put the blame on my hardware. I just think it never made sense to blame the hardware since it works fine in Windows.

    Thanks for the link, Michael. My "workaround" to this one was moving boot to init 3. That way, I don't restart gdm log-in. I'll try modifying the scripts and see what happens.

  6. #6

    Default

    I would just like to report that the kdmrc and gdm hacks did not work for me. Thumbs down ATi... thumbs down.

    I'll try to postsession hacks.

    EDIT:

    None of the workarounds work. I've set it back to init 3. These are just examples of my stability complaints on ATi. And I know very well ATi hasn't fixed these problems. *sigh* Maybe after 10 releases...
    Last edited by niniendowarrior; 07-07-2006 at 09:47 PM.

  7. #7
    Join Date
    Aug 2006
    Posts
    1

    Default Workaround

    After a few days of not being able to restart X, I started turning things off that might have caused the video card to do something unexpected. I was able to get X to restart properly by disabling radeonfb. I'm not entirely sure why, but if you are using the radeon framebuffer included with the kernel, fglrx starts acting strange.

    How to fix it:
    Remove radeonfb support from your kernel. The VESA framebuffer will work fine.
    In 2.6.17 the framebuffer options are located in
    "Device Drivers --> Graphics Support"
    If you have it compiled into the kernel and don't feel like rebuilding you can add "video=radeonfbff" to your kernel arguments to disable it.

    Hope this helps.

  8. #8

    Default

    Quote Originally Posted by synack View Post
    After a few days of not being able to restart X, I started turning things off that might have caused the video card to do something unexpected. I was able to get X to restart properly by disabling radeonfb. I'm not entirely sure why, but if you are using the radeon framebuffer included with the kernel, fglrx starts acting strange.

    How to fix it:
    Remove radeonfb support from your kernel. The VESA framebuffer will work fine.
    In 2.6.17 the framebuffer options are located in
    "Device Drivers --> Graphics Support"
    If you have it compiled into the kernel and don't feel like rebuilding you can add
    Code:
    video=radeonfb:off
    to your kernel arguments to disable it.
    Hope this helps.
    If I understand it correctly, you had it set in the grub boot, correct?

    How can I check if radeonfb is compiled in the kernel or as module?

    I'm willing to try this out during the weekend.

  9. #9
    Join Date
    Jun 2006
    Posts
    94

    Default

    The bug is still here in 8.28.8 drivers. All I can say until this gets fixed is: Don't buy ATI hardware.

  10. #10

    Default

    I know how you feel Tsiolkovsky. I've fed myself alot of ATi hate material in the past and it's not very nice. We both had very bad experience with ATi but that's not to say it's bad for everyone. Michael, for one, doesn't experience bad-to-the-bone nightmares using ATi.

    I guess from here, it's finding a workaround or moving to a different graphics card manufacturer. Have you tried the radeonfb workaround because my questions about it have gone unanswered.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •