Results 1 to 4 of 4

Thread: Nvidia proprietary driver regresses after I reinstall it

Threaded View

  1. #1
    Join Date
    Sep 2009
    Posts
    129

    Default Nvidia proprietary driver regresses after I reinstall it

    Okay, this is a weird one.

    I realize that this post is light on technical info, but that's because I'm so unfamiliar with this topic that I'm not sure where to look for technical info. Anyone more knowledgeable, please feel free to ask me to post config files, etc. that might be relevant.

    TL;DR: After installing the latest proprietary Nvidia drivers, performance regressed quite severely in some games, but even after reinstalling the obsolete driver from the repos I'd been using before, performance hasn't gone back to previous levels.

    Hardware: Thinkpad T510, Nvidia NVS 3100M PCI-E 512 Mib GDDR3, Core i5 @2.53 Ghz, hyperthreading enabled (4 logical cores, 2 physical,) RAM upgraded to 4 GiB.

    Software: Linux Mint 10, 32-bit Linux 2.6.35-32-generic-pae kernel, Gnome 2.32 w/ Metacity, no compositing window manager effects, various versions of the Nvidia proprietary driver.

    Long version:
    I'm running Linux Mint 10 (= Ubuntu Maverick.) I know, I know, not supported anymore. I'll upgrade it when I have time. It's not really relevant for this question. I've been using that distro's version of the nvidia-current drivers for a while now. That package contains the 260.19.06 beta drivers.

    I decided to give the 304.51 drivers a shot, and discovered that my gaming framerates had decreased by about 10-20%. I tried tweaking all the settings in the Nvidia GUI: sync to vblank, "image settings" slider, even pegging the GPU clock at max performance. I concluded that this must be a regression in the nvidia drivers, so I decided to be a good citizen and figure out what version had introduced the regression so I could write a good bug report.

    However, every version I tried still had that same performance hit. I tried 304.22, 270.41.06, 260.19.44-- I even dug up the same 260.19.06 beta version I'd installed from the repositories on Nvidia's FTP server, and it was still slower! I made sure to check the settings in the Nvidia GUI each time.

    Okay fine, so the Ubuntu packagers must do something special to make it faster than Nvidia's .run package. No problem, I thought, I'll just go back to the version from the repositories. So I did that, and it certainly was a hassle-- it involved manually removing files from /var/lib/dkms and .ko files from /lib/modules, then reinstalling the package. But it worked, and I'm now back to Ubuntu's version, I think.

    Except performance hasn't improved. In one scene, it's still 205 FPS where it should be 260.

    I'm stumped. Does anyone have any idea what's going on?
    Last edited by MaxToTheMax; 09-30-2012 at 06:04 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •