Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: fglrx 8.01 buildpkg Debian/lenny fails

  1. #1
    Join Date
    Oct 2007
    Posts
    91

    Default fglrx 8.01 buildpkg Debian/lenny fails

    The included buildpkg script for Debian/lenny is failing on my system for fglrx 8.01. The script in version 7.12 and 7.11 worked flawlessly, even if the drivers themselves left me wanting. How do I access the latest script, or does anyone have any suggestions on how else to fix this problem?

    Thanks


    $ sh ati-driver-installer-8-01-x86.x86_64.run --buildpkg Debian/lenny

    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.452.1........................................... .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ....
    ==================================================
     ATI Technologies Linux Driver Installer/Packager 
    ==================================================
    Generating package: Debian/lenny
    Package build failed!
    Package build utility output:
    dpkg-buildpackage: source package fglrx-installer
    dpkg-buildpackage: source version 8.452.1-1
    dpkg-buildpackage: source changed by ATI Technologies Inc. <http://ati.amd.com/support/driver.html>
    debian/rules build
    dpkg-buildpackage: host architecture i386
    dh_testdir
    # move licenses away from binary dir
    if [ ! -d usr/share/doc/fglrx ]; then \
    mkdir -p usr/share/doc/fglrx; \
    mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
    fi
    # set executable on user apps
    find usr/X11R6/bin -type f | xargs chmod a+x
    # remove exec bit from files that don't deserve it
    find usr/X11R6/include \
    usr/X11R6/lib \
    usr/X11R6/lib64 \
    usr/share usr/src -type f | xargs chmod -x
    find: usr/X11R6/lib64: No such file or directory
    find lib -not -name "*.sh" -type f | xargs chmod -x
    find lib -name "*.sh" -type f | xargs chmod +x
    # set proper permissions on /etc files
    if [ -d etc/ati ]; then \
    chmod 755 etc/ati ; \
    chmod 644 etc/ati/* ; \
    chmod a+x etc/ati/*.sh ; \
    fi
    if [ -f debian/fglrx.default ]; then \
    mv -v debian/fglrx.default debian/fglrx; \
    fi
    `debian/fglrx.default' -> `debian/fglrx'
    fakeroot debian/rules binary
    dh_testdir
    # move licenses away from binary dir
    if [ ! -d usr/share/doc/fglrx ]; then \
    mkdir -p usr/share/doc/fglrx; \
    mv usr/X11R6/bin/LICENSE.* usr/share/doc/fglrx; \
    fi
    # set executable on user apps
    find usr/X11R6/bin -type f | xargs chmod a+x
    # remove exec bit from files that don't deserve it
    find usr/X11R6/include \
    usr/X11R6/lib \
    usr/X11R6/lib64 \
    usr/share usr/src -type f | xargs chmod -x
    find: usr/X11R6/lib64: No such file or directory
    find lib -not -name "*.sh" -type f | xargs chmod -x
    find lib -name "*.sh" -type f | xargs chmod +x
    # set proper permissions on /etc files
    if [ -d etc/ati ]; then \
    chmod 755 etc/ati ; \
    chmod 644 etc/ati/* ; \
    chmod a+x etc/ati/*.sh ; \
    fi
    if [ -f debian/fglrx.default ]; then \
    mv -v debian/fglrx.default debian/fglrx; \
    fi
    dh_testdir
    dh_testroot
    dh_clean -k
    dh_installdirs
    # Create the directories to install into
    dh_installdirs -pfglrx-driver \
    usr \
    usr/lib/xorg \
    usr/lib/xorg/modules \
    usr/lib/dri \
    usr/bin \
    usr/sbin \
    etc/acpi \
    etc/acpi/events \
    etc/default \
    etc/X11/Xsession.d
    dh_installdirs -pfglrx-driver-dev \
    usr \
    usr/include \
    usr/lib
    dh_installdirs -pfglrx-kernel-src \
    usr/src/modules/fglrx \
    usr/src/modules/fglrx/debian
    dh_installdirs -A -pfglrx-amdcccle \
    usr \
    usr/bin \
    usr/share \
    usr/share/applnk \
    usr/share/applications \
    usr/share/icons \
    usr/share/pixmaps
    dh_installdirs -p \
    usr/src
    dh_install
    dh_install -pfglrx-driver "usr/X11R6/bin/fgl*" "usr/bin"
    dh_install -pfglrx-driver "usr/X11R6/bin/aticonfig" "usr/bin"
    dh_install -pfglrx-driver "usr/sbin/atieventsd" "usr/sbin"
    dh_installman -pfglrx-driver "usr/share/man/man8/atieventsd.8"
    # amd64 needs some library redirection
    dh_install -pfglrx-driver "usr/X11R6/lib/*.so*" "usr/lib"
    dh_install -pfglrx-driver "usr/X11R6/lib/modules/dri" "usr/lib"
    dh_install -pfglrx-driver "usr/X11R6/lib/modules/linux" "usr/lib/xorg/modules"
    dh_install -pfglrx-driver "usr/X11R6/lib/modules/drivers" "usr/lib/xorg/modules"
    dh_install -pfglrx-driver "usr/X11R6/lib/modules/*.so" "usr/lib/xorg/modules"
    dh_install -pfglrx-driver "usr/X11R6/lib/modules/*.a" "usr/lib/xorg/modules"
    dh_install -pfglrx-driver "etc/fglrx*" "etc"
    dh_install -pfglrx-driver "etc/ati" "etc"
    dh_install -pfglrx-driver "debian/70fglrx" "etc/X11/Xsession.d"
    dh_install -pfglrx-driver "debian/fglrx-powermode.sh" "etc/acpi"
    dh_install -pfglrx-driver "debian/fglrx-*-aticonfig" "etc/acpi/events"
    dh_install -pfglrx-driver "debian/fglrx" "etc/default"
    dh_installinit -pfglrx-driver --name="atieventsd"
    # create symlinks to shared libs
    dh_link -pfglrx-driver "usr/lib/libGL.so.1.2" "usr/lib/libGL.so.1"
    dh_install -pfglrx-driver-dev "usr/X11R6/lib/*.a" "usr/lib"
    dh_install -pfglrx-driver-dev "usr/X11R6/include/*" "usr/include"
    dh_install -pfglrx-driver-dev "usr/include/*" "usr/include"
    dh_install -pfglrx-kernel-src \
    lib/modules/fglrx/build_mod/*.c \
    lib/modules/fglrx/build_mod/*.h \
    lib/modules/fglrx/build_mod/*.sh \
    lib/modules/fglrx/build_mod/lib* \
    lib/modules/fglrx/build_mod/2.6.x/Makefile \
    usr/src/modules/fglrx
    dh_install -pfglrx-kernel-src "debian/changelog" "usr/src/modules/fglrx/debian"
    dh_install -pfglrx-kernel-src \
    debian/copyright \
    debian/compat \
    module/rules \
    module/control.template \
    module/dirs.template \
    module/postinst \
    usr/src/modules/fglrx/debian
    (cd debian/fglrx-kernel-src/usr/src \
    && chown -R root:src modules \
    && tar -jcf fglrx.tar.bz2 modules \
    && rm -rf modules)
    # control panel package
    dh_install -A -pfglrx-amdcccle "usr/X11R6/bin/amdcccle" "usr/bin"
    dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm" "usr/share/icons"
    dh_install -A -pfglrx-amdcccle "usr/share/icons/*.xpm" "usr/share/pixmaps"
    dh_install -A -pfglrx-amdcccle "debian/amdcccle.desktop" "usr/share/applications"
    dh_install -A -pfglrx-amdcccle "debian/amdcccle.kdelnk" "usr/share/applnk"
    dh_install -A -pfglrx-amdcccle "usr/share/ati" "usr/share"
    dh_desktop -pfglrx-amdcccle
    dh_installdocs
    dh_installdocs -pfglrx-driver usr/share/doc/fglrx/*
    #dh_installchangelogs
    dh_link
    dh_strip
    dh_compress
    dh_makeshlibs
    dh_installdeb
    LD_PRELOAD= dh_shlibdeps --exclude=emul
    dpkg-shlibdeps: warning: symbol _XFlush used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextAddDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol _XReply used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextRemoveDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextCreateExtension used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: symbol XextFindDisplay used by debian/fglrx-driver/usr/lib/libfglrx_pp.so.1.0 found in none of the libraries.
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libpthread.so.0 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with librt.so.1 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libdl.so.2 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/lib/xorg/modules/drivers/fglrx_drv.so shouldn't be linked with libm.so.6 (it uses none of its symbols).
    dpkg-shlibdeps: warning: debian/fglrx-driver/usr/bin/fglrxinfo shouldn't be linked with libXext.so.6 (it uses none of its symbols).
    dpkg-shlibdeps: failure: couldn't find library libfglrx_gamma.so.1 needed by debian/fglrx-driver/usr/bin/fglrx_xgamma (its RPATH is '').
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: command returned error code 512
    make: *** [binary] Error 1
    dpkg-buildpackage: failure: fakeroot debian/rules binary gave error exit status 2
    Removing temporary directory: fglrx-install.pP6057

  2. #2
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    Be sure that your xorg.conf is useable, then just execute:

    http://kanotix.com/files/install-fglrx-debian.sh

  3. #3
    Join Date
    Oct 2007
    Posts
    91

    Default

    I found the solution. I first tried installing the latest script from phorogit, but the buildpkg still failed.

    To get it working, I first extracted the archive, then I created a symbolic link
    to: fglrx-install/arch/x86/usr/X11R6/lib/libfglrx_gamma.so.1
    from: fglrx-install/arch/x86/usr/X11R6/lib/libfglrx_gamma.so.1.0

    Then I ran the fglrx-install/ati-installer.sh buildpkg script.
    Last edited by sandain; 01-18-2008 at 05:45 PM.

  4. #4

    Default

    Quote Originally Posted by sandain View Post
    I found the solution. I first tried installing the latest script from phorogit, but the buildpkg still failed.

    To get it working, I first extracted the archive, then I created a symbolic link
    to: fglrx-install/arch/x86/usr/X11R6/lib/libfglrx_gamma.so.1
    from: fglrx-install/arch/x86/usr/X11R6/lib/libfglrx_gamma.so.1.0

    Then I ran the fglrx-install/ati-installer.sh buildpkg script.
    When I run ati-installer.sh it just says unrecognized parameter and won't build.

  5. #5
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    Why don't you run my script? As long as your xorg.conf is correct the script will work fine.

  6. #6

    Default

    Quote Originally Posted by Kano View Post
    Why don't you run my script? As long as your xorg.conf is correct the script will work fine.
    I get this error

    Error: No KANOTIX found. Do not ask for support!
    Error: Bad /etc/X11/xorg.conf file.

    My xorg.conf file is pretty much empty, nothing detected properly.

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    EndSection

  7. #7

    Default

    After looking at Kano's script, your error is being generated because inside your "Configured Video Device" section you have no Device line mentioning vesa or another driver. Try adding Driver "vesa" to your device section and then try...

  8. #8
    Join Date
    Aug 2007
    Posts
    6,607

    Default

    Well you need a Screen section too to set the default to 24 bit. I really dislike what the current lenny/sid default is. Before it was more easy to replace the needed parts.

  9. #9

    Default

    im also trying do --buildpkg but without no result...

    so you suggest to run this command right(see if it is right because im so noob...)

    Code:
    ln -s fglrx-install/arch/x86/usr/X11R6/lib/libfglrx_gamma.so.1 
    fglrx-install/arch/x86/usr/X11R6/lib/libfglrx_gamma.so.1.0
    but without the space between 1 .0 for second file?
    I'm right?

  10. #10

    Default

    The script worked, I just had to change it to build for hardy.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •