So, a little report on my experience with Ivy Bridge + AMD Enduro on a Clevo P170EM / intel HM77 chipset.

Graphics hardware:
Code:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI WIMBLEDON XT [Radeon HD 7970M] (rev ff)
1. Doing nothing
Since it's a HD 7970 it runs quite hot on the default power profile.
Code:
default engine clock: 850000 kHz
current engine clock: 849990 kHz
default memory clock: 1200000 kHz
current memory clock: 1199990 kHz
voltage: 1050 mV

1.1 radeon power profiles
This is my second radeon notebook chip where the mid and the low power profile produce the same result:
Code:
default engine clock: 850000 kHz
current engine clock: 299990 kHz
default memory clock: 1200000 kHz
current memory clock: 149990 kHz
voltage: 1050 mV
On the low/mid profile the temperature seems to be quite stable
Code:
radeon-pci-0100
Adapter: PCI adapter
temp1:        +46.0C
But occassionally the fan gets louder for a short time.


1.2 vgaswitcheroo
So what you really want to do is disabling that card. The first thing I tried was vgaswitcheroo:
Code:
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
This disables the discrete card (DIS = discrete, IGD = integrated as I have learned):
Code:
cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0
Problem 1: It seems to disable the fan control too so the fan keeps running at whatever speed it was running before disabling the discrete card.
So what I do is
Code:
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
# wait a few seconds until the card is cool
echo ON > /sys/kernel/debug/vgaswitcheroo/switch
# the fan is shut off since the card is cool enough
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
# now the fan is off and stays off
Problem 2: It seems to be not too reliable. It sometimes seems to freeze X and when I try OFF directly on boot it doesn't really work, and when I try it manually again it just hangs. When this happens, reboot doesn't work either.

2.0 PRIME
A sad topic.
I run the latest git version of xorg, mesa and mainline linux 3.6.
xrandr --listproviders won't show the discrete card, unless X is started while radeon is enabled.

Then it looks like this:
Code:
$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 112 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 3 outputs: 8 associated providers: 0 name:Intel
Provider 1: id: 69 cap: 0xd, Source Output, Source Offload, Sink Offload crtcs: 6 outputs: 0 associated providers: 0 name:radeon
The manpage of xrandr from git still doesn't contain information to offloaders, but there are only two possibilities:
Code:
$ xrandr --setprovideroffloadsink 112 69
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  34 ()
  Value in failed request:  0x70
  Serial number of failed request:  11
  Current serial number in output stream:  12

$ xrandr --setprovideroffloadsink 69 112
The second one has no output and I think that's a good sign.

Code:
$ DRI_PRIME=0 glxinfo | grep OpenGL
ATTENTION: default value of option force_s3tc_enable overridden by environment.
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL version string: 3.0 Mesa 9.1-devel (git-34c58ac)
OpenGL shading language version string: 1.30
OpenGL extensions:
So far so good.
Code:
$ DRI_PRIME=0 glxinfo | grep OpenGL
unfortunately crashes X:
Code:
[  3712.534] (EE) Backtrace:
[  3712.534] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x589656]
[  3712.534] (EE) 1: /usr/bin/X (0x400000+0x18d479) [0x58d479]
[  3712.534] (EE) 2: /usr/lib/libpthread.so.0 (0x7fa23d94c000+0xf170) [0x7fa23d95b170]
[  3712.534] (EE) 3: /usr/bin/X (0x400000+0x15a03b) [0x55a03b]
[  3712.534] (EE) 4: /usr/bin/X (DRI2Connect+0x77) [0x55bf27]
[  3712.534] (EE) 5: /usr/bin/X (0x400000+0x15d0e4) [0x55d0e4]
[  3712.534] (EE) 6: /usr/bin/X (0x400000+0x37d16) [0x437d16]
[  3712.535] (EE) 7: /usr/bin/X (0x400000+0x268ca) [0x4268ca]
[  3712.535] (EE) 8: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7fa23c5eb725]
[  3712.535] (EE) 9: /usr/bin/X (0x400000+0x26c0d) [0x426c0d]
[  3712.535] (EE) 
[  3712.535] (EE) Segmentation fault at address 0x28
[  3712.535] 
Fatal server error:
[  3712.535] Caught signal 11 (Segmentation fault). Server aborting
[  3712.535] 
[  3712.535] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help.
Question: Is the PRIME crash known/expected? Do I need to do something else to get it working? I got the same the last time I tried a notebook with optimus. Shall I report a bug? The HD 7970M support is maybe not ready but it surely should run glxinfo, right?


Next I will try PCI passthrough / VGA passthrough to a windows 7 VM (I have a CPU with vt-d and even though intel says the HM77 chipset doesn't support vt-d, with a bios update it is supposed to). Let's see how that turns out.