Results 1 to 10 of 33

Thread: Problem with 8.01: "Failed to initialize ASIC in kernel"

Threaded View

  1. #1
    Join Date
    Jan 2008
    Posts
    27

    Exclamation [Solved] Problem with 8.01: "Failed to initialize ASIC in kernel"

    ***** This issue has been solved by means of a workaround - see below! ****

    Hello,

    since version 8-01 aka 8.452 I am experiencing this disturbing 'failed to initialize ASIC' error that I have not seen in previous versions:

    Code:
    (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
            compiled for 7.1.0, module version = 8.45.4
            ABI class: X.Org Server Extension, version 0.3
    (II) fglrx(0): Using adapter: 1:0:0.
    (EE) fglrx(0): Failed to initialize ASIC in kernel.
    (--) fglrx(0): VideoRAM: 262144 kByte, Type: DDR3
    (II) fglrx(0): PCIE card detected
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    Additionally or maybe consequently (?) the system has trouble with the PCIe memory:

    Code:
    (**) fglrx(0): ATI GART size: 256 MB
    (EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1014)
    And I finally end up without 3D support:

    Code:
    (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
    (WW) fglrx(0): ***********************************************
    (WW) fglrx(0): * DRI initialization failed!                  *
    (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
    (WW) fglrx(0): * 2D acceleraton available (MMIO)             *
    (WW) fglrx(0): * no 3D acceleration available                *
    (WW) fglrx(0): ********************************************* *
    EDIT: In the syslog the errors look like this:

    Code:
    kernel: [fglrx] Maximum main memory to use for locked dma buffers: 928 MBytes.
    kernel: [fglrx] ASYNCIO init succeed!
    kernel: [fglrx] PAT is enabled successfully!
    kernel: [fglrx] module loaded - fglrx 8.45.4 [Jan 16 2008] on minor 0
    kernel: [fglrx:firegl_cail_init] *ERROR* CAIL: CAILEarlyASICInit failed, error 1
    kernel: [fglrx:firegl_init_asic] *ERROR* Failed to initialize ASIC.
    kernel: [fglrx:drm_vmalloc] *ERROR* [mempages] Allocating 0 bytes
    kernel: [fglrx:firegl_init_pcie] *ERROR* failed to alloc pagelist of size 00
    I have not seen any of these errors in version 7-12 aka 8.443.

    Any ideas on what the problem is or how to fix it?

    System: OpenSUSE 10.2 (32-bit) / kernel 2.6.24-rc7 / Xorg 7.3 (Xserver 1.4)
    Graphics: ATI Mobility Radeon X1900.

    EDIT:
    * Checked with kernels 2.6.23 and 2.6.22: same errors - so it's not a kernel 2.6.24 issue!
    * Re-checked with fglrx 8.443 (just to be sure): no errors here
    ==> something is very different with fglrx 8.452 as opposed to earlier versions!

    EDIT:
    Looks like I'm not the only one experiencing these problems:
    http://ati.cchtml.com/show_bug.cgi?id=987

    EDIT:
    There's another report of this bug here.

    So far there are two reports with a Mobility X1400 and mine with the Mobility X1900.
    Do we see a pattern forming here? Both the X1400 and the X1900 are a bit different from the rest of the X1xxx series...

    EDIT:
    We now have 5 confirmed reports of the "failed to initilize ASIC" error. The chips involved are the X1900, X1400 (twice), X300 and X700 (all of them Mobility Radeon). Interestingly all of these systems were running openSUSE 10.2/10.3 with X.org 7.3 (xserver 1.4).

    While from first three reports it looked like it was an issue specific to the X1900 and X1400 adapters, there are now two people with a X1400 reporting they are not seeing the ASIC bug (lucky you!). They are both running Gutsy with X.org 7.2 (xserver 1.3) though!

    So is that the new common denominator?
    Xorg 7.3 or OpenSUSE 10.2 / 10.3 or the combination?

    EDIT:
    Antiarch posted a workaround for this issue:
    Quote Originally Posted by Antiarch View Post
    The good news is there's a simple work around for it. Find the Device section in your xorg.conf (Section "Device") and look for a line that starts with BusID. In quotes will be something like "1:0:0" (there will be different numbers depending on your card) Before that string of numbers, add "PCI:", to make it look like this: "PCI:1:0:0".
    Such a faulty(?) "BusID" entry is generated by SaX2, the openSuSE X-setup-tool.
    So we were on the right track...

    Thanks to Antiarch and sndirsch for spreading / providing the workaround!

    Cheers,
    knutbert
    Last edited by knutbert; 01-30-2008 at 04:28 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •