The driver has lots of problems with Xserver 1.4. Usually it starts, but AIGLX does not work and the first 3d app (except glxgears) hangs. Maybe ATI should compile it against Xserver 1.4 direct instead of using the same binary like for 1.3.