Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Ubuntu 12.04 Needs New Drivers For Valve's Source

  1. #11
    Join Date
    Nov 2008
    Posts
    142

    Default

    Quote Originally Posted by Ragas View Post
    Funny how that goes. I have the same card (minus the ghz edition, but that's mostly just clockspeeds) And it works like a charm on catalyst.

    Maybe you should stop blaming your own Incompetence on other people.

    I'm sorry if that sounded rude, but I had to say it, since I see stuff like this way to often. If you need some help with your drivers, just ask before assuming it's not working.
    My card is Saphire HD 7870 GHz edition (as I said) with 2GB GDDR5. It works perfectly with Windows 7 and semi-works with Ubuntu 12.04 with catalyst (no hdmi sound, crashes unity whenever it feels so).

    However it does not work at all with Ubuntu 12.10. After I install catalyst the PC becomes unbootable, not even in safe-mode. So far I have tried clean installs with Ubuntu, Kubuntu (just in case it was a compiz thing), and then installing the driver from the repositories and also from straight amd.com downloads. This is clearly a catalyst problem. Yes, maybe I am incompetent for you linux l33ts. In any case AMD is not going to see my money again. I have had nvidia cards for years and their drivers always worked great for me.
    Last edited by zoomblab; 11-06-2012 at 02:04 PM.

  2. #12
    Join Date
    Nov 2008
    Posts
    142

    Default

    Quote Originally Posted by nadro View Post
    I see two options in zoomblab case:
    1. He is just a troll or NV fanboy and he haven't any Radeon card in PC.
    2. His knowledge about software is really low, he broken Your OS and now say that this is AMD fault...

    The bad thing is that probably we will not see updated drivers for HD2k-HD4k...
    Did you know that in order to install the official catalyst 12.10 driver (downloaded from amd.com) you have to have: debhelper, dh-make, dh-modaliases, execstack, lib32gcc1, libc6-i386 and dkms packages also installed? AMD made me learn that and I kept notes. Unfortunatelly that pain only helped as far as successfuly installing a broken driver. Indeed my knowledge is low. I don't even know how to compile the kernel. These things are like obvious to you guys right?
    Last edited by zoomblab; 11-06-2012 at 02:34 PM.

  3. #13
    Join Date
    Aug 2012
    Posts
    245

    Default

    Quote Originally Posted by zoomblab View Post
    My card is Saphire HD 7870 GHz edition (as I said) with 2GB GDDR5. It works perfectly with Windows 7 and semi-works with Ubuntu 12.04 with catalyst (no hdmi sound, crashes unity whenever it feels so).

    However it does not work at all with Ubuntu 12.10. After I install catalyst the PC becomes unbootable, not even in safe-mode. So far I have tried clean installs with Ubuntu, Kubuntu (just in case it was a compiz thing), and then installing the driver from the repositories and also from straight amd.com downloads. This is clearly a catalyst problem. Yes, maybe I am incompetent for you linux l33ts. In any case AMD is not going to see my money again. I have had nvidia cards for years and their drivers always worked great for me.
    It does sound like a Catalyst problem ... But to be on the safe side, I'll add these. Ubuntu 12.10 had the issue of (for some reason) not including the kernel headers .... You can easily install them though by adding the "linux-headers-generic" package(assuming you have vanilla kernel, for pae etc there's a similar package you should install). It's needed to properly install fglrx/Catalyst. If you didn't have that, then you should try installing it and purging-reinstalling Catalyst.

    Also make sure sure to run "sudo amdconfig --initial -f" at the end of installation(manual or from repos). You probably did that, but I mention it to be on the safe side.

    Btw, by unbootable, you mean like black screen with a blinking cursor, it just hangs when about to launch X, your wallpaper is the only thing appearing, kernel panic message and forced to shut down. Mostly curiosity. If I have a clue of what you could do more I'll share with you for sure though. Cheers.

    **Edit: It may be bootable with nomodeset if Catalyst breaks it still. No 3d, but you can restore it to before and fix it possibly(desktop probably not working, so I'd suggest using a virtual terminal then). If it's not bootable even with that after installing Catalyst, there's probably some serious stuff going on there ...
    Last edited by Rigaldo; 11-06-2012 at 02:37 PM.

  4. #14
    Join Date
    Nov 2008
    Posts
    142

    Default

    Quote Originally Posted by Rigaldo View Post
    It does sound like a Catalyst problem ... But to be on the safe side, I'll add these. Ubuntu 12.10 had the issue of (for some reason) not including the kernel headers .... You can easily install them though by adding the "linux-headers-generic" package(assuming you have vanilla kernel, for pae etc there's a similar package you should install). It's needed to properly install fglrx/Catalyst. If you didn't have that, then you should try installing it and purging-reinstalling Catalyst.

    Also make sure sure to run "sudo amdconfig --initial -f" at the end of installation(manual or from repos). You probably did that, but I mention it to be on the safe side.

    Btw, by unbootable, you mean like black screen with a blinking cursor, it just hangs when about to launch X, your wallpaper is the only thing appearing, kernel panic message and forced to shut down. Mostly curiosity. If I have a clue of what you could do more I'll share with you for sure though. Cheers.

    **Edit: It may be bootable with nomodeset if Catalyst breaks it still. No 3d, but you can restore it to before and fix it possibly(desktop probably not working, so I'd suggest using a virtual terminal then). If it's not bootable even with that after installing Catalyst, there's probably some serious stuff going on there ...
    Indeed I had to execute sudo apt-get install linux-headers-$(uname -r) and sudo amdconfig --initial at the end. After that it would freeze right after the grub selection. No wallpaper, no blinking cursor, just blank screen and no response to any key whatsoever. In safe mode it printed some messages for a short while and then also freeze.

    Thank you for your help though!

  5. #15
    Join Date
    Aug 2012
    Posts
    245

    Default

    What about adding nomodeset to GRUB entry before booting?(press "e" on the entry and add "nomodeset" at the end of the line starting with linux, then press F10). Doesn't boot still? Weird that it's like that .. I don't recall facing this situation any time ..
    The only thing I can think of that could work is trying out a PPA that downgrades X.org and allows to install the legacy drivers for Ubuntu 12.10(not recommended though ..). In the weird case the driver treats the card as a 4xxx series(for example it might basically be a 4xxx overclocked, I think they do some stuff of this kind, or just a bug). It's crazy enough to work ..
    I suggest you file a bug if you want to as well, to AMD or Ubuntu(the latter will have to forward it to the first anyways).
    I guess I have no idea then .....

  6. #16
    Join Date
    Sep 2008
    Posts
    251

    Default

    @zoomblab just some explanation why some people went aggressive against you and your post:

    What you said (in your first post) was, that your graphiccard does not work with AMD's driver.

    What you meant was that AMD's driver does not work with Ubuntu 12.10.

    Also while it helps reducing frustration, it doesn't help you with your problem to write such a post...and while you may not be able to hack around this, someone somewhere has figured out how to solve the problem (in fact, in all the years I am on the interwebz it was only in two or three cases that I was the 'first' person to encounter a real problem. (aside from beta tests of games)).

    [suggestion]
    In the future, if you've the urge to write such a post. Do it, but after you are done read it think about what you really want (that the problem goes away) think how this post will help you with that task (not much), take a deep breath (not a must), delete the text in the unposted textbox and create a thread in the appropiate forum and ask for help. Also check your favorite search engine's search results.
    [/suggestion]
    Good day/evening/night.
    Last edited by Detructor; 11-06-2012 at 04:42 PM.

  7. #17

    Default

    Quote Originally Posted by zoomblab View Post
    Did you know that in order to install the official catalyst 12.10 driver (downloaded from amd.com) you have to have: debhelper, dh-make, dh-modaliases, execstack, lib32gcc1, libc6-i386 and dkms packages also installed? AMD made me learn that and I kept notes. Unfortunatelly that pain only helped as far as successfuly installing a broken driver. Indeed my knowledge is low. I don't even know how to compile the kernel. These things are like obvious to you guys right?
    Did you know on driver page http://support.amd.com/us/gpudownloa...eon_linux.aspx there is link to wiki http://wiki.cchtml.com where all this things is explained?
    Did you know, Catalyst 12.10 is incompatible with Ubuntu 12.10, and you need to install drive from Ubuntu repository or 12.11 Beta instead? (It's explained in wiki too.)
    Looks like you tried driver from Ubuntu repository, but without at least dmesg and Xorg.0.log (you may take it using LiveCD) there is not much we can do to understand what fail on your setup.

    If you have unbootable Ubuntu 12.10 with Catalyst 12.10, then boot from this disk/flash go to Advanced>Rescue>answer bunch of questions>select system partition>Execute a shell in your system partition. Now you can remove driver and, if you want, try again with 12.11 Beta (if result will be the same - give us logs this time).

  8. #18
    Join Date
    Aug 2011
    Posts
    62

    Default

    I have installed nvidia driver 304.64 in mint 13 mate 32bit (ubuntu 12.04), on a 7600GT. This driver seems to run great and what little 3D content I could run ran smooth.
    I copied a few warez games for Windows from a remote host, only Warcraft III works reliably or at all (but with a sound bug) ; I could run CS:Source's stress test totally fine (not a local server with bots, plain Wine 1.4 was not up the task).

    So I'm confident Steam will work and give me playable games. I'd wish to get DoD:Source and CS:Source, which I never played (I had Steam many years ago with all the HL1 games but even then I would rather run Counterstrike 1.5)

    Driver was a bitch to install, after troubleshooting (don't forget to set up a readable text console on ctrl-alt-f1/f2/etc.) I made some progress : I had driver 295.40 present in the package manager, so I needed to uninstall those packages. Then nvidia 304.64 installation, from the downloaded 38MB "script", still failed. Now it's nouveau that pissed me off, so of course you have to blacklist the module but I missed something for some reason, then I get the desktop working in VESA, I don't remember why I did that but it was nice being able to do so.
    Then it was fixed, 304.64 was correctly installed.

    But at almost every step, I would frantically try to fuck with the /etc/X11/xorg.conf, and called "service mdm stop" and "service mdm start" a billion times. Now I remember, nvidia driver used to say in a text mode error message, "No screens found", it took me some time to clean up the xorg.conf with some stupidity hanging in it (a Screen "1", the old 8400GS as Device "0", Modeline stuff I had failed to get working but was still there)
    And the worst thing is, my xorg.conf says Driver "vesafb", but it's the nvidia driver that runs! (it took over when it was correctly installed and working)

    I know this stuff isn't always easy but having to fuck around this much as an experienced user, with some things that don't make sense, is too much. Anyone else I know (barring a couple of people) would have given up, or even left the computer unable to start a graphical session and reinstalled the OS.
    Years back I remember nvidia driver installation from terminal totally painless on Ubuntu 8.04 and/or 10.04 (or was it 7.04). A pain in the ass on Debian Lenny, but the successive fixes for the failures were more logical.

  9. #19
    Join Date
    Aug 2011
    Posts
    62

    Default

    I've found a good account on how to run fglrx on a radeon 4800 in ubuntu 12.10
    Support has been dropped from AMD, so what you can try is downgrading the Xorg server. See there on comment number 71 :

    http://blog.linuxmint.com/?p=2216

    I stick to nvidia GPUs, as even when a GPU gets put in a legacy status, the driver is frozen but updated for newer Xorg servers and fixing critical bugs (if there were any). So the 7600GT I now run is good to go till 2017 (then, I could stick do a distro version of year 2017 for a few years if I still want to run it)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •