Results 1 to 9 of 9

Thread: X1400 problems

  1. #1
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Thumbs down X1400 problems

    I've been having major problems with my laptop and ATI drivers... It's a Dell 6400 (E1505) with a X1400 card (and C2D cpu).

    Afaik the only working driver for me is 8.28.8. The versions before that do not work for me as my current kernel is not supported i guess (I'm running SLED10 with extra's added). Every higher version just will not budge!

    How do I install the fglrx driver? --> --buildpkg SuSE/SLED10-IA32; rpm -Uhv blabla... When trying my old xorg.conf or just simply trying to run Sax2 I get the following error:
    Code:
    <snip>
    (EE) fglrx(0): PreInitDAL failed
    (EE) fglrx(0): PreInit failed
    <snip>
    (EE) Screen(s) found, but none have a usable configuration.
    
    Fatal server error:
    no screens found
    I've been searching around for a solution, but nothing helps. I always have to go back to 8.28.8 for X to work...
    It's bugging me as hell, cos I've seen phoronix runs his test on a X1400, so I know that every release SHOULD work.

    Am I missing something? Why doesn't sax2 even work?

    Should I at my xorg.conf in a code block? (I've tried removing modlines for newer releases btw).

  2. #2

    Default

    I haven't used SuSE in a while, but can you post your xorg.conf? I have seen this problem before, just now I just need to remember what I did to correct it .

    Actually, if my memory serves me, try running aticonfig --initial --force as root and then reboot. Sax2 may be the cause with the configuration.

  3. #3
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    My xorg.conf:
    Code:
    Section "Files"
      FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    <SNIP>
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
    EndSection
    
    Section "Module"
      Load         "dbe"
      Load         "type1"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
      Load         "v4l"
      Load         "dri"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "pc104"
      Option       "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
      Driver       "synaptics"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Emulate3Buttons" "on"
      Option       "InputFashion" "Mouse"
      Option       "Name" "Synaptics;Touchpad"
      Option       "Protocol" "explorerps/2"
      Option       "SHMConfig" "on"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[3]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "ImPS/2 Generic Wheel Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  352 220
      HorizSync    30-78
      Identifier   "Monitor[0]"
      ModelName    "LCD MONITOR"
      Option       "DPMS"
      VendorName   "___"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    Section "Screen"
      DefaultDepth 24
      SubSection "Display"
        Depth      16
        Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "$
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "$
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    Section "Device"
      BoardName    "MOBILITY RADEON X1400 (M54 7145)"
      BusID        "1:0:0"
      Driver       "fglrx"
      Identifier   "Device[0]"
      Option       "FSAAMSPosY0" "0.000000"
      Option       "FSAAMSPosX1" "0.000000"
      Option       "Stereo" "off"
      Option       "FSAAScale" "1"
      Option       "FSAAMSPosY4" "0.000000"
      Option       "CapabilitiesEx" "0x00000000"
      Option       "no_dri" "no"
      Option       "PseudoColorVisuals" "off"
      Option       "FSAAMSPosX0" "0.000000"
      Option       "FSAAMSPosX2" "0.000000"
      #Option       "NoDDC"
      Option       "FSAAMSPosY5" "0.000000"
      Option       "VideoOverlay" "on"
      Option       "OpenGLOverlay" "off"
      Option       "KernelModuleParm" "locked-userpages=0"
      Option       "CenterMode" "off"
      Option       "no_accel" "no"
      Option       "FSAADisableGamma" "no"
      Option       "FSAAMSPosX4" "0.000000"
      Option       "FSAAMSPosY2" "0.000000"
      Option       "FSAAMSPosX5" "0.000000"
      Option       "UseInternalAGPGART" "no"
      Option       "mtrr" "off"
      Option       "StereoSyncEnable" "1"
      Option       "FSAAMSPosY3" "0.000000"
      Option       "FSAAMSPosY1" "0.000000"
      Option       "FSAAMSPosX3" "0.000000"
      Option       "ForceGenericCPU" "no"
      Option       "Capabilities" "0x00000000"
      Option       "UseFastTLS" "0"
      Option       "DesktopSetup" "Clone"
      Option       "HSync2" "31-48"
      Option       "ForceMonitors" "auto,crt1"
      Option       "Mode2" "1024x768"
      Option       "GammaCorrectionI" "0x00000000"
      Option       "SaXDualHSync" "31-48"
      Option       "SaXDualHead" ""
      Option       "SaXDualMode" "Clone"
      Option       "SaXDualMonitorModel" "1024X768@60HZ"
      Option       "SaXDualMonitorVendor" "--> VESA"
      Option       "SaXDualOrientation" "LeftOf"
      Option       "SaXDualResolution" "1024x768"
      Option       "SaXDualVSync" "50-60"
      Option       "VRefresh2" "50-60"
      Option       "GammaCorrectionII" "0x00000000"
      Option       "FSAACustomizeMSPos" "no"
      Option       "ScreenOverlap" "0"
      Option       "BlockSignalsOnLock" "on"
      Option       "FSAAEnable" "no"
      VendorName   "ATI"
    EndSection
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      InputDevice  "Mouse[3]" "SendCoreEvents"
      Option       "Clone" "off"
      Option       "Xinerama" "off"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    
    Section "Extensions"
    EndSection
    I tried removing the different modlines:
    in device, in monitor, the modes block.

    I'll try the command tonight and see whether it will work...
    I find my xorg.conf very messy, I;ve been using this one for ages and added some crap in to solve some old problems with XGL. Perhaps a lot can be deleted, but I'm not sure what.

  4. #4
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Still the same
    Preinit(dal) failed

    Got any more ideas? I just cant believe this.... bleh! Phoronix, could you perhaps post your Xorg.conf so that I could try that one?

  5. #5

    Default

    Code:
    # T60 X1400
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Synaptics" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "type1"
        Load  "freetype"
        Load  "dri"
        Load  "glx"
    EndSection
    
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option        "XkbModel" "pc105"
        Option        "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
        Identifier  "Synaptics"
        Driver      "synaptics"
        Option        "Device" "/dev/input/mice"
        Option        "Protocol" "auto-dev"
        Option        "Emulate3Buttons" "yes"
    EndSection
    
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option        "Composite" "disable"
    EndSection

  6. #6
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Isnt that the default xorg.conf (after rpm install) and after running "aticonfig --initial"? Ifso, i've tried that as well, to no avail

    What could be the problem that ONLY 8.28.8 works :?
    Could it be a hardware thing (combo of X1400 with a certain mobo, etc)? If it is a software thing, I'll hold on a week or two/three, till my new 7200RPM hdd arrives and I can do a complete SuSE reinstall (this time with 10.2).

    thnx for the help.
    Ati...... *sigh*

  7. #7

    Default

    Did you try regenerating the packages? Had you tried 8.33.6?

  8. #8
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    Yup, rebuild, 8.33.6. All the same... I find it very odd.

  9. #9
    Join Date
    Jan 2007
    Location
    NL
    Posts
    13

    Default

    *update on this issue*

    For people who want to use "newer" fglrx drivers (all _after_ 8.28) with SuSE, there is a workaround... Found it on a novell bugzilla list (and is now also found on opensuse wiki):

    the drivers work perfectly when you boot up with framebuffer disabled. Just delete the "vga=XXXX" part in the grub boot list. After reboot, you can install as usual, and configure with sax2 (-r -m 0=fglrx).
    Last edited by gavro; 02-03-2007 at 09:35 AM. Reason: typo's

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •