Results 1 to 10 of 10

Thread: how to disable 2d color tiling?

  1. #1
    Join Date
    Nov 2007
    Posts
    1,353

    Default how to disable 2d color tiling?

    Hey guys, got steam installed correctly. But I seem to be having corruption in the gui. It is all garbled and messed up.... So I ran from the command line and got this message. But It's not just steam, I come to realize that it is all 3d applications. However glxgears seems to run properly, and even compiz seems to run good. But any game that I start or 3d screensaver i get this exact samwe problem.

    Code:
        radeon: The kernel rejected CS, see dmesg for more information.
    OK, checked dmesg and this is what it had to say....

    Code:
        [43006.708381] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43006.708384] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
        [43006.708386] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43006.721341] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43006.721344] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
        [43006.721346] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43006.738022] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        4300638025] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
        [43006.738027] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43006.755002] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43006.755006] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
        [43006.755007] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43006.771554] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43006.771558] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
        [43006.771559] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43006.838297] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43006.838301] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
        [43006.838302] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43007.909628] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43007.909631] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 1148
        [43007.909633] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
        [43010.946440] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
        [43010.946444] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    This link here suggests that it is a regression from 2d color tiling. I have xorg-server, mesa, libdrm, llvm, xf86-video-ati all installed from git as of today (12-21-2012), and the 3.8-rc1 kernel installed. And the problem persists.... The only thing I can think of doing is disabling 2d tiling, but I can't find any documentation on how to do that.

    Any help would be appreciated thanks guys.

    http://www.serverphorums.com/read.php?12,506952
    Last edited by duby229; 12-22-2012 at 10:39 PM.

  2. #2
    Join Date
    Feb 2008
    Location
    Linuxland
    Posts
    4,725

    Default

    Option "ColorTiling" "boolean"

    man radeon -> search for tiling

  3. #3
    Join Date
    Dec 2007
    Posts
    2,273

    Default

    Option "ColorTiling2D" "False"

    I suspect what is happening is that you are running a 32-bit application on a 64-bit distro and you have an old out of date 32-bit 3D driver. Make sure you update the 32-bit 3D driver.

  4. #4
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    hmmm, ok that is an interesting concept. I'm not sure what you mean by 32bit 3d driver though. Are you refering to the libs in this package on gentoo, emul-linux-x86-opengl?

    OK, to clarify, I did disable color tiling 2d and now everything seems to be working well. also downgraded to stable packages for gentoo and everything still seems to be working good.
    Last edited by duby229; 12-23-2012 at 11:19 AM.

  5. #5
    Join Date
    Dec 2007
    Posts
    2,273

    Default

    Quote Originally Posted by duby229 View Post
    hmmm, ok that is an interesting concept. I'm not sure what you mean by 32bit 3d driver though. Are you refering to the libs in this package on gentoo, emul-linux-x86-opengl?
    If you want to run 32-bit 3D apps on a 64-bit distro, you also have to compile a 32-bit version of the 3D driver. 32-bit apps require 32-bit libs. The name of the package will vary depending on the distro. I'm not familiar with how gentoo deals with that.

  6. #6
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    the 3d driver is in mesa right? so if I get the latest mesa and build 32bit package that will include the 3d driver?

  7. #7
    Join Date
    Dec 2007
    Posts
    2,273

    Default

    Quote Originally Posted by duby229 View Post
    the 3d driver is in mesa right? so if I get the latest mesa and build 32bit package that will include the 3d driver?
    Yes, that's correct.

  8. #8
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    Found a guide that allows to do exactly what you said Alex,

    Will try it and let know if it worked well or not. Thank you for your patience.

    http://www.linuxsystems.it/2012/05/g...tilib-overlay/

  9. #9
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    I couldnt get those instructions to work. It is a nasty hack, I got all sorts of build problems, plus I dont want git, just the current stable version. So I think The only option I have left to me is to file a bug reports on gentoo's bugzilla requesting that they update emul-linux-x86-opengl with a new enough mesa to to support the default features of the radeon driver.

    I think it may be possible to build a mesa package in a 32bit chroot, then write an ebuild to install it to lib32 on the real 64bit root, but that is a bit over my head.

  10. #10
    Join Date
    Nov 2007
    Posts
    1,353

    Default

    Just an update to this thread.... I got emul-linux-x86-opengl updated to a version which contains mesa 9.0 and all is working well even with ColorTiling2D enabled.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •