Results 1 to 9 of 9

Thread: how do i exclude a test in "suite-definition.xml"

Hybrid View

  1. #1
    Join Date
    Oct 2012
    Posts
    20

    Default how do i exclude a test in "suite-definition.xml"

    Hi,

    I have defined a test-suite "suite-definition.xml"

    Code:
    <Execute>
        <Test>pts/cpu</Test>
      </Execute>
      <Execute>
        <Test>pts/disk</Test>
      </Execute>
      <Execute>
        <Test>pts/memory</Test>
      </Execute>
    one test is hanging and i have to kill the process or it just runs forever...
    the test name is tscp-1.0.0
    how do i exclude it in my "suite-definition.xml" file?

    thank you.

  2. #2

    Default

    Quote Originally Posted by Yaniv View Post
    Hi,

    I have defined a test-suite "suite-definition.xml"

    Code:
    <Execute>
        <Test>pts/cpu</Test>
      </Execute>
      <Execute>
        <Test>pts/disk</Test>
      </Execute>
      <Execute>
        <Test>pts/memory</Test>
      </Execute>
    one test is hanging and i have to kill the process or it just runs forever...
    the test name is tscp-1.0.0
    how do i exclude it in my "suite-definition.xml" file?

    thank you.
    The easiest way would be to just delete it from the XML file.

  3. #3
    Join Date
    Oct 2012
    Posts
    20

    Default

    Hello Michael,

    the problem is that "pts/tscp" is part of the "pts/cpu"

    Code:
    ./phoronix-test-suite info pts/cpu                                                                                   
                                                                                                                                                                 
                                                                                                                                                                 
    Phoronix Test Suite v4.0.1                                                                                                                                   
    CPU / Processor Suite                                                                                                                                        
                                                                                                                                                                 
    Run Identifier: pts/cpu-1.2.0                                                                                                                                
    Suite Version: 1.2.0                                                                                                                                         
    Maintainer: Michael Larabel                                                                                                                                  
    Suite Type: Processor                                                                                                                                        
    Unique Tests: 25
    Suite Description: This test suite contains tests designed to test the system's CPU / processor.
    
    pts/cpu-1.2.0
      * pts/padman
      * pts/etqw-demo
      * pts/graphics-magick
      * pts/john-the-ripper
      * pts/ttsiod-renderer
      * pts/compress-pbzip2
      * pts/compress-7zip
      * pts/encode-mp3
      * pts/encode-flac
      * pts/x264
      * pts/ffmpeg
      * pts/openssl
      * pts/gcrypt
      * pts/himeno
      * pts/pgbench
      * pts/apache
      * pts/c-ray
      * pts/povray
      * pts/smallpt
      * pts/tachyon
      * pts/crafty
      * pts/tscp
      * pts/mafft
      * pts/npb
      * pts/stream

    this feature is very good and saves time... just define
    Code:
    <Execute>
        <Test>pts/cpu</Test>
      </Execute>
    and cpu tests are running...

    because i have in my xml file "pts/cpu" i can not remove "pts/tscp"....

    is there some workaround?

    Thank You
    Last edited by Yaniv; 12-05-2012 at 10:05 AM.

  4. #4

    Default

    You could set environment variable: SKIP_TESTS=tscp

    It should work like that otherwise SKIP_TESTS=pts/tscp

  5. #5
    Join Date
    Oct 2012
    Posts
    20

    Default

    Quote Originally Posted by Michael View Post
    You could set environment variable: SKIP_TESTS=tscp

    It should work like that otherwise SKIP_TESTS=pts/tscp
    where do i set this?
    in the xml file?

  6. #6

    Default

    Quote Originally Posted by Yaniv View Post
    where do i set this?
    in the xml file?
    environment variable from your terminal.

  7. #7
    Join Date
    Oct 2012
    Posts
    20

    Default

    Quote Originally Posted by Michael View Post
    You could set environment variable: SKIP_TESTS=tscp

    It should work like that otherwise SKIP_TESTS=pts/tscp

    tested both variables. and confirmed they are exported...
    both result in the following PTS error. and the tests did not run at all.

    Code:
    [NOTICE] Undefined: run_object in pts_test_run_manager.php:1450
    PHP Fatal error:  Call to a member function get_identifier_base_name() on a non-object in /root/phoronix-test-suite/pts-core/objects/client/pts_test_run_manager.php on line 1450
    Solution
    remove the pts/tscp definition from this file...
    Code:
    ../test-suites/pts/cpu-1.2.0/suite-definition.xml
    in this file are all pts/cpu tests defined.

  8. #8

    Default

    Thanks for the report about the error, it's been fixed in Git.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •