Results 1 to 5 of 5

Thread: glesx.so init causes sig 11

  1. #1
    Join Date
    Jan 2008
    Posts
    3

    Default glesx.so init causes sig 11

    Just swapped in an new HD2600 XT (AGP version) and tried installing the latest driver using: ati-driver-installer-8-01-x86.x86_64.run
    on Debian's 2.6.22-3-686 kernel in "testing".

    Install log looks good. And, after reboot, X loads up nicely until the very end when glesx.so causes a signal 11 during initialization:
    ...
    9: /usr/lib/xorg/modules//glesx.so [0xb581aa1c]
    10: /usr/lib/xorg/modules//glesx.so(esutInit+0x74) [0xb5819294]
    11: /usr/lib/xorg/modules//glesx.so [0xb5813f6d]
    12: /usr/lib/xorg/modules//glesx.so(GlesxExtensionInit+0x94) [0xb5814234]
    13: /usr/bin/X11/X(InitExtensions+0x85) [0x80f6885]
    14: /usr/bin/X11/X(main+0x2bf) [0x8076c6f]
    15: /lib/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb7d24450]
    16: /usr/bin/X11/X(FontFileCompleteXLFD+0x1e9) [0x80761b1]

    xorg.conf is minimal, deleted all my old stuff and used "aticonfig --initial".

    Searching around here for other problems with this card and glesx.so, I tried turning off a couple of options:
    Option "Textured2D" "off"
    Option "TexturedXrender" "off"
    but they didn't help.

    Is this worth a bug report? Does ATI pay any attention to them?

  2. #2
    Join Date
    Dec 2007
    Posts
    90

    Default

    I'm amazed you got this far at all.
    I have the same chipset AGP card and all I get is a hang when trying to use the fglrx version you mention (or any other for that matter).
    I use x86_64 Ubuntu/7.10 on a dual core AMD4800+ system with a VIA K8T800 chipset-based motherboard.

    What are the specs of your CPU / motherboard / Linux distro?

    -edit- P.S. I have 4 GB of RAM (the max my board will support) and suspect my driver hang might be due to a chipset or MTRR memory mapping issue.
    I tried all AGP aperture settings that my mainboard BIOS will allow.

  3. #3
    Join Date
    Jun 2007
    Posts
    406

    Default

    Quote Originally Posted by Swoopy View Post
    I'm amazed you got this far at all.
    I have the same chipset AGP card and all I get is a hang when trying to use the fglrx version you mention (or any other for that matter).
    I use x86_64 Ubuntu/7.10 on a dual core AMD4800+ system with a VIA K8T800 chipset-based motherboard.

    What are the specs of your CPU / motherboard / Linux distro?

    -edit- P.S. I have 4 GB of RAM (the max my board will support) and suspect my driver hang might be due to a chipset or MTRR memory mapping issue.
    I tried all AGP aperture settings that my mainboard BIOS will allow.
    if you think that it's a mtrr problem then add:
    Option "mtrr" "off"
    to your device section in xorg.conf.

  4. #4
    Join Date
    Jan 2008
    Posts
    3

    Default

    Quote Originally Posted by Swoopy View Post
    I'm amazed you got this far at all.
    I have the same chipset AGP card and all I get is a hang when trying to use the fglrx version you mention (or any other for that matter).
    I use x86_64 Ubuntu/7.10 on a dual core AMD4800+ system with a VIA K8T800 chipset-based motherboard.

    What are the specs of your CPU / motherboard / Linux distro?

    -edit- P.S. I have 4 GB of RAM (the max my board will support) and suspect my driver hang might be due to a chipset or MTRR memory mapping issue.
    I tried all AGP aperture settings that my mainboard BIOS will allow.
    Debian "testing" with Debian's 2.6.22-686 kernel or my own 2.6.23.14 kernel. Same CPU as you but with an nvidia NForce3 chipset. But agpgart uses the amd64_agp module, the cpu based agp that interfaces with chipset based agp. When I tried using a chipset only based module (nvidia_agp) with agpgart, fglrx wouldn't hang: there would just be a message about no "internal" agp support for 2.6 kernels and there would be no 3-D. Never tried any bios settings. Here's agp messages in log for V2.6.23.14:
    kernel: Linux agpgart interface v0.102
    kernel: agpgart: Detected AGP bridge 0
    kernel: agpgart: Setting up Nforce3 AGP.
    kernel: agpgart: AGP aperture is 64M @ 0xf8000000

    But now I've got this new glesx.so problem.
    Last edited by blaz; 01-29-2008 at 12:28 PM.

  5. #5
    Join Date
    Jan 2008
    Posts
    3

    Default Bug #939

    Looks like this bug has already bit someone:
    http://ati.cchtml.com/show_bug.cgi?id=989
    I tried the 256 MB agp aperture and no longer get this segfault. But it looks like I now some other problems. Increasing the aperture size doesn't really fix things, just moves the problem around. Time to look at radeonhd I guess.
    Last edited by blaz; 01-29-2008 at 07:25 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •