Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: There's Another Linux Kernel Power Problem

  1. #1
    Join Date
    Jan 2007
    Posts
    15,103

    Default There's Another Linux Kernel Power Problem

    Phoronix: There's Another Linux Kernel Power Problem

    After last year discovering a major Linux kernel power regression that was widely debated until the Phoronix test automation software bisected the problem to get to the bottom of the situation, there's more active power regressions today on the Linux desktop. As I've mentioned on Twitter and in other articles in weeks prior there's a few regressions, but one of them for at least some notebooks is causing a very significant increase in power consumption. This situation that remains unresolved as of the Linux 3.7 kernel can cause the system to be going through about 20% more power.

    http://www.phoronix.com/vr.php?view=18242

  2. #2
    Join Date
    Dec 2008
    Posts
    150

    Default

    ...due to single-handedly writing hundreds of articles per month...
    Perhaps you should try writing with both hands. I hear typing is much faster that way...

  3. #3
    Join Date
    Nov 2012
    Posts
    149

  4. #4
    Join Date
    Dec 2011
    Posts
    7

    Default

    Quote Originally Posted by jwilliams View Post
    Perhaps you should try writing with both hands. I hear typing is much faster that way...
    good one

  5. #5
    Join Date
    Apr 2010
    Posts
    1,946

    Default

    Michael +100 karma points.

    I think its indeed may have sense to outsource some of the editorial work and concentrate on articles about own projects, like this one.
    Thanks, Michael!

  6. #6
    Join Date
    Sep 2007
    Location
    Connecticut,USA
    Posts
    964

    Default

    Quote Originally Posted by crazycheese View Post
    Michael +100 karma points.

    I think its indeed may have sense to outsource some of the editorial work and concentrate on articles about own projects, like this one.
    Thanks, Michael!
    Good idea, maybe get help from the knowledgeable posters here to help with bisecting or running further tests?

  7. #7
    Join Date
    Dec 2012
    Posts
    38

    Default

    Given that 3.7 lacks drops that the others have, maybe it's a cpuidle regression?

    Or maybe the scheduler is migrating cores too much, not keeping all the cores at a higher frequency than they would normally be? Can easily check that with perf. I did see http://klaig.blogspot.com/2012/12/fo...-can-make.html today, but the versions listed aren't consistent with this, though perhaps there was a minor regression in 3.6 that was amplified by some change in 3.7.

  8. #8
    Join Date
    Jun 2011
    Posts
    10

    Default Not sure if this is the same thing but,

    I have been testing 3.7 since the rc1, and later in the development I started noticing power issues on my Asus X53E with the Sandy Bridge graphics. I finally noticed that powertop 2.1 would report the GPU running 100 percent of the time, and the exhaust was running hot also. I checked the DMESG, and it did show that the i915 kernel module was enabling the sleep states, but obviously it wasn't working..

    normally a reboot of the laptop would temporarily fix the issue, least until I tried booting the unit cold again..

    only other issue is that 3.6 and 3.7 don't seem to work right with reboots, and power off, I have to manually turn it off with the switch. 3.5 doesn't have any of these issues.

    when running 3.7 without the gpu bugging, I am getting much better power usage, normally idles under 8 watts, where normally I get 8.2 watts according to powertop or the gnome power monitor.

  9. #9
    Join Date
    Nov 2011
    Posts
    286

    Default

    Quote Originally Posted by Lederhosen View Post
    I have been testing 3.7 since the rc1, and later in the development I started noticing power issues on my Asus X53E with the Sandy Bridge graphics. I finally noticed that powertop 2.1 would report the GPU running 100 percent of the time, and the exhaust was running hot also. I checked the DMESG, and it did show that the i915 kernel module was enabling the sleep states, but obviously it wasn't working..

    normally a reboot of the laptop would temporarily fix the issue, least until I tried booting the unit cold again..

    only other issue is that 3.6 and 3.7 don't seem to work right with reboots, and power off, I have to manually turn it off with the switch. 3.5 doesn't have any of these issues.

    when running 3.7 without the gpu bugging, I am getting much better power usage, normally idles under 8 watts, where normally I get 8.2 watts according to powertop or the gnome power monitor.
    Has this been reported to the kernel developers?

    ...
    I guess this doesn't affect me, as I have 1 AMD Neo-based laptop & 1 Atom N270.

  10. #10
    Join Date
    Dec 2012
    Posts
    1

    Default

    Quote Originally Posted by Ibidem View Post
    Has this been reported to the kernel developers?

    ...
    I guess this doesn't affect me, as I have 1 AMD Neo-based laptop & 1 Atom N270.

    I believe it's related to this one: oddly enough, no solution yet.

    But right yesterday I found another issue in the 3.6.x kernels which prevents PCIE ASPM to be enabled when on battery power... at least on my laptop.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •