I'v been struggling many days for the display issue on my system(PowerPC based) with ATI Radeon Graphics card. Much appreciation if anyone can help me out or guide me how to solve the problem.

Here's more details:

My system is Ubuntu 12.04, powerpc architecture.
My kernel is compiled on 3.4.20, tried different options related to graphics support ( like DRM, framebuffer, etc, but with all possibilities tried out, the results the same)

lspci will give below results:

0001:01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV380 [Radeon X600 (PCIE)]
0001:01:00.1 Display controller: Advanced Micro Devices [AMD] nee ATI RV380 [Radeon X600]

dmesg will got below results:

udevd[1108]: starting version 175
170 Adding 3951984k swap on /dev/sda2. Priority:-1 extents:1 across:3951984k
171 EXT3-fs (sda3): using internal journal
172 init: udev-fallback-graphics main process (1990) terminated with status 1
173 init: plymouth main process (1055) killed by SEGV signal
174 init: plymouth-splash main process (1993) terminated with status 2
175 init: plymouth-log main process (2009) terminated with status 1

My xorg.conf file and Xorg.0.log is attached as well, along with a complete dmesg log file.

In brief, Xorg is fail to find any device/screen to start.

I really get crazy on this problem. Please help me.

(BTW, I was told that the xserver-xorg-video-ait/radeon package don't support some ATI cards on ubuntu 9.04 or later, is that true?
I'm tring to install non-apt package named xf86-video-ati-6.14.0, is that a right approach?)

log for dmesg: dmesglog.txt

log for Xorg.0.log: Xorg.0.log_part1.txtXorg.0.log_part2.txt

xorg.conf : xorg.conf.txt