Results 1 to 5 of 5

Thread: Capping Frame Rate to Refresh Rate on a Intel GMA X3500

  1. #1
    Join Date
    Oct 2011
    Location
    Rural Alberta, Canada
    Posts
    1,017

    Default Capping Frame Rate to Refresh Rate on a Intel GMA X3500

    My brother is trying to play some classic Unreal Engine 1 games on his Lenovo 3000 N200 laptop with an Intel GMA X3500 GPU but is having issues due to the fact the games are running to fast, making them amusingly unplayable. My desktop machine which has a Diamond Radeon HD 4670 does not have this problem as I am using the R600 Gallium3D drivers and they are capping the game's frame rate at my screen's refresh rate. So, even though my machine is more capable it is not playing the games too fast even though the weaker Intel is. Is there anyway to activate a smiliar functionality with the Intel drivers? He is running Fedora 17 with the stock drivers provided with the distribution.

  2. #2
    Join Date
    May 2007
    Location
    Third Rock from the Sun
    Posts
    6,582

    Default

    You should be able to limit the frame rate in the game settings.

    http://forums.beyondunreal.com/showp...45&postcount=2

  3. #3
    Join Date
    Oct 2011
    Location
    Rural Alberta, Canada
    Posts
    1,017

    Default

    That requires separate third-party renderers and I do not know if they work with the Linux versions of Rune or UT99, which are the games he is trying to play.

    Games are running fantastically on my radeon.

  4. #4
    Join Date
    Oct 2011
    Location
    Rural Alberta, Canada
    Posts
    1,017

    Default

    Okay, the problem with UT99 seems strangely to have been with the sound. Got it working on proper OSS rather than ALSA OSS emulation using my little script here and it is fine:

    Code:
    #!/bin/sh
    #
    # OSS Startup Script
    # Created by Hamish Paul Wilson
    # July 23, 2012
    #
    # Move to /etc/profile.d/
    #
    
    modprobe snd-pcm-oss
    However, Rune is still going like a bat out of hell.

  5. #5
    Join Date
    Oct 2011
    Location
    Rural Alberta, Canada
    Posts
    1,017

    Default

    Unfortunately that odd solution was in fact too odd - the actual reason it worked then was because we had Firefox open in the background. I would still like to find a better solution to this problem though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •