Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Amd CCC...nexuiz... and X full CPU...but glxgears fix the problem?!

  1. #1
    Join Date
    Dec 2007
    Posts
    12

    Default Amd CCC...nexuiz... and X full CPU...but glxgears fix the problem?!

    Hi folks.... I finally managed to get (a little) work fglrx in my fedora...I had conflicts between runlevels..

    but now I have another problem..

    after boot, if I run the amd/ati control panel or a game....nothing happen... with top I see that X is at 84 % CPU and GLXINFO HI cpu usage too...

    for unlocking the problem, I just run GLXGEARS and all works....

    what happen? How to fix this issue?

    I'm using the fglrx 8.44 by livna... same problem with 8.45 (livna) and official installer...

    kernel: 2.6.23.14-107

    Code:
    # Xorg configuration created by livna-config-display
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    EndSection
    
    Section "ServerFlags"
    	Option	    "AIGLX" "on"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "it"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "fglrx"
    #	Option	    "AGPMode" "8"
    	Option	    "RenderAccel" "on"
    	Option	    "XAANoOffscreenPixmaps"
    	Option	    "ColorTiling" "on"
    	Option	    "OpenGLOverlay" "off"
    	Option	    "VideoOverlay" "on"
    Option "AGPFastWrite" "on"
    Option "EnablePageFlip" "true"
    
    
    Option "UseFastTLS" "0"
    Option "BlockSignalsOnLock" "on"
    Option "ForceGenericCPU" "off"
    Option "KernelModuleParm" "locked-userpages=0"
    
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Extensions"
    	Option	    "Composite" "Enable"
    EndSection

  2. #2
    Join Date
    Aug 2007
    Posts
    6,622

    Default

    That error is in every driver since 8.41.7 and Xserver 1.4. If you use an older driver (with -ignoreABI override) then it works without that problem.

  3. #3
    Join Date
    Dec 2007
    Posts
    12

    Default

    Quote Originally Posted by Kano View Post
    That error is in every driver since 8.41.7 and Xserver 1.4. If you use an older driver (with -ignoreABI override) then it works without that problem.
    please explain better....

    where to put that string???

  4. #4
    Join Date
    Aug 2007
    Posts
    6,622

    Default

    Depends on the DM you use. Do you use KDM, GDM or whatever?

  5. #5
    Join Date
    Dec 2007
    Posts
    12

    Default

    Quote Originally Posted by Kano View Post
    Depends on the DM you use. Do you use KDM, GDM or whatever?

    gdm I use fedora like mom did it

  6. #6
    Join Date
    Aug 2007
    Posts
    6,622

    Default

    For Debian you would use this - I will not install Fedora:

    echo [server-Standard] >> /etc/gdm/gdm.conf
    echo command=/usr/bin/X -audit 0 -ignoreABI >> /etc/gdm/gdm.conf

    Also when you want to use 8.40.4 you will need this:

    http://mlau.at/files/fglrx-842-2623.patch
    Last edited by Kano; 01-29-2008 at 06:17 PM.

  7. #7
    Join Date
    Dec 2007
    Posts
    12

    Default

    tnx for your reply... but doesn't work for me...


    tried also ignoreabi in other ways (tnx google ) but nothing to do

  8. #8
    Join Date
    Jun 2007
    Location
    Albuquerque NM USA
    Posts
    349

    Default

    Same here (I see problem, Kano's fix doesn't work...unless I'm screwing it up which is possible). Ubuntu 8.04 (alpha-2).

    I'd test it on my production machine running 7.10 except it has radeonhd, which I trust more than fglrx.

  9. #9
    Join Date
    Dec 2007
    Posts
    12

    Default

    so.....the only solution is running glxgears at every xorg start? WOW great fglrx driver -_-"

  10. #10
    Join Date
    Aug 2007
    Posts
    6,622

    Default

    That fix is for using 8.40.4 or older. My fglrx script has it included. As long as your xorg.conf has already a driver fglrx statement you can execute it for testing with -v 8.39.4 or -v 8.40.4 as options. It does not yet work with those pure default xorg.conf files.

    http://kanotix.com/files/install-fglrx-debian.sh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •