Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 45

Thread: R600 Gallium3D Getting Close On OpenGL 3.3 Support

  1. #21
    Join Date
    Nov 2008
    Location
    Old Europe
    Posts
    904

    Default

    Quote Originally Posted by agd5f View Post
    Both 3D and rotation are working. You just have to use glamor and a pre-1.13 xserver at the moment until the issues with xserver 1.13 are sorted out.
    Does it work with zaphod configurations now?

  2. #22
    Join Date
    Nov 2011
    Location
    Orange County, CA
    Posts
    71

    Default

    Quote Originally Posted by agd5f View Post
    Both 3D and rotation are working. You just have to use glamor and a pre-1.13 xserver at the moment until the issues with xserver 1.13 are sorted out.
    I just rebuilt everything and it still doesn't work for me.
    Could somebody check what I'm doing wrong?
    xorg.conf.d: http://pastebin.com/7yzcnFtT
    Xorg.0.log: http://pastebin.com/AepK2XDq
    build_radeonsi.sh: http://pastebin.com/HZGhh0fq

    Basically what I do is (some of this may be redundant but I never checked what exactly I need):
    Download/build/install 3.8 kernel from git://people.freedesktop.org/~airlied/linux origin/drm-next branch
    Download/build/install LLVM from git://people.freedesktop.org/~tstellar/llvm
    Download/build/install entire stack with git://anongit.freedesktop.org/git/xorg/util/modular util/modular
    Download/build/install xorg-server-1.11.4 from tarball with --enable-glx-tls --enable-xorg --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
    Download/build/install git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati with --enable-gallium-radeon --with-egl-platforms=x11,drm --enable-glamor
    Download/build/install git://anongit.freedesktop.org/mesa/mesa with --with-dri-driverdir=$PREFIX/lib/dri --with-egl-platforms=x11,drm --with-gallium-drivers=swrast,r300,r600,radeonsi --enable-gbm --enable-shared-glapi --enable-glx-tls --with-dri-drivers=radeon
    Download/build/install git://anongit.freedesktop.org/git/mesa/drm
    Download/build/install git://anongit.freedesktop.org/git/xorg/driver/glamor with --enable-glx-tls

    kdmrc has
    ServerCmd=/opt/xorg/bin/X -verbose 9 -logverbose 9 -configdir /opt/xorg/share/X11/xorg.conf.d

    and I'm still getting
    [ 1169.968] (WW) RADEON(0): Direct rendering disabled
    [ 1169.968] (II) RADEON(0): Acceleration disabled

  3. #23
    Join Date
    Nov 2011
    Location
    Orange County, CA
    Posts
    71

    Default

    P.S. LLVM settings are
    ./configure --prefix=/usr/local --enable-experimental-targets=R600 --enable-optimized --cache-file=/dev/null --srcdir=.

  4. #24
    Join Date
    Aug 2008
    Location
    Tokyo, Japan
    Posts
    36

    Default

    Quote Originally Posted by rrohbeck View Post
    [ 1169.968] (II) RADEON(0): Acceleration disabled
    Looks like it's not picking up Option "AccelMethod" "glamor". I think maybe the xorg.conf.d/ snippets must be named *.conf, or it might be easier to just put it in /etc/X11/xorg.conf.

    BTW, this sort of problem report should rather go to a relevant mailing list.

  5. #25
    Join Date
    Nov 2008
    Location
    Madison, WI, USA
    Posts
    860

    Default

    Quote Originally Posted by rrohbeck View Post
    I just rebuilt everything and it still doesn't work for me.
    Could somebody check what I'm doing wrong?
    xorg.conf.d: http://pastebin.com/7yzcnFtT
    Xorg.0.log: http://pastebin.com/AepK2XDq
    build_radeonsi.sh: http://pastebin.com/HZGhh0fq

    Basically what I do is (some of this may be redundant but I never checked what exactly I need):
    Download/build/install 3.8 kernel from git://people.freedesktop.org/~airlied/linux origin/drm-next branch
    Download/build/install LLVM from git://people.freedesktop.org/~tstellar/llvm
    Download/build/install entire stack with git://anongit.freedesktop.org/git/xorg/util/modular util/modular
    Download/build/install xorg-server-1.11.4 from tarball with --enable-glx-tls --enable-xorg --disable-dmx --disable-xvfb --disable-xnest --disable-xwin
    Download/build/install git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati with --enable-gallium-radeon --with-egl-platforms=x11,drm --enable-glamor
    Download/build/install git://anongit.freedesktop.org/mesa/mesa with --with-dri-driverdir=$PREFIX/lib/dri --with-egl-platforms=x11,drm --with-gallium-drivers=swrast,r300,r600,radeonsi --enable-gbm --enable-shared-glapi --enable-glx-tls --with-dri-drivers=radeon
    Download/build/install git://anongit.freedesktop.org/git/mesa/drm
    Download/build/install git://anongit.freedesktop.org/git/xorg/driver/glamor with --enable-glx-tls

    kdmrc has
    ServerCmd=/opt/xorg/bin/X -verbose 9 -logverbose 9 -configdir /opt/xorg/share/X11/xorg.conf.d

    and I'm still getting
    [ 1169.968] (WW) RADEON(0): Direct rendering disabled
    [ 1169.968] (II) RADEON(0): Acceleration disabled


    IIRC: You need to rebuild mesa with the --enable-glx-tls and the other options BEFORE you build xf86-video-ati. When I've seen glamor guides in the past, they basically recommended MESA -> GLAMOR -> xf86-video-ati. The xf86-video-ati configure log might also be useful here.

  6. #26
    Join Date
    Nov 2011
    Location
    Orange County, CA
    Posts
    71

    Default

    Quote Originally Posted by Veerappan View Post
    IIRC: You need to rebuild mesa with the --enable-glx-tls and the other options BEFORE you build xf86-video-ati. When I've seen glamor guides in the past, they basically recommended MESA -> GLAMOR -> xf86-video-ati. The xf86-video-ati configure log might also be useful here.
    That didn't change anything. But maybe the new fglrx will work for me, I'll try it now.

  7. #27
    Join Date
    Dec 2007
    Posts
    2,315

    Default

    Quote Originally Posted by rrohbeck View Post
    That didn't change anything. But maybe the new fglrx will work for me, I'll try it now.
    Have you fixed your configuration so that the accelmethod option is actually picked up by the xserver?

    Option "AccelMethod" "glamor"

  8. #28
    Join Date
    Nov 2011
    Location
    Orange County, CA
    Posts
    71

    Default

    Quote Originally Posted by agd5f View Post
    Have you fixed your configuration so that the accelmethod option is actually picked up by the xserver?

    Option "AccelMethod" "glamor"
    Yes, the current Device section is
    /opt/xorg/share/X11/xorg.conf.d/50-Device:Section "Device"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Identifier "HD7850"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Driver "ati"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "AccelMethod" "glamor"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: BusID "PCI:6:0:0"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-HDMI-0" "S273HL1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:# Option "Monitor-DVI-1" "S273HL2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DVI-0" "Shimian"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-0" "QNIX1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-1" "QNIX2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:EndSection

  9. #29
    Join Date
    Nov 2011
    Location
    Orange County, CA
    Posts
    71

    Default

    Quote Originally Posted by rrohbeck View Post
    Yes, the current Device section is
    /opt/xorg/share/X11/xorg.conf.d/50-Device:Section "Device"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Identifier "HD7850"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Driver "ati"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "AccelMethod" "glamor"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: BusID "PCI:6:0:0"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-HDMI-0" "S273HL1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:# Option "Monitor-DVI-1" "S273HL2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DVI-0" "Shimian"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-0" "QNIX1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-1" "QNIX2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:EndSection
    I uploaded the latest xorg.conf.d to http://pastebin.com/hFMbKNWK

  10. #30
    Join Date
    Dec 2007
    Posts
    2,315

    Default

    Quote Originally Posted by rrohbeck View Post
    Yes, the current Device section is
    /opt/xorg/share/X11/xorg.conf.d/50-Device:Section "Device"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Identifier "HD7850"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Driver "ati"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "AccelMethod" "glamor"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: BusID "PCI:6:0:0"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-HDMI-0" "S273HL1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:# Option "Monitor-DVI-1" "S273HL2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DVI-0" "Shimian"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-0" "QNIX1"
    /opt/xorg/share/X11/xorg.conf.d/50-Device: Option "Monitor-DisplayPort-1" "QNIX2"
    /opt/xorg/share/X11/xorg.conf.d/50-Device:EndSection
    Is it actually getting picked up by the xserver however? Previously it was not. Can you post your xorg log? It would be easier to track all of this if you opened a bug:
    https://bugs.freedesktop.org

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •