Quote Originally Posted by varikonniemi View Post
Now only if the Ubuntu drivers update tool would offer anything newer than nvidia-experimental (310 series).
Yeah I'm starting to get a bit despondent about the situation there.

I think part of the problem is that there's now a separation between GeForce 8 series and up and older models. So I guess it's not a matter of just updating the X-Swat PPA anymore.

But even the 310 series in Jockey is actually the beta release, rather than the stable release that went out over a month ago.

meh ubuntu