Results 1 to 7 of 7

Thread: Noob question here but I need a 100% absolutely positive answer to this

  1. #1
    Join Date
    Jul 2012
    Posts
    2

    Default Noob question here but I need a 100% absolutely positive answer to this

    I'm not too familiar with proprietary driver installation on Linux. I used to just use the old OSS drivers but due to more demand for performance I switched. I've been using AMD GPUs (no flame war intended, so please refrain from the urge...) for nearly my whole life on both WIndows and Linux, but on Linux, uninstalling drivers to install new ones isn't as easy as it is on Windows, obviously.

    So what is the 100% foolproof way of uninstalling the Catalyst driver (in my case, Catalyst 12.11 beta 11) and then having it be barebones again so that I may install the new one that apparently just came out, Catalyst 13.11?

    Can someone give me the absolute answer? Everything I've seemed to find online just makes my terminal report back with "No existing blah blah blah" and stuff like that.

  2. #2
    Join Date
    Aug 2012
    Posts
    245

    Default

    Well, depending on distribution, you could use the package manager to remove it if you installed by packages(if they were either created from downloaded driver or they wrre from official/unofficial repositories ..).
    Some distros offer auto updating packages(but update a little slower than the driver on AMD's site obviously so you don't bother much with it.
    If you have installed it by package manager .. It depends on the package manager.
    For example if you have Ubuntu or a deriverative(Linux Mint etc.) it is "sudo apt-get remove --purge fglrx*". Or find all installed fglrx packages on synaptic and choose to remove with configuration files and apply. (Likely similar on debian)
    You could something similar to the later with most graphical package managers, but you might have to search for Catalyst instead of fglrx(it's the same thing though). Like packagekit for Fedora or Arch, etc.(Or "sudo pacman -Rdd <<list of catalyst packages separated by spaces here>>" for Arch)
    If you installed manually with no package manager involved at all(no deb or rpm packages generated from driver installer or from distribution repos), then the following command SHOULD work:
    "sudo sh /usr/share/ati/fglrx-uninstall.sh"
    I can't tell you from 100% sure, cause I have refrained from manual installation as much as I could and I would advise you the same when a package manager method is available.
    For example the Arch Linux wiki says the following:
    "Warning: Using the installer from ati.com/amd.com is not recommended! It may cause file conflicts and X failures and you will miss Arch-specific fixes. You must be familiar with booting to the command-line if you wish to attempt this."

    Also, to check if you're running Catalyst/fglrx correctly you can run the "fglrxinfo" command. If it doesn't show any error etc, it's running. If it's not found you likely don't have it installed at all.
    As for foolproof, I'm not sure what you expect exactly. Just make sure that after removal the is no xorg.conf file(/etc/X11/xorg.conf), because it might be left behind and instruct the system to use fglrx, which won't be present. Assuming you want radeon to take over afterward.(For Ubuntu, removing with config files(or purge) should do that for you.)
    In distros like Arch you'd have to reinstall a few packages again to get radeon back.

    Naming your distribution and method of installation you used for the driver would help of course..

  3. #3
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,383

    Default

    Yep, the most important thing is to uninstall it the same way you installed it, ie if you installed a package then use the package manager to uninstall, and if you installed manually then follow the uninstall instructions in the installation notes.

  4. #4
    Join Date
    Jul 2012
    Posts
    2

    Default

    In reply to both of you guys: neither of those terminal codes work. When I try and run the uninstaller script (I am using the one from AMD's official site, on Ubuntu 12.04 x64), it says some files were already moved or altered. It says this exactly...

    "One or more files have been altered since installation.
    Uninstall will not be completed. See /etc/ati/fglrx-uninstall.log for details."

    That file, btw, doesn't exist.

    What the hell do I do now? D: I ALWAYS encounter this shitty issue. It's getting old.

  5. #5
    Join Date
    Oct 2007
    Location
    Toronto-ish
    Posts
    7,383

    Default

    A bit of background would help. How did you install the driver in the first place ?

  6. #6
    Join Date
    Jun 2008
    Location
    Melbourne
    Posts
    209

    Default

    You'll have to use the force flag:

    /usr/share/ati/fglrx-uninstall.sh --force

    Most likely what has happened is that the /etc/ati/signature file has been changed to remove the watermark.

  7. #7
    Join Date
    Aug 2012
    Posts
    245

    Default

    The above post should be the one for you.
    I'd suggest that you use the package manager method next time.
    In case you decide to do so, you can go to "Software Sources" in Ubuntu through system settings or search for it, and from there you'll find a tab regarding drivers, where there should be three choice, the opensource driver, the fglrx that was released at the date that version of Ubuntu was released and one that is updated regularly to match the latest(non-beta) version of fglrx.
    Also you can install manually if you want the latest version as soon possible, but choose to make packages from the install and instead use those. There are instructions available if you need. Actually, after you see the interface of the driver, you can just choose "Generate distribution specific packages", continue and choose your distro and version (Ubuntu Quantal/12.10 in this case). Then install those. Either through command line (type the following in a terminal "sudo dpkg -i /path/to/folderwithpackages/*.deb" or "cd /path/to/folderwithpackages/" and then "sudo dpkg -i *.deb" ) or double click and do it through Software Center, or GDebi etc.(Haven't tried and wouldn't really suggest the later.)
    At last, you could find a ppa that provides the latest version as well.
    Also, to be sure, run "sudo aticonfig --initial -f --adapter=all" at the end to make a valid xorg.conf file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •