Page 5 of 6 FirstFirst ... 3456 LastLast
Results 41 to 50 of 52

Thread: AMD Legacy Catalyst 13.1 for HD2000-4000 is out

  1. #41
    Join Date
    Aug 2009
    Posts
    16

    Default

    Thanks Andy_v. Yes, that's why I highlighted that bit; the radeon & fglrx modules shouldn't be loaded or used simultaneously. The fglrx installer or aticonfig usually take care of blacklisting the radeon module & generating the xorg.conf, but since it can't find a supported adaptor it doesn't do so.

    I've also tried extracting & patching the fglrx installer, but I'm probably just beating a dead donkey trying to get this to work without the fglrx driver being fixed properly by AMD. I'll keep trying things & look into those links you provided, Andy_v, thank you.

    Bridgman, if there are any AGP hotfix patches I could test for you I'd be very happy to do so , or if you need any more system details just let me know.
    Last edited by mr_marmalade; 02-23-2013 at 05:32 PM.

  2. #42
    Join Date
    Aug 2012
    Posts
    245

    Default

    So the problem boils down to amdconfig not detecting the graphics card for some reason it seems ... :/

  3. #43
    Join Date
    Aug 2007
    Posts
    6,613

    Default

    Use control file from 12-4 driver and put it into /etc/ati.

  4. #44
    Join Date
    Aug 2009
    Posts
    16

    Default

    Hi Kano, that seems to have worked to an extent. Thank you! The fglrx driver seems to be running, but it is very slow.

    Code:
    zippy@ZIPPY:~$ fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: ATI Radeon HD 4600 Series  
    OpenGL version string: 3.3.11672 Compatibility Profile Context
    
    zippy@ZIPPY:~$ fgl_glxgears 
    Using GLX_SGIX_pbuffer
    144 frames in 5.0 seconds = 28.800 FPS
    214 frames in 5.0 seconds = 42.800 FPS
    215 frames in 5.0 seconds = 43.000 FPS
    Hmm, now its running a bit better. I changed KDE from XRender to OpenGL. It still seems a bit laggy but I'll play around some more. Thanks.

    Disabling desktop effects speeds things up further, now getting over 1260fps in fgl-gears. There're some pauses in desktop responsiveness, I didn't have this with Debian Squeeze. Hmm, further investigation to do!
    Last edited by mr_marmalade; 02-27-2013 at 12:19 PM.

  5. #45
    Join Date
    Mar 2013
    Posts
    1

    Default Flash performance down the drain?

    Hello people, first time poster here, and sorry to interrupt the thread.
    Installed the 13.1 legacy stuff, on Debian, working REALLY nicely with steam..

    BUT, flash video playback just became unbearable! less than 5fps on youtube/comedy central/pretty much anything. This is unfortunately a deal breaker, thus after messing half a day around with steam, I had to revert back to the open source drivers.

    Anybody experienced this? What gives??

    Cheers people!

  6. #46
    Join Date
    May 2009
    Location
    Toulouse (France)
    Posts
    40

    Default amd legacy with wine

    I've installed the amd legacy driver from debian experimental on a "debian wheezy + graphic stack from kanotix", and I can confirm native steam/TF2 works like a charm.
    my problem is that fglrx+wine (steam civ5) hang my display after a while... the computer is still alive cause from the console I can kill my wine processes.

    for now, I've the choice between opensource driver that is rock stable but slow, or flgx legacy that is now stable enough...
    that why I still need a crapy dual boot.

    does someone knows if the new fglrx drivers for new cards (hd 7750 for eg) is more stable ? cause I'm looking for changing my old card.

    regards

  7. #47
    Join Date
    May 2009
    Posts
    80

    Post

    Quote Originally Posted by jery View Post
    I've installed the amd legacy driver from debian experimental on a "debian wheezy + graphic stack from kanotix", and I can confirm native steam/TF2 works like a charm.
    my problem is that fglrx+wine (steam civ5) hang my display after a while... the computer is still alive cause from the console I can kill my wine processes.

    for now, I've the choice between opensource driver that is rock stable but slow, or flgx legacy that is now stable enough...
    that why I still need a crapy dual boot.

    does someone knows if the new fglrx drivers for new cards (hd 7750 for eg) is more stable ? cause I'm looking for changing my old card.

    regards
    Well my card is Radeon HD4850 and the performance with kernel 3.8 and mesa 9.2git(from xorg-edgers ubuntu ppa) is a lot better than it ever was with Catalyst. Team fortress 2 runs and most important of all it runs STABLE while resolution being the legendary "full hd" 1920x1080 with high details + 2xMSAA and the whole game just plays very smoothly around 40-60+ fps most of the time. Also I can play skyrim through wine finally with all the high details and yadda yadda... All in all if you can by all means just try mesa 9.1 and up with latest kernel before switching card. You wont regret it! What happened between mesa 9.0 and now is just amazing performance vice, so congrats to devs too! I was kind of giving up hope but this thing just SCREAMS NOW!

  8. #48
    Join Date
    May 2009
    Location
    Toulouse (France)
    Posts
    40

    Default

    I'm already running MESA 9.1 (from kanotix repository), and a 3.8.x kernel (from debian experimental)... and my hd4650 with OSS driver is really not as fast as it is with fglrx...

  9. #49
    Join Date
    Feb 2009
    Posts
    8

    Default AutoApt

    Quote Originally Posted by Goodolandy View Post
    I hope this will be incorporated in to the "Additional Drivers" Ubuntu utility because that has always been the only way I have ever gotten the ATI driver installed. I have tried over 20 times over the years and two more times with the latest 13.1 and have had ZERO success.

    If someone has had success in creating the Ubuntu 12.10 installer for this recent driver, I would love to get it from you. The installer always says it was successfull only to say on the next screen that there are errors.
    https://help.ubuntu.com/community/AutoApt

    auto-apt run ./<cmd>...

    I use it to solve dependency/missing problems...

  10. #50
    Join Date
    Apr 2013
    Posts
    108

    Thumbs down it does not work

    I have ati hd Radeon 4250, and I have tried to install it in too many different distros (ubuntu 12.04 with kernel 3.5 and 3.8, ubuntu 12.10, ubuntu 13.04 (following all the tutorials in the web, doing the xorg downgrade to 1.12, etc), chakra, manjaro, opensuse, linux mint 14, elementary os with kernel 3.8, etc) and I cant install it, wen I restart te pc just appear a black screen than make me to reinstall the distro again. Now I am using mesa 9.2, and works good, but not enought for steam linux games

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •