Quote Originally Posted by gigaplex View Post
Ribbonsoft did NOT deliberately remove compatibility with later versions of the GPL by taking away the 'or later' clause from GPLv2.
Yes they did, if you do not include 'or, later' then the licence is de facto incompatible with future versions or the GPL, not including the 'or later' clause is a deliberate choice to keep the code GPLv2 ONLY.

Quote Originally Posted by gigaplex View Post
So please, refrain from calling me a moron for my inability to read. If a project is GPL v2 without specifying "or later" it is by default incompatible with GPL v3.
Of course it is, since it's then GPLv2 ONLY, how could it possibly be compatible with GPLv3? That is why the FSF include the 'or later' clause in the source code they release, as do the majority of other developers licencing their code under the GPL. The most notable exception is obviously Linux which is is GPLv2 only.