Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Amd Hd 3850 Agp

  1. #11
    Join Date
    Feb 2008
    Location
    Perth
    Posts
    11

    Default

    Thanks for the update. Did you see notable performance gains moving to the 3850?

    A shame about the chip failure.

    Cheers.
    D.

    Quote Originally Posted by Swoopy View Post
    As an update to my earlier post there,
    I have now been running my 2600 XT AGP just fine under Linux with 3D support since the release of Catalyst 8-5 (so mid-May) and my discovery of the mem=xxxxMB kernel boot parameter (it runs Doom3, Homeworld, GoogleEarth and other OpenGL stuff).
    Recently I purchased an upgrade to a 3850 AGP.

  2. #12
    Join Date
    Dec 2007
    Posts
    90

    Default

    Quote Originally Posted by tenzero View Post
    Thanks for the update. Did you see notable performance gains moving to the 3850?

    A shame about the chip failure.

    Cheers.
    D.
    All the measurements I was able to do in the short time were glxgears and fgl_glxgears .... (stand-alone & running them simultaneously)
    Based upon that, I would guesstimate the 3850 AGP to have been about 1.5x to 2.5x faster than my 2600XT AGP (both with 512 MB GDDR3 memory on-board).
    Side-note: my 2600XT AGP is the H.I.S. IceQ Turbo overclocked edition (so overclocked in hardware, e.g. even in Linux, rather than via the Windows driver)
    so performance gains coming from a "normal" 2600XT or Pro may be slightly bigger.

    I use mostly Windows XP for gaming and therefore graphical benchmarking (The few Linux OpenGL apps/games I mentioned are what I can use / play when my PC is booted into Linux doing other stuff in the background which is the common situation most of the time)
    Unfortunately Windows Service Pack 3 broke my XP install (no, I do not have the AMD + Intel power management driver issue, it's much worse)
    so I couldn't benchmark for want of having to re-install XP.

    All in good time, assuming I get a working 3850 AGP back rather than my money ....

  3. #13

    Default

    Quote Originally Posted by dokers View Post
    I have the 3850 AGP and so far I have not had much luck with it in Ubuntu 8.04 alpha 6, about the only thing that works is the VESA driver and not that well. Hopefully support for this will come soon! If anyone can get it working with something other than VESA, let me know!
    I had to jump through hoops to get my agp x1950 working in linux. Maybe the 3850 is the same?

  4. #14
    Join Date
    Mar 2008
    Posts
    10

    Default

    Quote Originally Posted by alexforcefive View Post
    I had to jump through hoops to get my agp x1950 working in linux. Maybe the 3850 is the same?
    UPDATE, The 8.5 Catalyst works fine for me on the AGP 3850. But anything newer than that doesn't, when I run fglrxinfo I get:

    fglrxinfo: ../../src/xcb_io.c:350: _XReply: Assertion `!dpy->xcb->reply_data' failed.
    Aborted

    I've spent a lot of time searching, tried removing dkms, all references to old kernels and old fglrx and still no luck. If anyone has a good suggestion, let me know, but so far everyting I've tried is useless.

  5. #15
    Join Date
    Jul 2008
    Posts
    3

    Default

    I just got my 3850 card (AGP) working with the guide from http://wiki.cchtml.com/index.php/Ubu...allation_Guide and the 8.5 driver. Even a skilled monkey could do this... Now if only I had an Island like in the good ol days. anyway in the past and with "Envy" I newer got it to work... 3d but no accel I always use PPracer as real world test software.

  6. #16
    Join Date
    Mar 2008
    Posts
    10

    Default

    Quote Originally Posted by abracat View Post
    I just got my 3850 card (AGP) working with the guide from http://wiki.cchtml.com/index.php/Ubu...allation_Guide and the 8.5 driver. Even a skilled monkey could do this... Now if only I had an Island like in the good ol days. anyway in the past and with "Envy" I newer got it to work... 3d but no accel I always use PPracer as real world test software.
    Where you able to get it working with anything newer than 8.5? I've tried and failed. I'm convinced this card will never work with anything but this one driver!

  7. #17
    Join Date
    Jul 2008
    Posts
    3

    Default

    Quote Originally Posted by dokers View Post
    Where you able to get it working with anything newer than 8.5? I've tried and failed. I'm convinced this card will never work with anything but this one driver!
    I haven't tried... The main question is why the wouldn't work though. the guide is really great. for people on low-range machine I only got 1.5 GB of ram the main issue seems to be AGP-detection since your AGP card typicly comes close to a PCI card with an AGP port. I would strongly recommmend turning composite and AIGXL off since i don't need 3d-glitter I only need 3d-games to run/accel. And my succes with 3d-glitter has been very limited.

    If any one got succes experience with a later driver or with radeonhd xorg beta (mesa 7.1) and 3d for games I would be a happy camper / but I guess that one is even more tricky

  8. #18
    Join Date
    Jan 2008
    Posts
    294

    Default

    Quote Originally Posted by dokers View Post
    Where you able to get it working with anything newer than 8.5? I've tried and failed. I'm convinced this card will never work with anything but this one driver!
    My 3850 AGP works OK with 8.6 and 8.7 - I haven't got a clue what's breaking for you.

    I am running 32 bit LFS using xorg 7.2 kernel 2.6.24.2.

  9. #19
    Join Date
    Nov 2008
    Posts
    1

    Default

    Quote Originally Posted by dokers View Post
    Where you able to get it working with anything newer than 8.5? I've tried and failed. I'm convinced this card will never work with anything but this one driver!
    Hi,

    I recently installed my AGP HD3850 on SuSE 10.2 using the update catalyst version 8.10.

    In summary I can state:
    I have NEVER EVER EVER experienced such a simple grafics card installation with linux. I followed precisely AMD's install instruction, 15 min later and everything worked great, including 3D Games / OpenGL apps etc...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •