Results 1 to 3 of 3

Thread: ATI 8.44.3 - OpenGL Performance issues ??

  1. #1
    Join Date
    Feb 2008
    Posts
    2

    Default ATI 8.44.3 - OpenGL Performance issues ??

    Hello,

    Good evening!

    I run Fedora 8 (32-bit) on a Fujitsu Siemens Amilo M1425 Laptop which uses an ATI Mobility Radeon 9700 with a dedicated graphics memory of 128 MB.

    After upgrading to the AMD ATI Proprietary linux driver 8.44.3 (Catalyst 7.12), I have found that there seems to be a problem with OpenGL performance.

    Hardware rendering functions well, and I get frame rates of over 3000 with "glxgears", but when I use the OpenGL select mode (Render mode GL_SELECT), and then repeatedly call the "glLoadName(...)" function while generating a mesh, the entire system freezes up with the processor racing to 100% load with even relatively small meshes...

    I have not had this issue with earlier versions of the driver....in-fact, this particular scenario used to be faster on the ATI laptop, than on desktops running nVidia Graphics cards.

    Is anyone aware of such performance issues with the proprietary drivers?? And would anyone have any suggestions for work-arounds ?

    Have a nice day!

    Philippose

  2. #2
    Join Date
    Feb 2008
    Posts
    2

    Default

    Hello again,

    Just to give some more information regarding the first post...

    Yesterday I had to uninstall the ATI Proprietary drivers from my system because there was no matching driver package for the latest kernel update.

    Once I uninstalled the driver, I tried the same software again (this time running on software rendering, using the default fallback driver linux uses), and the GL_SELECT mode worked like a dream... extremely fast!

    Today I installed the ATI drivers again, and well, as expected... GL_SELECT went back to being excruciatingly slow...

    So I guess it has been confirmed that there is a bug in the current ATI Catalyst 7.12 driver version.

    I wonder if there is any change in the Catalyst 8.01 version...

    Philippose

  3. #3
    Join Date
    Feb 2008
    Posts
    4

    Default

    Quote Originally Posted by philippose View Post
    I wonder if there is any change in the Catalyst 8.01 version...
    Nope -- everything since 7.12 is stuffed, until 8.3. I haven't tested 8.4.

    See

    http://www.it.usyd.edu.au/~tapted/slow_glselect.html

    It is good news that the open source drivers seem to be performant for you -- I should run some tests on them too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •