I am getting some rather infuriating problems after upgrading a machine to Fedora 18. While the Radeon HD 2400 card that was in the machine worked fine with Fedora 17, I am now experincing instability and 3D crashes when running games such as Quake 3. The hardware itself is still fine as it worked before and I booted up a session of SuperGamer Supreme 2.5 and everything was working fine with the Catalyst drivers. I manaaged to grab the following output after one of the graphical crashes on the Radeon HD 2400:


I also tried using the on-board AMD 760G (ATI Radeon 3000) chipset on the motherboard and it experinced simliar problems, although it was able to recover from them after a short lockup and keep playing until the next lockup, and then recover again, etc. Still annoying, but not nearly as bad.

I also tried taking the Radeon HD 4670 from my machine and placing it in his board which did fix the crashes, meaning that it looks like it may be geneartion specific (I had some problems with a version of Deus Ex not texturing properly in WINE on all three cards, but I am not sure if that is a driver issue or an issue with WINE). I had also played Postal 2 from a live-session on the Radeon HD 4670 when it was in my machine and that worked without a hitch,

Here is the driver information for the Radeon HD 2400: