Hi there.
I'm bloody desperate newbie in graphic programming and I need help. My graphic card support only OpenGL 2.1 and GLSL 1.2 and I need to use some functionality of newer GLSL, so I wanted to use mesa and its software rendering. I tried to set environment variables, change packages, but whatever I did, it throw error

GLSL 1.30 is not supported. Supported versions are: 1.00 ES, 1.10, and 1.20

Probably it's some my idiocy, but it's for my university project, deadline in coming and as I said, I'm desperate now
I use Debian wheezy and its official mesa packages.
Thanks for any help...