Page 6 of 6 FirstFirst ... 456
Results 51 to 60 of 60

Thread: AGP users, UNITE!!!!

  1. #51
    Join Date
    Nov 2007
    Posts
    35

    Default

    Quote Originally Posted by NeoBrain View Post
    Just for record, 8.02 doesn't work with 3d accel, too.
    Just wondering but what Distro are you running. I think you said Gentoo at one point. Make sure you have your AGP chipset driver complied into your kernel. Had a problem recently after a reinstall and I couldn't figure out why then I realized I never complied support for my agp chipset into my kernel.

  2. #52
    Join Date
    Dec 2007
    Location
    Germany
    Posts
    365

    Default

    Quote Originally Posted by Compxpert
    Just wondering but what Distro are you running. I think you said Gentoo at one point. Make sure you have your AGP chipset driver complied into your kernel. Had a problem recently after a reinstall and I couldn't figure out why then I realized I never complied support for my agp chipset into my kernel.
    Yes, I am using Gentoo, but I have already tried with givemesuggar and bridgman to figure some way to make it work, without success however.
    I decided to just don't care about it and stay with 8.43 and wait until a functional release comes out, but I just thougt I should post my "AGB ATI experiences" anyways

  3. #53
    Join Date
    Oct 2007
    Posts
    39

    Default

    Hey yo!! Thought I would post up my results from trying the new 8.02 fglrx driver on my gentoo box. Didn't work, so I'm back to radeon, but this was what I found:

    I have a Gigabyte Radeon X800 XT Platinum Edition
    Samsung 193P LCD (1280x1024 @ 75Hz)
    MSI K8N Neo2 Platinum (nForce 3 Ultra)
    Athlon 64 X2 4800+
    1GB gSkill TCCD
    Gentoo running the gentoo kernel version 2.6.24-r1
    Using Xorg 7.3
    Ati driver 8.55.2 (8.02)
    AIGLX did work after a little tweaking

    I found that firefox scrolling was better, but not great. Running fgl_glxgears gave me the same unbearable corruption seen here:
    http://www.phoronix.com/forums/showt...5092#post25092

    Could be related to my running compiz-fusion with the GTK decorator, but I generally run AIGLX for the compiz windowmanager, so it needs to work ....



    I can tell sligh improvements are being made so far, but so much is broken and the open source driver is working so well that I have no reason to switch. My only complaint with the open source driver and compiz is tearing in videos, but it's alot better than the total lack of video support in the fglrx driver.

  4. #54
    Join Date
    Nov 2007
    Posts
    12

    Default

    Hi,

    I have/had also the issue with the AGP Rialto Bridge on my hardware configuration, but today I could get it to work.

    In the past I tried much things (change some settings in xorg.conf, in BIOS like AGP Aperture Size ....) to find a workaround agains the black sreen with frozen system during X start with fglrx (7.12 and later) enabled - but nothing has worked.

    The only possibility was to blacklist "via_agp" module in "/etc/modprobe.d/blacklist" but then I got no Xv extension and no 3D acceleration.

    Then (today) after installation of 8.45.5 from ATI OpenSuSE 10.3 repository and the same black screen (via_agp loaded), I tried "aticonfig --max-gart-size 512" and "bingo!" my system starts now with 8.45.5 and 3D acceleration (include Xv) enabled. My current setting for "AGP Aperture Size" in BIOS is 128MB and I believe that 256MB also works for me, but I have there no possibility to set values bigger than 256MB.

    Important: Use "aticonfig --max-gart-size 512" to set/change manual the value, because this add/change the entry in /etc/ati/amdpcsdb and not in xorg.conf !

    Athlon XP 2400+
    ASUS A7V133 (VIA KT133A)
    768MB SD-RAM
    Sapphire X1650 Pro AGP DDR3
    Kernel : 2.6.22.17-0.1
    Distribution: OpenSuSE 10.3

    Spooky
    Last edited by Spooky; 02-23-2008 at 08:23 AM.

  5. #55
    Join Date
    Dec 2007
    Posts
    85

    Default

    I wonder if this trick would work for an HD2600 pro AGP card????

    Did anybody else try?

  6. #56

    Default A possible fix for X86_64 users

    I have been lurking in these forums for some time looking for a fix for my Sapphire X1650 which is running on an AMD 64 dual core.
    I saw the previous post and thought I'd give February's ATI offering a try.
    I haven't had a working driver since the first AIGLX enabled version which worked but did not enable the interrupts.
    On earlier drivers using the XGL server I could get my card working with the MaxAtiGart option but I only put it in the xorg.conf.

    So I gave the new driver a try and managed to get a running Xserver but just with a mouse pointer and nothing else. A good deal better than a hard lockup. I took a look at the X log and it showed that the interrupts were being enabled so I decided to try a few things.

    One thing I have always noticed at the start of my X log is that the internal agpgart is not used because IOMMU is enabled in the kernel. So I though Ok I'll recompile the kernel without it so I set that to work and Googled around for some info on iommu's. Basically these are hardware address redirectors. The kind of device designed to throw driver writers into confusion. During my search I came across some boot options for X86_64 kernels. It seems I didn't need to recompile my kernel I could just turn iommu off. Investigating the options further I discovered that there is an option to prevent the iommu from remapping the agp aperture. I added the following to my kernel boot line "iommu=noaperture" and set the bios to give the full 512MB of aperture.
    Reboot startx and Voila' I have a working driver with glxgears at 950 fps not blisteringly fast but at least usable (I had 1200 with the xgl server).
    I know someone on this forum has a direct line to one of the ATI developers so perhaps they could relay this as it is certainly a fix for 64 bit machines. Alas those with 32 bit boxes probably won't get any joy I don't think they have iommu's but I could be wrong so check your X start-up log.

    Colin Close
    Last edited by itchka@compuserve.co; 02-26-2008 at 10:05 PM.

  7. #57
    Join Date
    Dec 2007
    Posts
    85

    Default

    That is very interesting itchka. Very nice research. I will try some of those trick with my hd 2600 pro

    Maybe it will do the trick

  8. #58
    Join Date
    Dec 2007
    Posts
    90

    Default

    Quote Originally Posted by itchka@compuserve.co View Post

    One thing I have always noticed at the start of my X log is that the internal agpgart is not used because IOMMU is enabled in the kernel. So I though Ok I'll recompile the kernel without it so I set that to work and Googled around for some info on iommu's. Basically these are hardware address redirectors. The kind of device designed to throw driver writers into confusion. During my search I came across some boot options for X86_64 kernels. It seems I didn't need to recompile my kernel I could just turn iommu off. Investigating the options further I discovered that there is an option to prevent the iommu from remapping the agp aperture. I added the following to my kernel boot line "iommu=noaperture" and set the bios to give the full 512MB of aperture.
    Reboot startx and Voila' I have a working driver with glxgears at 950 fps not blisteringly fast but at least usable (I had 1200 with the xgl server).

    I know someone on this forum has a direct line to one of the ATI developers so perhaps they could relay this as it is certainly a fix for 64 bit machines. Alas those with 32 bit boxes probably won't get any joy I don't think they have iommu's but I could be wrong so check your X start-up log.

    Colin Close
    Just for completeness' sake in response to Colin's excellent detailed post:

    I have been booting my system with the "iommu=noaperture" setting almost since I installed Ubuntu 7.10 64-bit on my AMD 64x2 dual-core. This was part of solving the "desktop app pause" issues I was having. I was running with an nVidia 6600GT card at the time.

    On my PC, in normal linux boot mode it's on, in recovery mode it's left out. I have tried every fglrx that was released since 7.10 and NONE worked on my system (VIA K8t800pro chipset) and video card (ATI HD2600XT AGP 512 MB).

    Not that I have a desire to disappoint fred but I am almost certain that "iommu=noaperture" is not the 'magic bullet' for fglrx with Radeon HD2xxx AGP cards

    -edit-: yes and I also did try fglrx a couple of times when booted in normal mode with no kernel boot-options included. Just to be sure that iommu wasn't set to noaperture by default when booting in recovery mode.
    My full boot-options in "normal" boot are :
    Code:
    ro quiet splash nodmraid notsc noapic nolapic acpi=strict iommu=noaperture
    Last edited by Swoopy; 02-27-2008 at 04:09 AM.

  9. #59
    Join Date
    Dec 2007
    Posts
    85

    Default

    Well I just hope that the next driver release will include support for agp version of the Hd2XXX family. Because right now I'm runing my computer with my old 9800 pro (wich work very well with the new driver) and my brand new HD2600 pro back in it's box.

  10. #60
    Join Date
    Apr 2008
    Posts
    4

    Default

    My system;
    ATI Technologies Inc Unknown device 94c4 (prog-if 00 [VGA controller]) (HD2400 AGP Based)
    CPU: AMD Athlon(tm) 64 Processor 2800+
    Host bridge: nVidia Corporation nForce3 250Gb Host Bridge
    OS FC7 and FC8

    I have been running this setup for a few months without any problems. But here the other day, I suddenly started experiencing problems, after changing som Bios settings (added a new sound card). After this the system suddenly froze after 1-2 minutes of system uptime. Changing the AGP Apeture in Bios up and down would change the amount of time before the system froze, but the system froze sooner or later. I found that changing the PCI VGA Palette Snoop in Bios (or whatever it is called) to disabled fixed the whole thing.

    I also noticed that changning AGP Aperture from 256 to 512 actually increased fgl_glxgears and glxgears with about 100 fps.

    glxgears abt 2690 fps
    fgl_glxgears abt 790 fps

    Nice to actually have improved the system

    Hope this can help someone.....



    morten

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •