Results 1 to 4 of 4

Thread: Why does amd say that fglrx _NEEDS_ multilib and 32bit libs, for the driver to work?

Hybrid View

  1. #1

    Default Why does amd say that fglrx _NEEDS_ multilib and 32bit libs, for the driver to work?

    Why does amd say that fglrx _NEEDS_ multilib and 32bit libs, for the driver to work?

  2. #2
    Join Date
    Jan 2013
    Location
    Ontario, Canada
    Posts
    92

    Default

    I don't think it actually does anymore, but not long ago, some of the programs were still 32 bit. That does not seem to be the case anymore, I just checked all mine and they are now all 64 bit binaries. In fact I just launched the AMD Catalyst Control Center for the first time. You made me check (I never cared much about that so never bothered again) and I'm glad to see that.

    It may also be that if you use the graphical installer provided with the AMD Catalyst Driver archive (i.e. not the facilities for making packages for your distro) that it may still require 32 bit libraries. That's the only reason I can think of that AMD might still say its required, because everything else seems to be 64 bit now. (Obviously any 32 bit compatibility OpenGL libraries couldn't be used without 32 bit system libraries but it would be a simple matter to detect and not install those if inappropriate. Last time I had an Nvidia card that was a choice with the nvidia installer)

    I don't do multilib on Linux, but when I first built this rig I thought I'd try Gentoo for a change, to have a source based distro. It required multilib for the ati driver ebuild, so I had to fix that. After I got tired of Gentoo and went back to Slackware, I found that I could roll up a Slackware package using the (--buildpkg switch when executing the .run file) and multilib wasn't needed. The control center program needed 32 bit libs at that time though, but that didn't matter.

  3. #3
    Join Date
    Sep 2010
    Posts
    716

    Default

    Installed fglrx from amd driver page, on Ubu12.10 and I did not needed any 32 libs... Now you get COMBINED driver installator. Which mean that you do not need to know if you run 32bit or 64bit setup. fglrx will install and work eitherway.

  4. #4
    Join Date
    Mar 2013
    Posts
    7

    Default

    Likely the combined blob looks for those as many of us run 32bit binaries and just expect things to work.

    no issue in having those installed (disk space is cheap no?). :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •