Results 1 to 2 of 2

Thread: Display problems, maybe du to EDID errors?

  1. #1

    Default Display problems, maybe du to EDID errors?

    Hi there,

    a friend of mine has problems with his NVIDIA graphics card: while the free 2D drivers are working without any problems (but with a bad performance) the proprietary drivers are not working properly: the screen is screwed up and only displays a white image with a coloured bar in the middle.

    I checked the X.Org log file and found a message reporting problems regarding the resolution and the EDID:
    Code:
    (WW) NVIDIA(GPU-0): The EDID read for display device DFP-0 is invalid: the
    (WW) NVIDIA(GPU-0):     checksum for EDID version 1 is invalid.
    
    [...]
    
    (WW) NVIDIA(0): No valid modes for "1280x800"; removing.
    (WW) NVIDIA(0): No valid modes for "1280x768"; removing.
    (WW) NVIDIA(0): No valid modes for "1024x768"; removing.
    (WW) NVIDIA(0): No valid modes for "1280x600"; removing.
    (WW) NVIDIA(0): No valid modes for "1024x600"; removing.
    (WW) NVIDIA(0): No valid modes for "800x600"; removing.
    (WW) NVIDIA(0): No valid modes for "768x576"; removing.
    (II) NVIDIA(0): Validated modes:
    (II) NVIDIA(0):     "640x480"
    (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
    (WW) NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI
    (WW) NVIDIA(0):     from DFP-0's EDID.
    (**) NVIDIA(0): DPI set to (48, 58); computed from "DisplaySize" Monitor
    (**) NVIDIA(0):     section option
    (==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
    At some places in the net (and here in the forum) it was mentioned that a fixed value for the EDID could help. But how can I set this fix value for the EDID in the xorg.conf?

    Some more information about the system in question: it is a Dell Laptop with a 15,4" screen and a main resolution of 1280x800. The graphics card is identified in the X-log file as:
    Code:
    (II) NVIDIA(0): NVIDIA GPU GeForce 8400M GS (G86M) at PCI:1:0:0 (GPU-0)
    (--) NVIDIA(0): Memory: 262144 kBytes
    (--) NVIDIA(0): VideoBIOS: 60.86.42.00.34
    (II) NVIDIA(0): Detected PCI Express Link width: 16X
    (--) NVIDIA(0): Interlaced video modes are supported on this GPU
    (--) NVIDIA(0): Connected display device(s) on GeForce 8400M GS at PCI:1:0:0:
    (--) NVIDIA(0):     DFP-0
    (--) NVIDIA(0): DFP-0: 330.0 MHz maximum pixel clock
    (--) NVIDIA(0): DFP-0: Internal Dual Link LVDS
    (II) NVIDIA(0): Assigned Display Device: DFP-0
    The distribution is an OpenSuse 10.3. The drivers are installed via the nvidia rpm packages for OpenSuse.

    I would add the full X.org log, alas I am not allowed to add attachments (yet).

  2. #2
    Join Date
    Aug 2007
    Posts
    6,645

    Default

    Usually you get that fallback only when a fake vga port is detected. If you have got 2 dvi connectors try the other one. Of course there are several override options for NV drivers too - i would use these (maybe only the 2nd):

    Option "UseEdidFreqs" "0"

    Option "ModeValidation" NoDFPNativeResolutionCheck"

    Maybe you ask in nvnews.net too, there are nv developers who could help you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •