There does not seem to be that much information about how to run radeonsi.
So I tried with my HD 7750 on (K)Ubuntu Raring, and documented what I did.

Since glamor is required, and it does not support the X version in Ubuntu, xorg-server has to be downgraded.
While running this process, I had to use a bit of force (dpkg --force-depends -P) to remove conflicting packages.
But in the end, apt is in a OK state.

1. Fetch, build and install debian xorg-server 1.12.4 (git://git.debian.org/git/pkg-xorg/xserver/xorg-server branch debian-unstable).

2. Blacklist xorg 1.13 in apt preferences, to prevent reinstallation.
Package: xserver-common
Pin: version 2:1.13*
Pin-Priority: -1

Package: xserver-xorg-core
Pin: version 2:1.13*
Pin-Priority: -1

Package: xserver-xorg-dev
Pin: version 2:1.13*
Pin-Priority: -1

3. Fetch mesa 9.1 (git://git.debian.org/git/pkg-xorg/lib/mesa branch ubuntu). Add --enable-gbm to debian/rules. Build and install.

4. Fetch glamor (git://anongit.freedesktop.org/git/xorg/driver/glamor). Configure and pay attention to missing dependencies manually, since there is no packaging (./configure --enable-glx-tls --prefix=/usr).
make install.

5. Fetch xf86-video-ati (git://git.debian.org/git/pkg-xorg/driver/xserver-xorg-video-ati branch ubuntu).
In debian/control remove the version dependency for xserver-xorg-dev. Also remove the dependencies on xserver-xorg-video-r128 and xserver-xorg-video-mach64 completely.
Build and install.

6. To get mouse/keyboard, I also had to rebuild xserver-xorg-input-evdev. If you use other drivers, those would also have to be recompiled.
Fetch xf86-input-evdev (git://git.debian.org/git/pkg-xorg/driver/xserver-xorg-input-evdev branch ubuntu). In debian/control remove the version dependency for xserver-xorg-dev.
Build and install.

Those where the minimal changes I was able to get it running with.
LLVM 3.2 in raring already has the r600g driver backported, and kernel 3.8 works.

I also tried latest LLVM git, Mesa git, and kernel 3.9-rc1+, but no significant differences.

KDE Desktop effects works.
Nexuiz runs at 22 fps at 1920x1200.
I thought I have Rochard running, but trying again just gives a black screen.
Torchlight immediately locks up the GPU, but the machine still responds over ssh.
Lightsmark 2008 completely freezes the machine after a few tests.

I could not test Trine, since it crashes the X server both with nouveau and radeonsi.