Alrighty, I finished making the packages The source code and packaging are available here: https://github.com/chenxiaolong/Fedora-Hybrid-Graphics

Instructions

1. Switch to the AMD/ATI card in the BIOS. This is just to prevent any crashes when you install xorg-x11-drv-catalyst-legacy.

2. Install xorg-x11-drv-catalyst-legacy just like from the link you posted (https://ask.fedoraproject.org/questi...gacy-chipsets/).

3. Reboot and make sure everything is fine.

4. Clone my git repo:

Code:
sudo yum install git rpmdevtools rpm-build wget
git clone https://github.com/chenxiaolong/Fedora-Hybrid-Graphics.git
cd Fedora-Hybrid-Graphics/
5. Install my patched Catalyst legacy drivers.

Code:
cd xorg-x11-drv-catalyst-legacy/
wget --inet4-only 'http://developer.amd.com.php53-23.ord1-1.websitetestlink.com/wordpress/media/2012/10/xvba-sdk-0.74-404001.tar.gz'
spectool -g xorg-x11-drv-catalyst-legacy.spec
sudo yum-builddep xorg-x11-drv-catalyst-legacy.spec
rpmbuild -bb xorg-x11-drv-catalyst-legacy.spec --define "_sourcedir $(pwd)" --define "_rpmdir $(pwd)"
sudo yum install ./x86_64/xorg-x11-drv-catalyst-legacy-*hybridgfx*.rpm
6. Install the hybrid-detect autoswitcher.

Code:
cd ../hybrid-detect-fglrx/
sudo yum-builddep hybrid-detect-fglrx.spec
rpmbuild -bb hybrid-detect-fglrx.spec --define "_sourcedir $(pwd)" --define "_rpmdir $(pwd)"
sudo yum install ./x86_64/hybrid-detect-fglrx-*.rpm
7. Reboot and enjoy graphics switching!

If anything goes wrong in the future (GUI not starting, etc.), try removing /var/lib/hybrid-detect/last_gfx_boot and then rebooting. That will force hybrid-detect to redetect which graphics card is enabled.

Please let me know if there are any issues