Results 1 to 6 of 6

Thread: virtualbox

  1. #1
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default virtualbox

    hi, i have kubuntu amd64 12.10 and virtualbox works with a kernel 3.5.0.
    i have download kernel 3.9.0-rc4 from kernel.org

    make-kpkg --rootcmd fakeroot --initrd kernel_image kernel_headers modules_image

    but after installation virtualbox write


    WARNING: The character device /dev/vboxdrv does not exist.
    Please install the virtualbox-ose-dkms package and the appropriate
    headers, most likely linux-headers-.

    You will not be able to start VMs until this problem is fixed.
    how fix this thanks.

  2. #2
    Join Date
    Jan 2013
    Posts
    1,096

    Default

    Google spits a few answers, when searching for "The character device /dev/vboxdrv does not exist"
    You tried them out?

  3. #3
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    yes,i not found my problem.
    i like compile kernel why not compile module virtualbox???? i not understand
    i not compile kernel /usr/src but in my download.
    with kernel 3.5.0 /dev/vboxdrv exist
    now try compile 3.9.0 rc4
    Last edited by Vincenzov; 03-25-2013 at 04:22 AM.

  4. #4
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    Kubuntu 13.04 with kernel build by me works. kernel 3.9.0 rc5
    I not understand :-)
    Last edited by Vincenzov; 04-01-2013 at 12:22 PM.

  5. #5
    Join Date
    Jan 2013
    Posts
    1,096

    Default

    Remove virtual box from your system.
    Go to oracle site and get their standalone .deb.
    Install deb.
    It should automatically pull dkms etc.

    Its cruicial to remove virtualbox first, because otherwise it might mess boot scripts (which is still correctable).

    I suggest this really has something to do with original kernel not building virtualbox module.
    At least, I had this problem now with Debian Testing and custom kernel.

  6. #6
    Join Date
    Oct 2011
    Location
    Italy
    Posts
    139

    Default

    thanks, now work good 13.04 e kernel 3.9.0 rc-5 :-) module dkms all ok
    Bye :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •